Jump to content
Sign in to follow this  
EArroyo

[SOLVED] Multiple IP addresses (macvlan)

5 posts in this topic Last Reply

Recommended Posts

I would like to create 2 macvlans on my unraid box, but I am getting an answer:

 

RTNETLINK answers: Device or resource busy

 

This works on just about any linux except on my unraid..  Am I doing something wrong?

 

I have tried the following:

 

ip link add link eth0 name eth1 address 7e:40:b2:a8:67.16 type macvlan

 

ip link add link eth0 name eth0.1 address 7e:40:b2:a8:67.16 type macvlan

 

 

Thanks.

Edited by EArroyo

Share this post


Link to post

Use the GUI to create the networks. See Settings -> Docker

(Docker service must be stopped to make changes)

 

Edited by bonienl

Share this post


Link to post

Thank you for your reply.  What I am trying to do is not run dockers.  I already have 3 Ubuntu Playground dockers, I wanted to remove these and run the daemon binding to IP address.

Share this post


Link to post

Your manual creation interferes with the implementation of Unraid, which creates networks automatically for the existing interfaces.

 

 

Share this post


Link to post

Yeah, thank you, I figured it out, I had to use Custom: br0 and it lets me put the IP address.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this