Jump to content
soupn

Cannot access unraid via browser

12 posts in this topic Last Reply

Recommended Posts

Hello,

feeling kind of dummy but after a format of my windows machine I cant access my unraid server via browsers (firefox or chrome).

I can enter the shared folders on unraid via network, but when I try to enter via browser I get several unsafe certificate messages:

 

firefox: SEC_ERROR_UNKNOWN_ISSUER

chrome: NET::ERR_CERT_AUTHORITY_INVALID

 

and there's no option to add any kind of exception and if i press continue it loops. This is a fresh machine, i´ve tried even with anti virus disabled.

 

Any help?

Share this post


Link to post

I did a google on  unraid.net  " firefox: SEC_ERROR_UNKNOWN_ISSUER"  and got only two hits.  You might want to do the same and see if anything in the 'solutions' might help with your problem.  (I have never heard of this issue with Unraid before.)   

 

If these did not fix the problem, please get a screen capture of the entire Error message and post it up with your next post. 

 

 Get a screen capture of the output of the command    winver    (With Win10, you type this in the search box on the bottom toolbar of the desktop.) 

 

Did you have your server setup with a certificate to use https?

 

Can you access the GUI from any other device or computer?

 

What antivirus software is installed on your computer?

 

Share this post


Link to post

What is the URL entry that you are using (either the one you type or the URL entry in the shortcut/bookmark)  and what appears on the URL address bar where the error message appears?  

 

EDIT:  If that URL begins with a string of letters and numbers, delete or (cross out) about a third of them.  

Edited by Frank1940

Share this post


Link to post

Hello Frank, thanks for your help.

 

Quote

 

I did a google on  unraid.net  " firefox: SEC_ERROR_UNKNOWN_ISSUER"  and got only two hits.  You might want to do the same and see if anything in the 'solutions' might help with your problem.  (I have never heard of this issue with Unraid before.)   

If these did not fix the problem, please get a screen capture of the entire Error message and post it up with your next post. 

 

Firefox: https://www.dropbox.com/s/bepjq35g0r4qgp2/firefox.png?dl=0

Chrome: https://www.dropbox.com/s/1bnul0njz6yxh2e/chrome.png?dl=0

 

When I press the Ignore and continue, it does nothing...

 

Quote

 Get a screen capture of the output of the command    winver    (With Win10, you type this in the search box on the bottom toolbar of the desktop.) 

https://www.dropbox.com/s/7jlf4sr4zsi6bvx/winver.png?dl=0

 

Quote

Did you have your server setup with a certificate to use https?

I think I just activated ssl/tls and it installed himself a self signed ssl

 

Quote

Can you access the GUI from any other device or computer?

Yes, from a laptop with Linux Mint 19.2 and Firefox 69

 

Quote

What is the URL entry that you are using (either the one you type or the URL entry in the shortcut/bookmark)  and what appears on the URL address bar

where the error message appears? 

Tried with direct IP and vault101.local. Both addresses go to same pages.

 

Quote

What antivirus software is installed on your computer?

ESET AV and Malwarebytes. Tested with both activated and deactivated.

 

 

Edited by Paulo Costa
links

Share this post


Link to post

Please put all screenshots directly into your message.  (You can drop-and-drag picture files into the message into the message body.  You may have to convert them to jpeg.)  I do not read Spanish(?) and the site where you posted them virtually covers the screen with some agreement that I can't read/understand that I apparently have to accept in order to be able to see the screen capture.   I will not do this and probably many other people won't either. 

12 minutes ago, Paulo Costa said:
Quote

What is the URL entry that you are using (either the one you type or the URL entry in the shortcut/bookmark)  and what appears on the URL address bar

where the error message appears? 

Tried with direct IP and vault101.local. Both addresses go to same pages.

 

The exact syntax is very important in trying to figure out what is going on.  I am looking for something like this: 


Bookmark:     

 192.168.1.242/Main

 

Bowser URL address for this bookmark:

https://ab121XXXXXXXXX5d952000fa0ca836d0b3fa12d6745.unraid.net/Main

Since you have a Linux computer that will give you access, you should be comparing its results on the URL with what you are seeing on the WIN10 computer.  This can easily some type of block in accessing the DNS redirect to get the address that is registered for the security certificate. 

 

By the way, WIN10 has a an enhanced screen capture utility.  See here for details:

 

     https://www.windowscentral.com/how-use-snip-sketch-take-screenshots-windows-10-october-2018-update

 

Be sure to read this section entitled "How to enable Print Screen button to use Snip & Sketch"  on how to make the 'PrtSc' key a shortcut to the tool.  It really makes it super easy! 

Share this post


Link to post

You can try disabling SSL and if it works then try re-enabling, edit config/ident.cfg on the flash drive and change USE_SSL from "yes" to "no", then reboot.

Share this post


Link to post
39 minutes ago, johnnie.black said:

You can try disabling SSL and if it works then try re-enabling, edit config/ident.cfg on the flash drive and change USE_SSL from "yes" to "no", then reboot.

Hello, disabling ssl works and I can login.

 

I've found this on logs:

 

Sep 11 14:09:14 Vault101 kernel: Sep 11 14:10:09 Vault101 nginx: 2019/09/11 14:10:09 [crit] 6064#6064: *24966 SSL_read() failed (SSL: error:14191044:SSL routines:tls1_enc:internal error) while processing HTTP/2 connection, client: 192.168.1.163, server: 0.0.0.0:443

Sep 11 14:10:09 Vault101 nginx: 2019/09/11 14:10:09 [crit] 6064#6064: *24968 SSL_read() failed (SSL: error:14191044:SSL routines:tls1_enc:internal error) while processing HTTP/2 connection, client: 192.168.1.163, server: 0.0.0.0:443

Sep 11 14:20:09 Vault101 nginx: 2019/09/11 14:20:09 [crit] 6064#6064: *25727 SSL_read() failed (SSL: error:14191044:SSL routines:tls1_enc:internal error) while processing HTTP/2 connection, client: 192.168.1.163, server: 0.0.0.0:443

Sep 11 14:20:09 Vault101 nginx: 2019/09/11 14:20:09 [crit] 6064#6064: *25726 SSL_read() failed (SSL: error:14191044:SSL routines:tls1_enc:internal error) while processing HTTP/2 connection, client: 192.168.1.163, server: 0.0.0.0:443

Share this post


Link to post

Try re-enabling it again, if errors persist you'll need to wait for somebody else's help as SSL issues are outside my wheelhouse.

Share this post


Link to post

yeah i´ve disable, reboot server and enable it again and boom...

Edited by Paulo Costa

Share this post


Link to post

I assume that "boom" means it failed to work properly.  You might try googling   unraid ssl issues  and see if you find something there.  Part of the problem is that the explanation that Firefox is giving you is in Spanish and many of us do understand Spanish.   What I suspect is that something is blocking the DNS redirect to get the proper   <long hex string>.unraid.net  address which is the address that the security certificate is issued for.  

 

If this is your problem, then you (or someone) have to figure out what is going on.   As an example, I had the same problem and it was the way my router was configured.  You don't have a router problem as your Linux laptop works fine.  But it could be something in your antivirus or some other setting on your Windows computer.  (The DNS redirection is often considered a security risk and, for that reason, it may be prevented!) 

 

Just as a piece of information, you can read about my particular problem and many other router issues in this thread:

 

   https://forums.unraid.net/topic/61265-what-router-are-you-running/page/3/?tab=comments#comment-637221

 

Share this post


Link to post

Hello, after some time I had to check my anti virus software options and the problem was there.

I use ESET Nod32 AV, and there's an option enabled by default SSL/TLS filtering, and I had to add my local cert to the List of Know Certs.

Everything working fine now.

thanks.

Annotation 2019-09-28 165524.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.