[Support] ich777 - Application Dockers


ich777

1111 posts in this topic Last Reply

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I'm currently looking into this and this will take some time since I'm really busy at the moment, the permission issue is actually because I tried a workaround and that did not fix it, anyways you can

Stop the container, delete the photoprism folder from your appdata directory and start it again.

For the PhotoPrism docker you should add in options for using mysql isntead of sqlite since the built in sqlite is horrible with performance and getting itself "locked" causing issues.   Her

Posted Images

2 hours ago, RCFilm said:

ich777/debian-buster:nvidia-steam -- GTX 1660 help

 

I have the container working just fine on an old Nvidia K2000 but am having trouble getting the container to start with my gtx 1660 and quarto p400.

any help?

What have you tried so far?

Are you trying to run two containers at the same time or did you just change the graphics card?

Have you tried to change the variable 'Xorg Dsplay Output Port'?

What does the log say?

Link to post

Hello, I have been tried your photoprism container and so far love it.

 

I have found a minor annoyance:

The first parameter ("Data Dir" where generated files like cache and index ...) won't work unless you also pass the variable:

PHOTOPRISM_STORAGE_PATH: /photoprism/storage

 

If you don't pass that variable the storage with all cache, index and database will be created inside /photoprism/originals in a hidden folder called ".photoprism"

 

Hopefully I have explained this correctly.

 

Thanks again!

Link to post
1 hour ago, jorge16 said:

Hello, I have been tried your photoprism container and so far love it.

 

I have found a minor annoyance:

The first parameter ("Data Dir" where generated files like cache and index ...) won't work unless you also pass the variable:

PHOTOPRISM_STORAGE_PATH: /photoprism/storage

 

If you don't pass that variable the storage with all cache, index and database will be created inside /photoprism/originals in a hidden folder called ".photoprism"

 

Hopefully I have explained this correctly.

 

Thanks again!

Yes, I've already seen that, thinking of letting it as it is... (with the only difference that I will delete the first path from the template)

What do you think? In my mind it would be perfectly fine to let the database at the photos itself because the harddrive must spin up for both the pictures itself and als the database. ;)

 

I don't know whats better, I only think of that because many people have only a smaller cache drive and if you have a big library of pictures this will take up the whole cache drives for thumbnails...

Link to post
5 hours ago, ich777 said:

Yes, I've already seen that, thinking of letting it as it is... (with the only difference that I will delete the first path from the template)

What do you think? In my mind it would be perfectly fine to let the database at the photos itself because the harddrive must spin up for both the pictures itself and als the database. ;)

 

I don't know whats better, I only think of that because many people have only a smaller cache drive and if you have a big library of pictures this will take up the whole cache drives for thumbnails...

I don't spin down the hard drives so I don't really have that problem.

 

At first I was thinking in setting thumbnails and database in SSD cache and photos on array. This was because in photoprism requirements it says:

"Indexing large photo and video collections significantly benefits from fast, local SSD storage and enough memory for caching."

But maybe you also need the photos in the SSD to really benefit...

Also I did not considered the thumbnail space, tomorrow I will check to see how much thumbnail space is required for X photos.

 

I think it will be better to have both options (maybe add a disclaimer that to really use the storage path, then the user should add the variable PHOTOPRISM_STORAGE_PATH). I myself, always prefer to have the "media" locations and the "configuration" locations separated.

 

 

Link to post

Trying out PhotoPrism and attempting to import photos but I don't have an "import" button in the library tab...just Index, Copy and Logs.  I have the import folder mapped to a folder on my array and have populated it with sample images, and have even tried running Docker Safe New Perms, but still no import button.  What am I missing?

Link to post
10 hours ago, jorge16 said:

I don't spin down the hard drives so I don't really have that problem.

 

At first I was thinking in setting thumbnails and database in SSD cache and photos on array. This was because in photoprism requirements it says:

"Indexing large photo and video collections significantly benefits from fast, local SSD storage and enough memory for caching."

But maybe you also need the photos in the SSD to really benefit...

Also I did not considered the thumbnail space, tomorrow I will check to see how much thumbnail space is required for X photos.

 

I think it will be better to have both options (maybe add a disclaimer that to really use the storage path, then the user should add the variable PHOTOPRISM_STORAGE_PATH). I myself, always prefer to have the "media" locations and the "configuration" locations separated.

 

 

Will look into this, now I am in contact with the developer sorting things out.

 

9 hours ago, drsparks68 said:

Trying out PhotoPrism and attempting to import photos but I don't have an "import" button in the library tab...just Index, Copy and Logs.  I have the import folder mapped to a folder on my array and have populated it with sample images, and have even tried running Docker Safe New Perms, but still no import button.  What am I missing?

Click on 'Copy' and then on 'Import' this is actually how the import works... :D

Link to post

How can I change 2 things with photoprism?

 

1. I need to move the ".photoprism" folder that gets created at the root of my photo folder somewhere else. Photo Prism isn't the only app I have pointed at that folder and it caused my other apps to begin indexing all the photo prism thumbnails.

 

2. Can I tell photo prism to ignore certain folders? I also use a Synology and it creates a folder called "@eaDIR" in every folder which contains all of the Synology generated thumbnails, and photo prism happily indexes all of them so I end up with 5 copies of every photo at different resolutions.

 

So With these 2 issues Im sure you can see that this would actually cause an endless loop that if not caught would eventually result in 100% disk usage with copies. Because if Photo Prism indexes the Synology thumbnails, and creates its own thumbnails, then the Synology will index the photo prisms thumbnails, and create its own thumbnails, which will then get indexed my photo prism, and on and on and on until my server is 100% full.

 

I really want to use Photo Prism, but I absolutely have to at a minimum fix issue #1

Link to post
11 hours ago, relink said:

How can I change 2 things with photoprism?

 

1. I need to move the ".photoprism" folder that gets created at the root of my photo folder somewhere else. Photo Prism isn't the only app I have pointed at that folder and it caused my other apps to begin indexing all the photo prism thumbnails.

 

2. Can I tell photo prism to ignore certain folders? I also use a Synology and it creates a folder called "@eaDIR" in every folder which contains all of the Synology generated thumbnails, and photo prism happily indexes all of them so I end up with 5 copies of every photo at different resolutions.

 

So With these 2 issues Im sure you can see that this would actually cause an endless loop that if not caught would eventually result in 100% disk usage with copies. Because if Photo Prism indexes the Synology thumbnails, and creates its own thumbnails, then the Synology will index the photo prisms thumbnails, and create its own thumbnails, which will then get indexed my photo prism, and on and on and on until my server is 100% full.

 

I really want to use Photo Prism, but I absolutely have to at a minimum fix issue #1

For the first thing add a variable and add this as the Key: 'PHOTOPRISM_STORAGE_PATH' and this as the Value: '/photoprism/storage' then it will store it in the intended location (will change the template shortly so that this is no problem again).

 

For the second thing I recommend to create a issue on Github from PhotoPrism: Click

(As a workaround I can only recommend to don't use Synology for this and delete all these folders if you really want to use PhotoPrism)

 

EDIT: Updated the template should be available in the next few hours in the CA App.

Link to post
6 hours ago, ich777 said:

For the second thing I recommend to create a issue on Github from PhotoPrism: Click

(As a workaround I can only recommend to don't use Synology for this and delete all these folders if you really want to use PhotoPrism)

The first suggestion worked perfectly. As for the second issue after some searching through github I did find an official solution.

Create a file at the root of the folder containing your images called ".ppignore" within the file just make a list of anything you want Photo Prism to ignore when indexing, one per line of course.

 

So I now have 1 file called ".ppignore" at the root of my photos folder with one line in it that just reads "@eadir" without the quotes. Now When photo prism indexes, the "@eadir" folders still show-up, but from within photo prism they appear empty, and nothing in them gets indexed.

Link to post
5 hours ago, bar1 said:

i dont see an ios/android app

There is a very early beta of both an android app and iOS app, it doesn't currently have a ton of feature but it does support automatic upload.

 

Andorid APK can be downloaded here

iOS App can be installed via TestFlight here OR Installed from source using Xcode.

Link to post
52 minutes ago, relink said:

There is a very early beta of both an android app and iOS app, it doesn't currently have a ton of feature but it does support automatic upload.

 

Andorid APK can be downloaded here

iOS App can be installed via TestFlight here OR Installed from source using Xcode.

thanks will give it a go

Link to post
11 hours ago, bar1 said:

thanks will give it a go

You could also use nextcloud to do this and set up the sync folder to the import folder that should also work.

Eventually there also is an iCloud photo downloader container on the CA App and you could also try that (but I don't know of this container is working and up to date)

Link to post

Hi, 

In first I want to thancks, I search for a long time to a docker image with nvidia drivers to do a  stream games sever :)


It's work well but it little bit limited about games that can I launch. I would to complete the docker with tools like wine, winetricks, .net etc ... but I don't understand well how to complete the docker with user.sh could you provide an example please ? 

Link to post
2 hours ago, Gunnm said:

Hi, 

In first I want to thancks, I search for a long time to a docker image with nvidia drivers to do a  stream games sever :)


It's work well but it little bit limited about games that can I launch. I would to complete the docker with tools like wine, winetricks, .net etc ... but I don't understand well how to complete the docker with user.sh could you provide an example please ? 

Why don't you run the games with proton? All games I've tried run with it.

Here is an example script: user.sh

 

I would recommend to create a folder called scripts in the appdata directory itself, then put the script in it (this basic script that I've provided does a 'apt-get update' to get all the latest packages and then installs nano with 'apt-get -y install nano' don't forget the '-y' switch otherwise it won't install the packages.

 

After that go in the template from the container and create a new Path with this configuration (you have to type in 'user.sh' since you can't directly click on it):

grafik.png.2b80b93226c086cd7c34a85262944ecf.png

 

Hope, this makes sense, if you got any further question please feel free to ask again ;)

Link to post

Thank you for the quick reply.

 

You have right it didn't work at first but if I force the parameter of the game to use a specific version of proton it's work. 

 

Now I have an issue with controller,strangely it's work well with big picture interface but not in the games maybe I need do something like that ?

Quote

 

sudo nano /etc/udev/rules.d/90-joystick-perms.rules

ENV{ID_INPUT_JOYSTICK}=="1", MODE="0660", GROUP="games"

 

 

Source https://doc.ubuntu-fr.org/steam

Edited by Gunnm
Link to post
13 minutes ago, Gunnm said:

Now I have an issue with controller,strangely it's work well with big picture interface but not in the games maybe I need do something like that ?

This is one thing I have to figure out but I don't got many spare time at the moment (also in the description it says that the controller input doesn't work.

Have to make a post on github how exactly steam and the games handle the input itself.

 

I know what you posted about the permissions but that doesn't work either...

 

As a workaround for now you can map the keyboard to the buttons that also works very well...

 

I really have to figure this out but as I said I got really limited time at the moment.

Link to post
  • 2 weeks later...

I am trying to get Click'n'Load working for the JDownloader2 container four hours now, but it just wont work. Maybe someone can help:

 

(1) I forwarded 9666 to the unraid server on my windows machine:

netsh interface portproxy add v4tov4 listenport=9666 listenaddress=0.0.0.0 connectport=9666 connectaddress=192.168.1.254

or mac machine:

ssh -L 9666:localhost:9666 -N -o GatewayPorts=yes 192.168.1.254

 

(2) forwarded tcp:9666 to the docker container

(3) disabled "RemoteAPI: Extern Interface Localhost Only" in the extended settings

 

... but it does not work.

Does anyone have an idea why? or a good methode to debug this?

Link to post
6 hours ago, Greyberry said:

I am trying to get Click'n'Load working for the JDownloader2 container four hours now, but it just wont work. Maybe someone can help:

 

(1) I forwarded 9666 to the unraid server on my windows machine:


netsh interface portproxy add v4tov4 listenport=9666 listenaddress=0.0.0.0 connectport=9666 connectaddress=192.168.1.254

or mac machine:


ssh -L 9666:localhost:9666 -N -o GatewayPorts=yes 192.168.1.254

 

(2) forwarded tcp:9666 to the docker container

(3) disabled "RemoteAPI: Extern Interface Localhost Only" in the extended settings

 

... but it does not work.

Does anyone have an idea why? or a good methode to debug this?

Have you also choose the option "listen on localhost adress only" in the jDownloader2 settings and also added the port 9666:9666 in the docker settings?

 

I'm also not sure if there is a plugin for this for firefox...

Link to post
4 hours ago, ich777 said:

Have you also choose the option "listen on localhost adress only" in the jDownloader2 settings and also added the port 9666:9666 in the docker settings?

Yes, that is what (2) and (3) supposed to mean.

 

always worked without the plugin though.

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.