[Support] ich777 - Application Dockers


ich777

Recommended Posts

copied from wrong thread:
 

i don't know why, but when using the host option with teamspeak dockers, i keep getting time outs on the clients. Didn't have this before. From the point i assigned it a dedicated ip, it has been stable for 24 hours . . . (or atleast till now)

Any idea why this is @ich777 ( i assume its an unraid thing, but can't be sure)

Link to comment
27 minutes ago, Caennanu said:

Didn't have this before. From the point i assigned it a dedicated ip, it has been stable for 24 hours . . . (or atleast till now)

Do you have a static IP or do you have a dynamic IP from your ISP?

 

Is it possible that something changed at the ISP side?

Link to comment
6 minutes ago, ich777 said:

Do you have a static IP or do you have a dynamic IP from your ISP?

 

Is it possible that something changed at the ISP side?

 

I have a static ip from the ISP I know for fact nothing has changed for my ISP as i work at said ISP :P

 

edit: the only thing that has changed, is that i went from a ryzen platform to an epyc platform.

Edited by Caennanu
Link to comment
53 minutes ago, Caennanu said:

edit: the only thing that has changed, is that i went from a ryzen platform to an epyc platform.

This is really strange...

I really can't tell why this is happening, eventually something is different with the NIC, that's my only guess.

Link to comment
3 hours ago, ich777 said:

Sorry overlooked the answer yesterday.

 

The config seems fine, in what folder did you copy the pictures that you want to import?

Please also look at this Github issue: Click

 

/mnt/user/Import Pictures

 

is the sub folders also checking when auto import from import folder ?

Edited by Masterwishx
Link to comment

ok, now i tried with your jDownloader but i'm still not getting anywhere.

here's my jDownloader Container:

jDownloader.thumb.png.18034ef300245b3488abe4659e63deb8.png

 

i changed the WebGUI port (because i have another container on 8080) to 8787.

 

What settings should i enter here on the extra port in the openVPN Docker?

port.png.f8f3e11518b06114498f4bef49a3b92c.png

 

Link to comment
10 minutes ago, pika said:

What settings should i enter here on the extra port in the openVPN Docker?

Container Port 8080, Host Port whatever you want.

What is the IP from your OpenVPN container in your network, not in the container?

 

10 minutes ago, pika said:

i changed the WebGUI port (because i have another container on 8080) to 8787.

You can delete this entry from the jDownloader template because it does nothing when you route the traffic trough the OpenVPN container and set the network to none.

Link to comment

deleted the port entry in jDownloader template, configured the container port to 8080 and host port to 8987 and tried to restart the jDownloader Container:

image.png.f98fb233e662b7fecfdf8cc2d9cb3b7b.png

 

removed the container and redownloaded it, now i can access the vnc/webgui!

 

speed is still not very good (600 kb/s vs 20 mb/s withtout openVPN routing).

  • Like 1
Link to comment

@pika may worth a try to rule out some things

 

as you think its a unraid, docker thing ... and your vpn provider is not throtteling etc

 

may try a different vpn container as test with a integrated http, socks proxy, setup ypur vpn connection.

 

then test from jdownloader normal installation on docker and windows using the proxy function to compare performance

 

image.thumb.png.de920547534da40a609a1458cfc98510.png

 

then you can rule out if its jdownloader specific or vpn specific ...

 

your test on a windows mashine with a vpn cient software may not be the best practice to compare now.

 

just as suggestion to rule out, as jdownloader can use a proxy for its traffic its a simple Test as you dont have to use --network....

  • Like 2
Link to comment
7 hours ago, alturismo said:

@pika may worth a try to rule out some things

 

as you think its a unraid, docker thing ... and your vpn provider is not throtteling etc

 

may try a different vpn container as test with a integrated http, socks proxy, setup ypur vpn connection.

 

then test from jdownloader normal installation on docker and windows using the proxy function to compare performance

 

image.thumb.png.de920547534da40a609a1458cfc98510.png

 

then you can rule out if its jdownloader specific or vpn specific ...

 

your test on a windows mashine with a vpn cient software may not be the best practice to compare now.

 

just as suggestion to rule out, as jdownloader can use a proxy for its traffic its a simple Test as you dont have to use --network....

meh, i don't even get a connection with socks5

 

image.png.1357baf0f2e8dae67cf966292fec5879.png

do i have to configure ports in the docker? or do i have to set up also a http proxy? couldn't find any guide with nordVPN...

Link to comment
14 hours ago, ich777 said:

Please also look at this Github issue: Click

 

i can understand its more for Webdav to avoid some errors but we can run cron jobs for it:

so can we run it in user script ?

i dont know how to do it in user script ....

/usr/bin/docker exec PhotoPrism PhotoPrism/bin/photoprism index

/usr/bin/docker exec PhotoPrism PhotoPrism/bin/photoprism import

???

Link to comment
2 hours ago, pika said:

meh, i don't even get a connection with socks5

 

which VPN Docker you are trying now ?

 

mine, binhex, ... as sample have a http privoxy and socks proxy implemented, by default without a user pass ... i see you added credentials there so i wonder what you using now ...

Link to comment

 Having some issues with the Thunderbird docker again since update

 

Quote

---Checking if UID: 99 matches user---
---Checking if GID: 100 matches user---
---Setting umask to 000---
---Checking for optional scripts---
---No optional script found, continuing---
---Checking configuration for noVNC---
Nothing to do, noVNC resizing set to default
Nothing to do, noVNC qaulity set to default
Nothing to do, noVNC compression set to default
---Starting...---
---Version Check---
---Thunderbird not installed, installing---
---Something went wrong, can't download Thunderbird, putting container in sleep mode---

 

This is the second or third time this has happened, last time I just left it for a few days and it worked again this time however no such joy. Are you aware of a work around on this by chance?

 

Thanks 

 

Link to comment
5 hours ago, Arcau said:

This is the second or third time this has happened, last time I just left it for a few days and it worked again this time however no such joy. Are you aware of a work around on this by chance?

Can you try if you can download the Linux x64-BIT version from here from your local computer?

Have you got any blocking software like AdGuard or PiHole in your network installed?

 

I've also rebuilt the container now, please update the container itself on the Docker page by clicking "force update".

 

Btw, a simple restart will try to download the Thunderbird files again.

Link to comment
9 hours ago, alturismo said:

which VPN Docker you are trying now ?

 

mine, binhex, ... as sample have a http privoxy and socks proxy implemented, by default without a user pass ... i see you added credentials there so i wonder what you using now ...

i'm using ich777's openVPN Docker... (test above shows proxy within jDownloader without VPN Docker / network = bridge)...

 

just re-read your post and now i'll try another docker... whith which docker should i test? there are so many apps to choose from :)

 

edit: just tried binhex privoxyvpn but i can't reach the jDownloader Docker through that container...

Edited by pika
Link to comment
3 hours ago, Masterwishx said:

But after thouse lines nothing happen, maybe I wrote wrong command to execute import and index by docker run? 

Usually you have to do something like:

docker exec -i DOCKERNAME YOURCOMMAND
  • Like 1
Link to comment
3 hours ago, pika said:

edit: just tried binhex privoxyvpn but i can't reach the jDownloader Docker through that container...

the Test is NOT to route the jdown container through the vpn docker by --container as network.

 

jdown has a buildin proxy option, just start jdown as bridge or whatever you like to use mode and enter the proxy settings in jdownloader, you reach jdown directly ...

 

sample from here

 

image.png.df65fedfe52397c0532a3f73f8db88df.png

as you see, my VPN Docker (which you cant use as its a wireguard hide.me only) is on its ip, my jdownload is on its own ip, so i reach my jdownloader simple by 192.168.1.60:5800 or VNC direct 192.168.1.60:5900

 

image.thumb.png.bb6d5ffaedfb9de2d7231e5b582ccae9.png

 

inside jdown you configure now your http and/or socks proxy, name or ip (recommended to make sure), port(s), and disable "no proxy" to make sure all external traffic is going through there.

 

and my extra point is, this scenario you can test from your jdown docker, from any jdown on a VM, Windows client, ...

 

lets say the jdown docker would be very slow like you described and the windows Test Jdown would be fast, it may would be then a jdown docker issue (what i cant imagine)

Edited by alturismo
Link to comment
42 minutes ago, alturismo said:

inside jdown you configure now your http and/or socks proxy, name or ip (recommended to make sure), port(s), and disable "no proxy" to make sure all external traffic is going through there.

but how do i configure it? i still don't get it, sorry.

do i have to configure this in combination with f.e. binhex-privoxyvpn or do i have to configure it only on jDownloader?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.