[Support] ich777 - Application Dockers


ich777

Recommended Posts

3 minutes ago, ich777 said:

This should not happen, in my container I haven't installed Kate instead there should be Gedit.

Try to open up a terminal in the Krusader GUI and type in 'gedit' (without quotes).

 

Maybe look at the settings within Krusader the only thing that I can imagine is that the default text editor is reset somehow...

 

i removed container ,deleted folder and reinstalled but having same isure , i will check it again ..

yes gedit is working with some errors in terminal 

image.thumb.png.c699eb9502fceca729dd8949ee9336af.png

Link to comment
11 minutes ago, Masterwishx said:

yes gedit is working with some errors in terminal 

You can ignore that, just Warnings and nothing to worry about.

Can you try it with english instead?

 

11 minutes ago, Masterwishx said:

i removed container ,deleted folder and reinstalled but having same isure , i will check it again ..

In the initial setup it should show that it uses gedit as default texteditor, maybe go to the settings and try to change the default text editor there.

Link to comment
5 minutes ago, ich777 said:

You can ignore that, just Warnings and nothing to worry about.

Can you try it with english instead?

 

In the initial setup it should show that it uses gedit as default texteditor, maybe go to the settings and try to change the default text editor there.

 

i have internal editor in krusader ,so its use kate editor like in binhex-krusader , i also founded that befor deleted container i had some old files from old krusader container that used a year ago i think ,so after removed , i runned for first time in root mode , in krusader dir (/mnt/disk1/appdata/krusader )was no files saved . after resarted in non root mode files is here. i will try in english maybe..

 

Link to comment
3 minutes ago, Masterwishx said:

i runned for first time in root mode , in krusader dir (/mnt/disk1/appdata/krusader )was no files saved . after resarted in non root mode files is here. i will try in english maybe..

I've tested this with German and it works flawlessly even with root mode.

But I've also found other things that are different in other languages, maybe the languages cause things to get sketchy...

  • Like 1
Link to comment

@ich777 in english also internal edit (krview) is not working to me...

 

in krusader docker doc there is (--env 'UMASK=000' \ --env 'UID=99' \ --env 'GID=100' \)

but in docker itself -- env 'RUNASROOT'  only , so when false its = (--env 'UMASK=000' \ --env 'UID=99' \ --env 'GID=100' \).

 

also in docker doc --volume /mnt/user:/mnt/user \  but in docker itself wrote change the Host Path to '/mnt'

like  --volume /mnt/user:/mnt/

 

you sayed that krusader internal edit (krview or kate) is working on your docker ?

if i change in krusader config editor from internal to gedit, i can start gedit by F4, but wanted internal edit (krview) to be editor .

maybe i can fix it by some apt-get install commands ?

 

Link to comment
17 minutes ago, Masterwishx said:

you sayed that krusader internal edit (krview or kate) is working on your docker

I don't have any of those editors installed in Krusader, only gedit.

 

17 minutes ago, Masterwishx said:

maybe i can fix it by some apt-get install commands ?

Sure just do:

apt-get update

 

And then search for the prefered app for Debian and then install it with:

apt-get install YOURAPP

  • Thanks 1
Link to comment
On 10/22/2020 at 7:02 AM, CorneliousJD said:

I had a *lot* of issues with the SQLite database in photoprism actually, lots of "database is locked" errors. After switching it out to MariaDB it just works and everything is much much faster now as a whole. 

FWIW I pinged the devs on SQLite and they said they tested ith a 6 core machine with fairly standard RAM but I'm running 16T/32C and 128GB of RAM so perhaps my machine was going *too* fast for it to keep up and was trying to move on while the SQLite DB was still locked? Not sure but moving to MariaDB solved the issues.

 

If you do decide to pull it from CA let me know - I will take over the template, I already have an approved CA repo so I can put it up instead if you wish. Your template works great so far on everything with it! 

 

I plan to roll with this as a self hosted Google Photos replacement (best thing I can find for now) and get Nextcloud to auto-upload photos from my phone to external storage that is the import folder of Photoprism and script auto-imports to happen every hour or overnight each day. :)

Hi everyone,

I have failed miserably with many attempts to setup mariadb and photprism on unraid. Are you able to share a step by step guide? assume I am an idiot. 

 

Link to comment
6 minutes ago, epicurean said:

Hi everyone,

I have failed miserably with many attempts to setup mariadb and photprism on unraid. Are you able to share a step by step guide? assume I am an idiot.

A quick Google search brought up this:

 

But I would recommend skipping Step 4 from the Reddit tutorial and put in the credentials here (please read the description from the variable):

grafik.thumb.png.6438c00d58be0c9ea023e17859298d3e.png

 

 

Hope that helps, I also think that @Sycotix has also made a Youtube video on this.

Link to comment
23 minutes ago, ich777 said:

A quick Google search brought up this:

 

But I would recommend skipping Step 4 from the Reddit tutorial and put in the credentials here (please read the description from the variable):

grafik.thumb.png.6438c00d58be0c9ea023e17859298d3e.png

 

 

Hope that helps, I also think that @Sycotix has also made a Youtube video on this.

Thank you Sir! For the mariadb part. do I setup that docker first, or the photoprism first?

Appreciate if steps for mariadb (with regards to photoprism) also explained. Thanks again!

 

Link to comment
3 minutes ago, epicurean said:

Thank you Sir! For the mariadb part. do I setup that docker first, or the photoprism first?

Appreciate if steps for mariadb (with regards to photoprism) also explained. Thanks again!

Like the Reddit post tells you, first the MariaDB, because Photoprism needs a Database that it can connect to.

Link to comment
16 hours ago, ich777 said:

I don't have any of those editors installed in Krusader, only gedit.

 

Sure just do:

apt-get update

 

And then search for the prefered app for Debian and then install it with:

apt-get install YOURAPP

 

Thanks again, finally installed kate editor in krusader ,

after that kate editor from console and KrViewer: Krusader's internal viewer-editor is running by F4 ,

its based on some kate editor lite version i think ... 

also internal editor was by default enabled in other krusader containers ,sorry i was a little disconfused that you have gedit instead.

 

Maybe in future you will include it to you container too?!? ..

 

Also please dont forget to check Prometheus Afterburner for include option for autorestart on start , to fix manual need to restart that we talked about .

 

Edited by Masterwishx
Link to comment

Hey guys, i can't use jdownloader since a few month. my problem is it starts up, starts the update process and after it downloaded the file (approx. 50% of the whole install process) Novnc disconnects and tells me server not found (i tried different browser and deleting the cache, even downgraded to 6.8 because then it was still working. but no change) this is the message which is displayed while the update fails.

 

any ideas what i could do?

jdownloader unraid.PNG

Link to comment
54 minutes ago, Mjaore said:

Hey guys, i can't use jdownloader since a few month. my problem is it starts up, starts the update process and after it downloaded the file (approx. 50% of the whole install process)

Since when did this happen exactly?

 

54 minutes ago, Mjaore said:

even downgraded to 6.8 because then it was still working

This would change nothing to a Docker container, this has to be something inside the container.

 

54 minutes ago, Mjaore said:

any ideas what i could do?

Please try to start over, delete the container, then go to your appdata directory and delete the jdownloader2 directory, then go to the CA App and redownload the container

  • Like 1
Link to comment
50 minutes ago, ich777 said:

Since when did this happen exactly?

 

This would change nothing to a Docker container, this has to be something inside the container.

 

Please try to start over, delete the container, then go to your appdata directory and delete the jdownloader2 directory, then go to the CA App and redownload the container

I reinstalled everything like 10 times! but i never deleted the appdata  -_- now its working again! thank you so much!

  • Like 1
Link to comment

Currently not implemented in my container, will look into this how to implement this ASAP.

 

Please force an update from the container and add this variable to the container:

grafik.png.d75dab0ffcd15dd06f93a0d0184ff2ba.png

 

 

Please also add a TCP Port to the template with the Container and Host port 41144.

  • Thanks 1
Link to comment
3 hours ago, ich777 said:

Currently not implemented in my container, will look into this how to implement this ASAP.

 

Please force an update from the container and add this variable to the container:

...

Please also add a TCP Port to the template with the Container and Host port 41144.

Dang, you are blazing fast, awesome! 🙂

 

Works like a charm, thanks a ton!!!

Link to comment

FIrst of all, sorry for the double-post.

 

Had a look at Prometheus (as suggested), but due to my long history with it, Checkmk is still the way to go for.

 

I tried the whole morning getting the docker for it to work - pulling different versions, playing around with extra parameters, different paths, UID/GID settings, ...

Nothing worked. After 1-2 minutes, the Checkmk docker gets errors that it is unable to retreive any data and locks up, pulling the whole system with it. I can't even download Diagnostics anymore and have to hard-reset the server to get it running again.

 

I'm currently running Checkmk in a VM, which works fine, but I would just like to migrate to Docker, already having set up a Postfix docker for it as well.

 

Is there any way to troubleshoot my problems with this Docker and maybe find a solution?

Link to comment
47 minutes ago, Turnspit said:

Nothing worked. After 1-2 minutes, the Checkmk docker gets errors that it is unable to retreive any data and locks up, pulling the whole system with it. I can't even download Diagnostics anymore and have to hard-reset the server to get it running again.

Try it with the default (old or stable, whatever you want to call it) version that is in the template.

 

Are you sure that you've deleted the checkmk directory that is created in your appdata folder and then tried to reinstall it?

I tried it now and it starts up just fine.

  • Thanks 1
Link to comment
10 minutes ago, Turnspit said:

2.0.0-latest

I only know that this version is locking up but not the old one.

 

I would recommend to open up an issue on the checkmk Github or contacting the support from Checkmk and tell them your problem that even the "old" or better speaking stable is locking up your server, but never experienced this as said for the stable version on any of my machines.

  • Like 1
Link to comment

After every lockup, I removed the docker including its image as well as the appdata folder.

 

Since I could still access the logs after the lockup, I just reinstalled the docker with default values again, in hopes to check the logs for any insights.

 

Lo and behold, so far it seems to be running stable (although quite slow compared to my installation on a Raspberry). Which is strange, because I also had those lockups in the beginning using the default settings of the Template.

 

Anyways, I will continue monitoring the Docker behaviour while setting up Email notifications.

 

Thanks again for your support, ich! :)

  • Like 1
Link to comment

I used your PhotoPrism App to get the PhotoPrism as Docker configured in my unRaid.

Works like a charm.

 

With the newest Release all the variables were changed in the config and have a prefix PHOTOPRISM_.

Do I need to edit the complete config manually or did you already update the app that I can skip this?

 

Until now there was no update available from your app, so I presume I have to edit the config manually - correct?

Link to comment
54 minutes ago, toasti said:

With the newest Release all the variables were changed in the config and have a prefix PHOTOPRISM_.

I don't understand since all the variables in the template already have the prefix "PHOTOPRISM_"

 

For example:

grafik.png.7e7e9d14ec97c79c668ca513bd178a07.png

 

 

55 minutes ago, toasti said:

Until now there was no update available from your app, so I presume I have to edit the config manually - correct?

Also please note, this is not my Docker container, I've created only a template for unRAID for the official PhotoPrism Docker container.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.