[Support] ich777 - Application Dockers


ich777

Recommended Posts

2 days later. It seems the issue was the following. Somewhen during the luckybackup work the GUI was minimized. Then with the VNC settings was tested with scaling, the scroll bar disappeared. The old laptop where i have remote access to access the unraid server has 1200x800 resolution. Now with the wrong scaling applied it was even after updating no task bar visible to bring the application to forground. Most likely everyhing was running flawless, just "off" screen and minimized.

Link to comment
15 minutes ago, Grobalt said:

Now with the wrong scaling applied it was even after updating no task bar visible to bring the application to forground. Most likely everyhing was running flawless, just "off" screen and minimized.

I've never experienced anything like that and I use my Thunderbird container quite frequently and even if it hangs because I open two instances from two different computers a restart from the container fixes everything.

 

Which scaling mode are you using?

 

Are you connecting maybe from more than one machine to the container at the same time with scaling set to remote, that can cause issues from what I know.

 

From a technical standpoint you can't minimize everything...

Link to comment

Hey!

 

Here a little bug on Thunderbird and Firefox, maybe it has already been mentioned.

From time to time, the right click disappear immediately and I must restart the Docker to have again the right click.

 

Have you ever had this issue?

Link to comment

Hello,

I have installed Firefox and OpenVPN-Client and both separately work fine for me, but when I try to get Firefox out through the VPN client, Firefox doesn't have the WebUi. In the Firefox docker I set the network to "no" and add the variable "--net=container:OpenVPN-Client" and assign the Firefox port to the VPN client. I restart both containers and Firefox still has no WebUi. I do not know what I'm doing wrong. You can help?

Link to comment
30 minutes ago, T0rrelles said:

I do not know what I'm doing wrong. You can help?

Can you provide a few screenshots from the container what you've did so far, maybe I can see where the issue is.

Do you routed a second container through the OpenVPN-Client container that uses a noVNC web interface?

Link to comment
6 minutes ago, T0rrelles said:

 

 

 

You have to put "--net=container:OpenVPN-Client" in the extra parameters for the container not the application like this (in your case at "Parámetros Adicionales":

image.png.1fc7a386a927701c98c56a8c39abf56b.png

 

Why are the Extra Parameters in your Docker template under the advanced section marked as required? Should look like this:

image.thumb.png.2d530d950dfff2dfdeb585d388f79762.png

Link to comment
1 minute ago, T0rrelles said:

The same thing happens, it doesn't show me the WebUI

Yes, because you have to manually type it in your address line, simply type in the address from your server and the port that you've created for Firefox in the OpenVPN-Client container.

Link to comment
1 minute ago, T0rrelles said:

Where, I don't have WebUI?

In your web browser like:

image.png.93987a4ac8b1e70700144ebc0b29e10e.png

 

The above IP and PORT is only a example, you have to change the IP to the IP from your server and also the port so that it reflects your mappings, you then simply click on vnc.html and then you are in the Firefox container:

image.png.8a1746a7ceb34f2f8e27e9293e4aa02f.png

 

You have to understand that the Firefox container has no own network anymore because you've set it to None and use the OpenVPN-Client container but that's fine and how you want it.

Link to comment

Thank you very much. Yes, from the laptop I can enter the Firefox docker and once in it I can use VNC.
I tried to start the docker from the WebUI of the server, as I did before trying to pass Firefox through the OpenVPN-Client, but it seems that it is not possible. Thank you very much again.

  • Like 1
Link to comment

Hello - I am trying to use Remmina and have set the resolution to my default monitor which is 3440x1440.  When I run Remmina in the web brower, its a very small window, maybe 500x500 or so and doesnt nearly capture the width of the VM.  Is there a way to adjust this?  Otherwise I correct very easily to my VMs.  Thanks in advance.

Link to comment
10 hours ago, Vaslo said:

When I run Remmina in the web brower, its a very small window, maybe 500x500 or so and doesnt nearly capture the width of the VM.  Is there a way to adjust this?  Otherwise I correct very easily to my VMs.

Do I understand that correct that the VMs are full screen?

 

I will look into that.

Do you mean some kind of scaling so that the font is bigger or do you mean simply that the main window is fullscreen?

Link to comment

Hello,

 

I'm trying to setup luckybackup and i followed the guide but when i try to start a task i get this:

 

556746362_2022-03-2012_07_52-luckyBackup-noVNCMozillaFirefox.png.40a5b93569e483d3ad4339b5c8b70248.png

 

When i try to connect from the cli of the docker it did ask to confirm the first time, as usual for ssh, but then it goes no problem without asking.

If i try to launch the same command that the gui uses (you can check it on the validate button) it works without asking for the authenticity of host.

 

I already tried to remove the docker and remove all files in the /luckbackup folder but the problem persists.

 

Obviously pressing OK on this box does nothing, it asks again 2/3 times and then fails

Link to comment
27 minutes ago, exico said:

I already tried to remove the docker and remove all files in the /luckbackup folder but the problem persists.

Do you run the container as root?

 

Which keys are you using in the container and which one did you copy over (maybe send a screenshot)?

Link to comment
Just now, exico said:

No idea of what was creating the problem

Keep in mind to always use the keys that are located in the /luckybackup directory and not the ones from the /root directory in the container regardless of running it as root or not.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.