Jump to content
ich777

[Support] ich777 - Application Dockers

208 posts in this topic Last Reply

Recommended Posts

13 hours ago, ich777 said:

Yes, and no they are encrypted it depends on the resolver...

You can test it at https://www.dnsleaktest.com/ and run the extended test.

Hi ich777,

 

I saw that link in an earlier post - when I run it, I only see a single server return, ie. the OpenDNS ones. The log window from DoH-Client (with verbose=true set in the config file) shows requests going to Google, DNS.SB and OpenDNS, which I set.

 

So, if those requests are being tunnelled over HTTPS/TLS, then only seeing one server in the DNSLeakTest is to be expected?

 

Cheers,

 

Xav.

Share this post


Link to post
33 minutes ago, xavierda said:

Hi ich777,

 

I saw that link in an earlier post - when I run it, I only see a single server return, ie. the OpenDNS ones. The log window from DoH-Client (with verbose=true set in the config file) shows requests going to Google, DNS.SB and OpenDNS, which I set.

 

So, if those requests are being tunnelled over HTTPS/TLS, then only seeing one server in the DNSLeakTest is to be expected?

 

Cheers,

 

Xav.

Depends on the Browser/OS configuration how much you find.

If it works then it should only display what you've choosen in the config of DoH.

Try to run the test with your standard DNS entries then it should identify your ISP and also the Hostname from your ISP.

 

This is a example if it's working:

Bildschirmfoto_2020-05-22_09-29-41.thumb.png.09abf64058c9c182e0fd9fbc76281d29.png

Edited by ich777

Share this post


Link to post

Hi, ich777,

I'm having a hell of a time getting DirSync Pro to work now that it's removed native SMB support

I've installed the Unassigned Devices plugin and mounted the remote directory (a NFS share on a raspberry pi that was formally SMB) but DirSync Pro can't write to it. I've checked that I've got the write permissions setup right through both the Unraid Terminal and the Docker terminal my using mkdir to create folders, but DirSync Pro itself doesn't seem to have write access. I'm not sure if it's due to me not setting up a 'local' directory correctly.

 

Currently, it's throwing up Warning: Destination file cannot be created: /mnt/local/... etc.

Share this post


Link to post
5 hours ago, Hazza64 said:

Hi, ich777,

I'm having a hell of a time getting DirSync Pro to work now that it's removed native SMB support

I've installed the Unassigned Devices plugin and mounted the remote directory (a NFS share on a raspberry pi that was formally SMB) but DirSync Pro can't write to it. I've checked that I've got the write permissions setup right through both the Unraid Terminal and the Docker terminal my using mkdir to create folders, but DirSync Pro itself doesn't seem to have write access. I'm not sure if it's due to me not setting up a 'local' directory correctly.

 

Currently, it's throwing up Warning: Destination file cannot be created: /mnt/local/... etc.

Can you post a picture of the dirsyncpro template, also, have you set the mounted nfs share inside the template setting to R/W Slave?

I'm thinking of adding the smb plugin back into the container, but at the time i'm having not much time...

 

Share this post


Link to post
1 hour ago, ich777 said:

Can you post a picture of the dirsyncpro template, also, have you set the mounted nfs share inside the template setting to R/W Slave?

I'm thinking of adding the smb plugin back into the container, but at the time i'm having not much time...

 

Yeah, I've selected RW/Slave.

Opening the Container command line and navigating to the mounted directory allowed me to use mkdir to make a folder I could see in both the SMB and NFS fileshare of the raspberry pi, so pretty sure that write access is working,

I'm guessing I've messed up the DirSyncPro container in some way that breaks things.

I deleted and re-downloaded the plugin to recreate the container to make sure.

DirSuncPro_ContainerSetup.png

Unassigned_NFS.png

Share this post


Link to post
8 hours ago, Shamalamadindong said:

Any idea why MagicMirror is so stubborn on running on 8080? If i change it i just get "Cannot GET /auth/"

Where have you changed it only in the docker template or also in your config file?

I recommend always if you change a port to first change it in the setting/config of the game/application itself and then delte the port inside the template and create a new one with the corresponding port and protocol.

Share this post


Link to post
12 hours ago, Hazza64 said:

Yeah, I've selected RW/Slave.

Opening the Container command line and navigating to the mounted directory allowed me to use mkdir to make a folder I could see in both the SMB and NFS fileshare of the raspberry pi, so pretty sure that write access is working,

I'm guessing I've messed up the DirSyncPro container in some way that breaks things.

I deleted and re-downloaded the plugin to recreate the container to make sure.

The config seems right but I have to look into it when i got time...

Eventually i will bring back the SMB syncing in the near future, but I have got little spare time at the moment...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.