Please explain what is happening with my Adaptec 72405

5 posts in this topic Last Reply

Recommended Posts



I needed to consolidate my 2 8-port controllers into 1 to free up a pci-e slot. After much research and deliberation, I ended up ordering an Adaptec 72405 from eBay. It has gotten mixed reviews on the forums, as far as functioning or not with Unraid, so I thought I'd roll the dice....


Mixed results! Controller appeared to install without issue. I flashed to the newest version of firmware, and switched the card to HBA mode.


At first Unraid would not start, but I switched to a different PCI-e slot, and it came up without issue. All 15 drives attached to it showed up during loadup, and I was thinking all was going very smoothly. Here's where the problem began.


I have 15 drives attached to the card. Out of 15, once Unraid loaded up and I started the array, only 4 appeared as expected, while 11 showed the error "Unmountable: Unsupported partition layout".


I tried a few different firmwares, moved the card around, switched the cables to different ports, but no change. After every reboot, the same 11 drives showed the same issue.


Also, it should be noted, that Unraid showed parity as still valid.


After some googling of the forums, I came across a few posts by that provided the key to how I could get my system back up and running (which I am currently in the process of doing. Thanks!!!)


One of the reason RAID controllers are not recommended, though would't expect it would write to the disks without you telling it to initialize them or similar.


Partition info is outside parity, so if you rebuild one disk at a time Unraid should recreate the partitions, to confirm, stop the array, unassign one of the unmountable disks, start the array, check that the emulated disk mounts correctly and data looks OK, also good to check filesystem, if all is well rebuild, you can rebuild on top of the original disks, though using new ones would be safer in case something goes wrong, when rebuild is done repeat for the other disk.

So 2 by 2 (I have dual parity), I've been removing the drives from the array, starting the array, stopping the array, re-adding new drives in their slots (in case something went wrong I wasn't over-writing the data), and re-starting the array.


So far so good. I re-built 5 drives (I did one first to test the process which is why it is an odd number), and all my data is there, and after numerus re-boots, the drives are still there... (*knock on wood*).


So the point of this post is two-fold. To begin, if you are willing to go through this convoluted process (or you are setting up a new array and can format all the drives with the new card), the Adaptec 72405 24-port, pci-e 3.0 controller seems to work great. I'll report back again in a few weeks once it has been running for awhile to confirm that it doesn't flake out on me.


More importantly though, can someone please explain what exactly is going on and why is this working? or anyone else with the expertise?


Honestly, I assumed with an HBA-mode option, it should just pass through the drives as expected. Why is it giving me a hard time for some of them, but not all of them?


And what is the reason? Is this a driver problem (I doubt it). Is it the card adding some meta data (But why not to all the drives??). What's going on????? :)


I am insatiably curious, and when I don't understand something that works but I can't explain why, I get really irked :).


Thanks for any light that can be shed on this!




Link to post
5 hours ago, DoeBoye said:

Is it the card adding some meta data

Should be, i.e. AMF whatever or something like that Meta data


5 hours ago, DoeBoye said:

But why not to all the drives??

May be all, but just Adaptec firmware have this "behavior", you can ( not suggest ) further confirm if connect those 4 mountable disk to a non-adaptec controller and see what happen.


Below post also state some similar result, 4 of 10 disks in same LUN and others in offline ........ luckly smart guys found above way to recovery



Those disk connect in Dell PERC H310 ( RAID mode ) previously ????

Edited by Benson
Link to post
On 9/30/2019 at 2:04 AM, Benson said:

Those disk connect in Dell PERC H310 ( RAID mode ) previously ????

Hi! Thanks for the response! Very odd. You'd think if Adaptec calls it "HBA', it would behave properly.


The PERC h310 was flashed to do straight IT mode. No raid.


As for trying another controller for the 4 drives to see what happens, I haven't tried that, but perhaps I will. I suspect they'll operate as usual.


As for the rest, the drives have all rebuilt, and everything seems to be fine. I didn't love the process to get here, but it seems like this could be a viable cheap 24 port alternative. I'll report back in a few weeks to close the loop.



Link to post
57 minutes ago, DoeBoye said:

The PERC h310 was flashed to do straight IT mode. No raid.

At first, I think those disk are come from some RAID controller to Adaptec card, but this is opposite.

So I suspect even Adaptec set in passthrough ( show RAW ? ), it still add metadata to disks, this not a good sign. I haven't any Adaptec HBA/RAID card, but I have swap Unraid disk to USB / onboard SATA / LSI / Marvell / Asmedia without headache.


Issue similar as disk with HPA enable.


Could you confirm Adpatec set in which mode ?


Above should be a selling point, Adaptec support TRIM to SSD.


57 minutes ago, DoeBoye said:

but perhaps I will

Interest for the result.


57 minutes ago, DoeBoye said:

a viable cheap 24 port alternative


Edited by Benson
Link to post
  • 1 year later...

@DoeBoye I wish you'd responded to the last post here, to know which mode you had it set to. I wonder if Simple Mode is like HBA mode but even dumber? 


Are all your disks connected to the Adaptec or some to mobo? What sort of parity speeds do you get from it in that config? I'm also v curious to know how it would be in a X4 slot (4GB/s split 15-24 ways would still max out spinning HDD speed). How many extra seconds does the controller add to boot time?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.