Home-assistant docker - access behind a proxy


jj_uk

Recommended Posts

I've installed the home assistant docker from the apps tab. I could access this just fine via /<ip address>:8123/

 

However, When i added a reverse proxy (using Nginx Proxy Manager) with SSL, i get bad gateway 502 error when accessing the GUI.

The cert is valid according to google chrome.

 

I searched and found that maybe adding a line to the config file would work, however, when i navigate to \\TOWER1\appdata\home-assistant\configuration.yaml and try to save the file changes, i dont have permission.

 

Anyone else using home assistant that can possibly help? I will need access to the config files at a later date so how do i get permission to modify them?

 

 

EDIT: If i change the network type to BRIDGE and specify a port in the template (8123), I can now access the HA GUI with my reverse proxy. However, I think it needs to be HOST because all my smart devices disappear. 

 

Edited by jj_uk
Link to comment
13 hours ago, jj_uk said:

I've installed the home assistant docker from the apps tab. I could access this just fine via /<ip address>:8123/

 

However, When i added a reverse proxy (using Nginx Proxy Manager) with SSL, i get bad gateway 502 error when accessing the GUI.

The cert is valid according to google chrome.

 

I searched and found that maybe adding a line to the config file would work, however, when i navigate to \\TOWER1\appdata\home-assistant\configuration.yaml and try to save the file changes, i dont have permission.

 

Anyone else using home assistant that can possibly help? I will need access to the config files at a later date so how do i get permission to modify them?

 

 

EDIT: If i change the network type to BRIDGE and specify a port in the template (8123), I can now access the HA GUI with my reverse proxy. However, I think it needs to be HOST because all my smart devices disappear. 

 

I experienced a similar problem what I did was opened the config.yaml and save a new instance by adding a letter to the file name then removed the original and renamed the copy to the original file name and then it let me edit and save not the most elegant solution but it worked and got me going

Link to comment
  • 1 year later...
Posted (edited)

It was a while ago and I can't remember. I'm running HA as host on unraid. My config file has 

http:


and nothing defined within it. 

 

Are you using Nginx Proxy Manager? My settings are:

 

Scheme: HTTP

Cache Assets: off

Block common exploits: on

Websockets Support: on

 

SSL Tab:

Force SSL: on

HSTS Enabled: on

HTTP/2 Support: on

HSTS Subdomains: off

 

Edit: See here: https://github.com/home-assistant/core/issues/24750

Edited by jj_uk
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.