[Support] HaveAGitGat - Tdarr: Audio/Video Library Analytics & Transcode Automation


Recommended Posts

Thanks! Got it up and running, but I have an issue with one of the plugins.
 

When using the plugin "Tdarr_Plugin_drdd_standardise_all_in_one" I get the following error at the end of a transcode:
"File is not video Tdarr_Plugin_drdd_standardise_all_in_one - Pre-processing ☒Plugin error! TypeError: Cannot read property 'streams' of undefined"

The file is a video file. I suspect plugins might have to be re-written specifically for v2.

Link to comment

Hey, Just installed the new V2 version, used v1 many months back 

 

Installed everything ok, the one issue i have is the config is lost whenever i add a new variable to the docker container and start it up. 

If i perform a stop -> start or restart the config is fine.  Its only when i add a new variable like NVIDIA settings that the config gets wiped out.  I haven't tested this on an unraid reboot.  

 

I beleive its becuase its not saving the config in the appdata folder for some reason.  The appdata\tdarr folder has the config and log file folders but no files contained in them

 

Any ideas what im doing wrong?  

 

Docker.thumb.PNG.c9fef7902c08473531bd9c8fbd7f0a71.PNG

Edited by trig229
Link to comment

Hi, resolved the issue.  Looks like the container paths are not set correctly as the default options

Hope this helps anyone with the same issue.  

 

@HaveAGitGat im not sure how to go about updating default options in docker/CA?

It is also the same for the Tdarr_Node as well

 

When adding the docker, the default values for the config, logs. and appdata are all set to the actual host path and not the container path, see below example.  It should be set to whats in the description

Cont_wrong.PNG.fe539467a1d9a35316c17731fef8f0c4.PNG

 

Updated the paths to the following and all working

 

Cont_updated.PNG.8f967ed8c1b6a0a174a2f489a7daa6c0.PNG

 

 

 

Link to comment

I ran into this same problem, but even after clearing the containers in an attempt to start fresh, i still dont have the default config, logs, etc.  Is there some way to make sure the templates are updated?

 

Also, if you are setting up tdarr, and it asks for server IP, do you put the host (brdige mode) or reference itself?

Same question for node, it asks for both server IP and node.  I assume i put unraid IP (bridge again) for the server, but for node is it referring to self.

Edited by TheDon
typos
Link to comment
On 2/3/2021 at 2:04 PM, trig229 said:

Hey, Just installed the new V2 version, used v1 many months back 

 

Installed everything ok, the one issue i have is the config is lost whenever i add a new variable to the docker container and start it up. 

If i perform a stop -> start or restart the config is fine.  Its only when i add a new variable like NVIDIA settings that the config gets wiped out.  I haven't tested this on an unraid reboot.  

 

I beleive its becuase its not saving the config in the appdata folder for some reason.  The appdata\tdarr folder has the config and log file folders but no files contained in them

 

Any ideas what im doing wrong?  

 

Docker.thumb.PNG.c9fef7902c08473531bd9c8fbd7f0a71.PNG

Can you post your node settings? I am super confused as to how I am supposed to set this up.

Link to comment

Here you go.  I have set mine to custom network as originally the template listed the server port field as "port" type and so conflicted with the tdarr server port.  I think the template is updated now though as i can see a new field for server port as a "variable" instead of "port" type.  

 

Tdarr.thumb.PNG.18aafb2f4aeba16136a02877504eda5a.PNG

Link to comment
Just now, deadmeatgames said:


[91m[2021-02-11T07:24:56.320] [ERROR] Tdarr_Node - [39mNode: 192.168.1.2:8267 - Server version is 2.00.03 but Node version is 2.00.04.

 

Just updated.  using haveagitgat/tdarr and haveagitgat/tdarr_node

Exactly. Update and it'll fix.

Link to comment
  • 2 weeks later...
15 hours ago, eagle470 said:

Hello, I've run into the following error on about 1,000 tv episodes.

 

Error: File is not a video.

 

Output for info on the file is attached

Tdarr-error.txt 714 B · 0 downloads

 

Make sure to put this community plugin at the top of your plugin stack:

 

Tdarr_Plugin_lmg1_Reorder_Streams

 

Most plugins expect the video stream as the first stream in order work correctly

Link to comment
4 hours ago, HaveAGitGat said:

 

Make sure to put this community plugin at the top of your plugin stack:

 

Tdarr_Plugin_lmg1_Reorder_Streams

 

Most plugins expect the video stream as the first stream in order work correctly

I have that as the first plugin process. I know the files ARE videos, I can watch them on Plex.

Link to comment
  • 2 weeks later...

Hello everyone.

 

New to tdarr and my goal is to replace handbrake since it seems like nvenc h.265 10bit is in an unknown status on when it will come to handbrake.

 

This software is really awesome but I'm having trouble bringing my file size down with decent quality comparable to handbrake.

I'm using the migz nvenc gpu plugin.
comparison

30gb file, handbrake (gpu h.265) with english only audio and subs get's down to little less than 4gb.  With tdarr that number is currently 15gb. 

Can anyone point me to plugins that can do gpu based nvenc h.265 10bit with decent quality and a much better file size?

Or is it possible to convert my current handbrake configuration into the correct ffmpeg cli string (with 10bit) or does anyone have their own non-community plugins that would so something similar? @HaveAGitGat any tips here?
 

Edited by repomanz
Link to comment

I solved my problem.  I copied locally the plugin "Tdarr_Plugin_MC93_Migz1FFMPEG" and tuned it a bit. I ended up modifying this line in the plugin to tailor to my needs.
 

  response.preset += `,-map 0 -c:v hevc_nvenc -rc:v vbr_hq -cq:v 28 -tune flim -preset slow ${bitrateSettings} `

 

key change/add:   -cq:v 28 -tune flim -preset slow

Edited by repomanz
Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.