[Support] HaveAGitGat - Tdarr: Audio/Video Library Analytics & Transcode Automation


Recommended Posts

On 12/14/2021 at 11:13 PM, DayspringGaming said:

What would cause a file to fail transcoding? I had it run through a library of linux ISOs, and have about 5000 or so that just won't transcode via NVENC. (A large amount worked correctly, though.) And most new files are failing as well. 

Ideas? 

Press the 'i' info button on the items in the Transcode: Error/Cancelled table at the bottom of the Tdarr tab and it should show you the error.

Link to comment
On 11/29/2021 at 3:21 PM, rosskinard said:

I saw where the docker containers were updated, so I told Unraid to update them.

 

Since then, I have serious instability where the server will hang up and the webUI dies, the nodes start throwing errors about the server not responding, etc.

 

Literally will not work properly again until both the server and the two nodes (server and GTX1080 node on main Unraid box, gtx970 node on a smaller Unraid box) have been restarted.

 

Did not have this issues before the update. Ideas?

 

Thanks

Ross

Which Tdarr version? 

Link to comment
On 11/20/2021 at 10:59 PM, DayspringGaming said:

Just replaced my GPU and am getting 1/3 or so of the performance I had before.

Tried removing the TDARR node setup and reinstalling. But sitting at 30 FPS on processing. Used to get 100+ or more with my older gpu. 

Old GPU: TitanXp
New GPU: 3080 FE

I checked the logs and am seeing the following error:

 

[HPM] Error occurred while trying to proxy request /socket.io/?EIO=4&transport=polling&t=Nq_Iyn7&sid=hebFTjgL85ANwTZjAAAC from 192.168.1.35:8265 to http://192.168.1.35:8266 (ECONNRESET) (https://nodejs.org/api/errors.html#errors_common_system_errors)

[HPM] Error occurred while trying to proxy request /socket.io/?EIO=4&transport=polling&t=Nq_IzGR&sid=9nczrJjdDz0tA5VBAAAA from 192.168.1.35:8265 to http://192.168.1.35:8266 (ECONNRESET) (https://nodejs.org/api/errors.html#errors_common_system_errors)

 

Try the latest container, it uses Jellyfin's ffmpeg: https://github.com/HaveAGitGat/Tdarr/blob/master/Dockerfile#L39

Link to comment
On 11/5/2021 at 11:20 PM, damnshaneisthatu said:

Anyone else's machine repeatedly restarting after doing Spaceinvader One's Tdarr tutorial and transcoding their media library?

 

I'm getting 3-5x restarts a day at least.

Try the latest containers if you're still using Tdarr and having that issue, did some updates so hopefully fixes it for you.

  • Like 1
Link to comment
On 11/10/2021 at 1:47 PM, cerickso88@gmail.com said:

I love this app/docker.   I've been so fustrated with Handbrake and how it doesn't pass through all the subtitles in the file so I tried this.    I've tried 2 plugins (FFMPEG H265) but both are not passing through the CC subtitles as I thought they would.   According to MediaInfo, the files has 1 Text Stream of UTF-8 which I think is the Closed Captioning which I want.

 

Is there something I'm missing?

 

 

image.png.3603b534965b6e1f431d69811adfc38c.png

 

Thanks,

ce

Here is the FFmpeg command being used:

https://github.com/HaveAGitGat/Tdarr_Plugins/blob/9bbc4fbec9a535799e36587a577bfa3f23a2c8fc/Community/Tdarr_Plugin_075a_FFMPEG_HEVC_Generic.js#L45

 

So it shouldn't be doing that unless something is missing.

Link to comment
On 11/9/2021 at 10:06 PM, i82q2p said:

I had this and think it could do with my media share set to cache=yes. I have set cache=no, run mover and use /mnt/user0/xxxx instead of mnt/user/xxxx in tdarr docker to bypass the cache. Seems to be rock solid now but lots of apps like plex etc. are still writing to cache.

 

I think I should be able to set my media share back to cache=yes then tdarr should only see the files on the array and pick them up when mover runs... but I've not managed to try it yet

Thanks, added to troubleshooting docs here: https://docs.tdarr.io/docs/troubleshooting/#tdarr-keeps-crashing-on-unraid

Link to comment
26 minutes ago, HaveAGitGat said:

Have you set a limit on the container logs? And have you mapped your transcode cache? This normally happens if you don't map the transcode cache as all the new files stay stuck in the container.

Ye i worked it out. recconfiged tdarr node and tdarr and all sorted. still not sure what in the config made it go to the logs when /temp did have a folder made for it. but saying that i did have /temp inside of tdarr input / output folder. eg. /tdarr inside that was input output and temp. inside input was film/ tv and inside output was the same. strange really

Link to comment

Hi - I installed the latest Tdarr on unRaid 6.9.2 with all docker and plugin updates per Spaceinvader1's instructions on unRaid. I also installed Tdarr server and node on a Win10 Pro PC to work on the same media file repositry (on the unRaid server). I went to bed with everything working fine, but woke up to find a frozen unRaid server, and obviously a failed Tdarr operation. I had to do a hard reset of the unRaid server, and restarted Tdarr on both unRaid and the PC. After doing a fresh rescan everything appears to be running ok again. I have attached the log files and I would be very grateful if someone could check them and let me know if there is something I should be doing differently.

Cheers

Steve

Tdarr_Updater_Log.txt Unraid Node log for Tdarr.txt Unraid Server log for tdarr.txt Win10_Tdarr_Node_Log.txt Win10_Tdarr_Server_Log.txt

Link to comment
22 hours ago, Steviewunda said:

Hi - I installed the latest Tdarr on unRaid 6.9.2 with all docker and plugin updates per Spaceinvader1's instructions on unRaid. I also installed Tdarr server and node on a Win10 Pro PC to work on the same media file repositry (on the unRaid server). I went to bed with everything working fine, but woke up to find a frozen unRaid server, and obviously a failed Tdarr operation. I had to do a hard reset of the unRaid server, and restarted Tdarr on both unRaid and the PC. After doing a fresh rescan everything appears to be running ok again. I have attached the log files and I would be very grateful if someone could check them and let me know if there is something I should be doing differently.

Cheers

Steve

Tdarr_Updater_Log.txt 1.34 kB · 0 downloads Unraid Node log for Tdarr.txt 28.55 kB · 1 download Unraid Server log for tdarr.txt 24.34 kB · 0 downloads Win10_Tdarr_Node_Log.txt 109.71 kB · 0 downloads Win10_Tdarr_Server_Log.txt 16.69 kB · 1 download

Seems to be due to the unraid mover. Solution here:

 

 

Link to comment
On 12/29/2021 at 8:24 PM, Steviewunda said:

I've had no more unRaid server freezes, but there are numerous files on the cache drive that should have moved - they have dates of 27th and 28th December (screenshot attached). Should I move them manually?

Tdarr 2021-12-30 092138.png

Might be there due to interruptions during processing. Compare them with your library files to see if they need to be deleted or not.

Link to comment
On 12/28/2021 at 10:47 PM, Dustin Turner said:

Unable to pull in Plugin IDs on TDarr Pro.

 

image.thumb.png.e1b67f1c7ee0a252d825b196e96d31d1.png

 

Running on Unraid 6.9.2 and is running fine with the CPU plugin. Wanted to add a library and start encoding with the GPU when I cam across this error.

 

I tried to do a force update on both the server and the node with no difference.

 

Thanks for the assistance. 

This was fixed shortly after it was first reported. Should be working fine now.

Link to comment
3 hours ago, mbppg said:

Hi, is there a way to reset all the stats? I was running a test folder and now I want to run on my real media folder but I would like to have all the stats reset to zero.

IIRC you select the library and then the clear stats option.

Link to comment

Hi all,

 

Just started messing with TDARR - and have it running.

 

Using an Unraid server (latest) and added TDARR server and node. Server running on an Dell R710 and have oodles of memory and 12 dual core Intel® Xeon® CPU X5675 @ 3.07GHz (24HT) 

 

I am using the plugins that came with including "Migz-Transcode Using Nvidia GPU & FFMPEG" plugin to do the heavy lifting.

 

I have an nvidia P400 video card installed and it shows up in the Unraid config and looks to be functioning all right.

 

I have 4200 files (TV and Movies) - So far there have been 326 transcodes - or so it says.

 

My question is where do I find the errors log for the transcode errors?

 

I currently have about 3200 transcoding errors which to me is a little high???

 

Also of concern is that I have only saved 4.2 GB in space so far....that seems light.

 

Need to find out what the errors are for - sounds like I have something configured wrong??

 

Let me know if you need any further info.....

 

Thanks in advance.

 

toolmanz

Link to comment

If you select the TDARR tab go to the bottom of the page and select Transcode: Error Cancelled you’ll see a list of video transcodes that were cancelled due to errors (default is 20). Each one has an info button next to it as well as requeue and ignore. If you select info you’ll get a popup with a description of the error.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.