[Support] HaveAGitGat - Tdarr: Audio/Video Library Analytics & Transcode Automation


Recommended Posts

16 hours ago, caplam said:

i found something strange.

I have only one node. Server and node are dockers on my unraid server with default parameters except for ip of course.

If i change the node name which is defaulted at "node name", the queue is stuck.

As soon as i set it to "node name" back the workers start.

What did you change the node name to? Also try restarting both the server and node.

Link to comment
7 hours ago, HaveAGitGat said:

What did you change the node name to? Also try restarting both the server and node.

i changed the name to "godzilla" and i also tried with "godzilla docker"

godzilla is the name of my unraid server.

Of i course i restarted both dockers.

Link to comment

Hi Everyone, I encountered a strange bug when running a docker update today.

 

The update caused the Server and Node to remove itself from 2 different servers. It seems like the 'Node Port:' variable got duplicated causing failures.

 

Removing the extra/duplicate 'Node Port:' line on the update container screen fixed everything.

Link to comment
7 minutes ago, Qzack7 said:

Hi Everyone, I encountered a strange bug when running a docker update today.

 

The update caused the Server and Node to remove itself from 2 different servers. It seems like the 'Node Port:' variable got duplicated causing failures.

 

Removing the extra/duplicate 'Node Port:' line on the update container screen fixed everything.

 

I was able to remove the extra "Node Port" on the tdarr docker template, but I still get an install failure for the tdarr node.  Any suggestions?

Link to comment
4 minutes ago, Iceman1199 said:

 

I was able to remove the extra "Node Port" on the tdarr docker template, but I still get an install failure for the tdarr node.  Any suggestions?

 

Nevermind....I noticed the tdarr node docker template also had a "node port" line.  Once I removed that, it was able to reinstall.  

Link to comment
4 minutes ago, Iceman1199 said:

 

I was able to remove the extra "Node Port" on the tdarr docker template, but I still get an install failure for the tdarr node.  Any suggestions?

Unlike the tdarr server template, the node template has two node port entries.  One at the bottom and the other close to the top third of the template.  Easy to overlook unlike the server template where it was one after another.

Link to comment
10 minutes ago, Troxx45 said:

Unlike the tdarr server template, the node template has two node port entries.  One at the bottom and the other close to the top third of the template.  Easy to overlook unlike the server template where it was one after another.

 

Yep, I only noticed it when looking through the failure notification on the 2nd to the bottom line when it kept complaining about the node port.

  • Like 1
Link to comment
49 minutes ago, Qzack7 said:

 

Yep, I only noticed it when looking through the failure notification on the 2nd to the bottom line when it kept complaining about the node port.

Ok good that it's working. So was it just an issue with your local template or does the main template need updating? (I'm not unRAID myself):

https://github.com/selfhosters/unRAID-CA-templates/blob/master/templates/tdarr_node.xml

Link to comment
On 2/28/2022 at 11:02 AM, caplam said:

i changed the name to "godzilla" and i also tried with "godzilla docker"

godzilla is the name of my unraid server.

Of i course i restarted both dockers.

Ok let me know if you have the same issue on 2.00.15 (out a few hours ago).

  • Like 1
Link to comment

My server automatically updated to the latest version over night and now my tdarr and tdarr node images are gone. I tried to reinstall using my previous templates but am getting an error "docker: Invalid containerPort: nodePort." and it won't install. 

 

It is using the same ports I was previously using, so I'm not sure where the issue is. 

 

And of course after posting, I found the problem. The container is pulling two entries for Node Port, one being 8264:8264 and the other being 8264:nodePort. So there's an issue with the template being pulled down. 

Edited by shelleya7801
issue update
Link to comment
8 minutes ago, shelleya7801 said:

My server automatically updated to the latest version over night and now my tdarr and tdarr node images are gone. I tried to reinstall using my previous templates but am getting an error "docker: Invalid containerPort: nodePort." and it won't install. 

 

It is using the same ports I was previously using, so I'm not sure where the issue is. 

 

And of course after posting, I found the problem. The container is pulling two entries for Node Port, one being 8264:8264 and the other being 8264:nodePort. So there's an issue with the template being pulled down. 

There was an issue with the template last week which was fixed last week. You can see template here:

https://github.com/selfhosters/unRAID-CA-templates/blob/master/templates/tdarr_node.xml

 

Not sure how the unRAID template updating works but seems you still had an old version I think.

Link to comment
2 minutes ago, HaveAGitGat said:

There was an issue with the template last week which was fixed last week. You can see template here:

https://github.com/selfhosters/unRAID-CA-templates/blob/master/templates/tdarr_node.xml

 

Not sure how the unRAID template updating works but seems you still had an old version I think.

Ahh I see that now. Not sure why it would have pulled an old template, as it automatically updated last night. I don't know how that part of the process works. Now that I have them up and running again, I forced an update and it didn't pull the wrong template so I guess my issue is resolved. Weird. 

Link to comment

I encountered the same issue as everyone else. I got everything installed again and up and running. However, using NVENC encoding all transcodes fail. The health checks go through ok but then when it comes time for the actual transcode to happen i get this error. 

 

[hevc_nvenc @ 0x5629e2d3e280] Specified rc mode is deprecated.

[hevc_nvenc @ 0x5629e2d3e280] Use -rc constqp/cbr/vbr, -tune and -multipass instead.

[hevc_nvenc @ 0x5629e2d3e280] InitializeEncoder failed: invalid param (8): Preset P1 to P7 not supported with older 2 Pass RC Modes(CBR_HQ, VBR_HQ) and cbr lowdelayEnable NV_ENC_RC_PARAMS::multiPass flag for two pass encoding and set

Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height

Conversion failed!

no settings at all have changed since reinstalling. the extra parameters, gpu id, and capabilities are all in there. from the error im seeing could it be an issue with the plugin im using? the one i am using is:

Tdarr_Plugin_vdka_Tiered_NVENC_CQV_BASED_CONFIGURABLE

 

any help would be appreciated

Link to comment
29 minutes ago, Margucci said:

I encountered the same issue as everyone else. I got everything installed again and up and running. However, using NVENC encoding all transcodes fail. The health checks go through ok but then when it comes time for the actual transcode to happen i get this error. 

 

[hevc_nvenc @ 0x5629e2d3e280] Specified rc mode is deprecated.

[hevc_nvenc @ 0x5629e2d3e280] Use -rc constqp/cbr/vbr, -tune and -multipass instead.

[hevc_nvenc @ 0x5629e2d3e280] InitializeEncoder failed: invalid param (8): Preset P1 to P7 not supported with older 2 Pass RC Modes(CBR_HQ, VBR_HQ) and cbr lowdelayEnable NV_ENC_RC_PARAMS::multiPass flag for two pass encoding and set

Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height

Conversion failed!

no settings at all have changed since reinstalling. the extra parameters, gpu id, and capabilities are all in there. from the error im seeing could it be an issue with the plugin im using? the one i am using is:

Tdarr_Plugin_vdka_Tiered_NVENC_CQV_BASED_CONFIGURABLE

 

any help would be appreciated

Which version did you update from? The issue is the the FFmpeg version was updated in December and the syntax is slightly different for some things.

Link to comment
Just now, HaveAGitGat said:

Which version did you update from? The issue is the the FFmpeg version was updated in December and the syntax is slightly different for some things.

i have been keeping up to date on the updates. so it was whichever version was current yesterday. so is it a plugin thing that it needs to be updated to account for the changes? even then, i didnt see anything in the notes about it being updated between 2 days ago and now. 

Link to comment
2 minutes ago, Margucci said:

i have been keeping up to date on the updates. so it was whichever version was current yesterday. so is it a plugin thing that it needs to be updated to account for the changes? even then, i didnt see anything in the notes about it being updated between 2 days ago and now. 

Yesterday was 2.00.14 which uses the same FFmpeg as 2.00.15 today, you can see the Dockerfile here:

https://github.com/HaveAGitGat/Tdarr/blob/master/docker/Dockerfile

 

So if it was working before it should be working now too. The FFmpeg update was mentioned in the 2.00.12 [12th December 2021] notes.

 

I’ll check with Vodka about that plug-in. I think you can remove the vbr_hq from that plug-in to make it work.

 

 

 

 

Link to comment
2 hours ago, HaveAGitGat said:

I’ll check with Vodka about that plug-in. I think you can remove the vbr_hq from that plug-in to make it work.

 

i removed the "-rc vbr_hq" from the profiles in the plugin and it does work again, however at a slower speed. should i have removed just the "vbr_hq" leaving the "-rc" in there? i have virtually no experience with ffmpeg. 

 

thanks a ton for the help though. at least its working now

 

EDIT

 

worked everything out. thanks for pointing me in the proper direction initially. 

Edited by Margucci
Link to comment

So after fixing the port assignment issue in the container template I cannot get GPU encoding to work on either the internal node or the tdarr_node container. Did something else change here that we need to know about? I haven't changed any of the settings besides transferring them to the tdarr_server node since yesterday and now only CPU encoding on the internal node is working. I tested the old tdarr_node install as well and GPU transcoding is not working there anymore either. 

Link to comment
7 hours ago, jjwood44@gmail.com said:

So after fixing the port assignment issue in the container template I cannot get GPU encoding to work on either the internal node or the tdarr_node container. Did something else change here that we need to know about? I haven't changed any of the settings besides transferring them to the tdarr_server node since yesterday and now only CPU encoding on the internal node is working. I tested the old tdarr_node install as well and GPU transcoding is not working there anymore either. 

 

8 hours ago, Margucci said:

 

i removed the "-rc vbr_hq" from the profiles in the plugin and it does work again, however at a slower speed. should i have removed just the "vbr_hq" leaving the "-rc" in there? i have virtually no experience with ffmpeg. 

 

thanks a ton for the help though. at least its working now

 

EDIT

 

worked everything out. thanks for pointing me in the proper direction initially. 

 

It was most likely due to this update with FFmpeg:
https://github.com/HaveAGitGat/Tdarr/issues/555
I've rolled back the FFmpeg version so if you pull the latest image (2.00.15.1) then it should work as before. Let me know if you have any issues.

  • Like 1
Link to comment
39 minutes ago, HaveAGitGat said:

It was most likely due to this update with FFmpeg:
https://github.com/HaveAGitGat/Tdarr/issues/555
I've rolled back the FFmpeg version so if you pull the latest image (2.00.15.1) then it should work as before. Let me know if you have any issues.

looks like vbr_hq is still causing an issue. it just needs to be replaced in the plugin with vbr (although it looks like it sets that as the default anyways so the entire "-rc vbr_hq" can be deleted. i did some testing with and without and the file size comes to the exact same thing. i did come across an update to the nvenc presets from last year:

https://docs.nvidia.com/video-technologies/video-codec-sdk/nvenc-preset-migration-guide/

 

so it looks like it isnt a FFmpeg issue, but a nvenc issue. 

 

also, is it possible to do a feature request. an option to only replace if the converted file is smaller than the original one. otherwise the converted one is discarded. i find that some low quality webrips in 264 are sometimes already decently small and encoding them to 265 if you prefer higher quality where available results in an increase in file size. 

Edited by Margucci
Link to comment
48 minutes ago, Margucci said:

looks like vbr_hq is still causing an issue. it just needs to be replaced in the plugin with vbr (although it looks like it sets that as the default anyways so the entire "-rc vbr_hq" can be deleted. i did some testing with and without and the file size comes to the exact same thing. i did come across an update to the nvenc presets from last year:

https://docs.nvidia.com/video-technologies/video-codec-sdk/nvenc-preset-migration-guide/

 

so it looks like it isnt a FFmpeg issue, but a nvenc issue. 

 

also, is it possible to do a feature request. an option to only replace if the converted file is smaller than the original one. otherwise the converted one is discarded. i find that some low quality webrips in 264 are sometimes already decently small and encoding them to 265 if you prefer higher quality where available results in an increase in file size. 

 I did create a PR for removing that a while ago but wasn’t sure if it would break things for some people. Have a look at this:

 

https://github.com/HaveAGitGat/Tdarr_Plugins/pull/223/files

 

For the new file size check, have a look at this plugin. 

 

Tdarr_Plugin_a9he_New_file_size_check

 

Add it anywhere in your plug-in stack. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.