Jump to content

[Support] HaveAGitGat - Tdarr: Audio/Video Library Analytics & Transcode Automation


Recommended Posts

Did a ton of reading on this, but it seems hard to keep up with the evolving hardware and software quite recently. 

Is there is known working method to use Tdarr with 12th gen intel iGPU Quick Sync?

There's no plugins available under the "QSV H265" selection in the plugin page that are referenced in many "how to's".

I got it to work with one plugin, but the videos were transcoded improperly and corrupted. Other plugins seem to fail transcode with a "GPU needed" or some other obscure error that isn't apparent what happened. 

Link to comment
  • 3 weeks later...

Does anybody know a resolution for the "infinite loop" issue?

 

I have a simple stack to change Youtube videos from VP09 / Opus to hvec/AAC so safari on Mac can use them. I can use mandrake to do this just fine, but when I use ffmpeg with havoc_nvenc I just get this annoying error, with no real solution.

 

I am using the three plugins in the stack;

Tdarr_Plugin_00td_filter_by_size

Tdarr_Plugin_075a_Transcode_Customisable 

Tdarr_Plugin_a9he_New_file_size_check

 

Pulling my hair out. This is wasting a tonne of time, as it transcodes the video just fine, then spits this error at the end.

Edited by CasaP
Link to comment

My node seems to be copying files to cache for transcode, but then never returning them even though they are completed and it is set to work in place with all output settings turned off.  The media share itself is set to disk only yet now files in that share are on the ssd cache used for transcode 

646853029_Screenshot2022-10-18at11_47_45PM.thumb.png.a1374f590caee0ce8be45fbcee4e661a.png

 

 

Screenshot 2022-10-18 at 11.48.29 PM.png

Screenshot 2022-10-18 at 11.54.45 PM.png

Link to comment

I'm seeing strange CPU spikes with the Tdarr server idling on my system. I want to keep it up so that new stuff automatically gets transcoded as added, but this weird idling behavior makes me want to turn it off. The server is causing a CPU spike consistently (up to 50% on every logical core) every 30 seconds. Using htop I have deduced that it is some shfs operation. Any idea what this might be or how to mitigate it? The Tdarr logs don't show anything about it. just the standard hourly check. Attaching screenshots for reference: 1 of CPU graph with Tdarr server stopped, 1 of CPU graph with Tdarr server started, and one of htop filtered to shfs at time of a spike

 

Anyone seen this before and/or know how to mitigate it or should I just shut it off when not actively in use?

Tdarr Server On.PNG

Tdarr Server Off.PNG

Tdar Server htop.PNG

Link to comment
On 9/29/2022 at 12:28 PM, frodr said:

I'm still having an error with the mapping. Most grateful for any tips how to fix this. 

 

 

Screenshot 2022-09-29 at 16.25.11.png

Screenshot 2022-09-29 at 16.25.35.png

 

Are you able to access your mapped network drives through windows file explorer? I only have this error pop up when my connection to the mapped drives fails. have you gotten it to run before and this just popped up or are you setting up for the first time?

 

Edit: Just scrolled up further and saw you're just setting it up. My first part still stands though.

Edited by rcm024
Link to comment
1 hour ago, rcm024 said:

 

Are you able to access your mapped network drives through windows file explorer? I only have this error pop up when my connection to the mapped drives fails. have you gotten it to run before and this just popped up or are you setting up for the first time?

 

Edit: Just scrolled up further and saw you're just setting it up. My first part still stands though.

 

Yes, I am.

Link to comment

I have a question about the 'Watched/Unwatched' status in Plex. The 'Unwatched' flag is being reset in Plex for Movie encodes, but not for TV encodes. I would like to stop it happening for movies too but can't figure out why it is happening.  I have the Tdarr plug in that keeps the file date unchanged and I also have the ' Empty trash automatically after every scan' option turned OFF in Plex library scans which I had thought was the solution to this problem. Does anyone know how to fix this?

Link to comment
  • 2 weeks later...

Spent all day yesterday messing about with Tdarr which I really wanted to work - slapped in my GTX770 and tried to get my mac as a second node before realising that the Nvidia card won’t transcode to h265, sigh and the Mac node wasn’t working at all.

 

I know this part is off track but no one else has any idea - i decided to try a server/client on my mac and eventually realised i had to download a different version of ffmpeg and handbrakecli to link to which worked but scanning anything (network or local) gives the following error for every file

 

Quote

ffprobe encountered a silent error while extracting data

Does this mean anything to anyone?

Link to comment

Hi all,

 

Most like I would be the first to run into this 'problem', but i couldn't find the answer in this thread or on the interwebs. I would like to keep a copy of both the original 4K version and a 1080p version in the same folder. This is because not all devices are capable of playback native 4K. I am using Radarr and Tdarr, Radarr places the files in /mnt/user/films and thats also the working directory for Tdarr. 

 

My first step is currently to transcode the movie to hevc if it isn't already, regardless of the resolution, next I would like to transcode the hevc version to 1080p. But I cant seem to figure out what would be a good workable solution.

 

the transcoding proces is setup as followed:

Library A: remove image from file, reorder streams, clean audio, remove subs, ffmpeg transcode to hevc, new file check, rename based on codec and resolution.

Library B: Filter on resolution (only proces anythink about 1080p), ffmpeg to 1080p in hevc, new file check, rename based on codec and resolution.

 

I tried all kinds of different setups with the processing folders. Same working folders, without deleting souce and with deleting, different working folders, you name it. Ideally I would like to store the different files from one movie in the same folder as this would be a lot easier to maintain in my oppinion. 

 

Is this even possible and if so how could this be done?

Thanks in advance!

Link to comment

Trying to install this with the nvidia code

 

--runtime=nvidia
nvidia_visible_devices = gpu-cebda6e6-708f-e91a-2d79-10b788f6cad1 nvidia_driver_capabilities = all

 

I get this get this error:

 

docker run
  -d
  --name='tdarr'
  --net='bridge'
  -e TZ="Europe/London"
  -e HOST_OS="Unraid"
  -e HOST_HOSTNAME="Moulin-Rouge"
  -e HOST_CONTAINERNAME="tdarr"
  -e 'serverIP'='0.0.0.0'
  -e 'internalNode'='false'
  -e 'nodeIP'='0.0.0.0'
  -e 'nodeID'='MyInternalNode'
  -e 'PUID'='99'
  -e 'PGID'='100'
  -l net.unraid.docker.managed=dockerman
  -l net.unraid.docker.webui='http://[IP]:[PORT:8265]'
  -l net.unraid.docker.icon='https://raw.githubusercontent.com/selfhosters/unRAID-CA-templates/master/templates/img/tdarr.png'
  -p '8266:8266/tcp'
  -p '8265:8265/tcp'
  -p '8264:8264/tcp'
  -v '/mnt/user/appdata/tdarr/server':'/app/server':'rw'
  -v '/mnt/user/appdata/tdarr/configs':'/app/configs':'rw'
  -v '/mnt/user/appdata/tdarr/logs':'/app/logs':'rw'
  -v '/mnt/user/data/media/':'/mnt/media':'rw'
  -v '/mnt/user/data/transcode/':'/temp':'rw'
  --runtime=nvidia nvidia_visible_devices = gpu-cebda6e6-708f-e91a-2d79-10b788f6cad1 nvidia_driver_capabilities = all 'ghcr.io/haveagitgat/tdarr' 
Unable to find image 'nvidia_visible_devices:latest' locally
docker: Error response from daemon: pull access denied for nvidia_visible_devices, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.
See 'docker run --help'.

The command failed.

 

Link to comment

New to Unraid and Docker - and Tdarr.

 

Using SpaceInvaders video guide, trying to install Tdarr, Server and Node on the same machine, I have put an Nvidia Quadro M2000 in to use for transcoding.

Tdarr Server installs OK but when I install the node, it fails with -

 

  --runtime=nvidia 'ghcr.io/haveagitgat/tdarr_node'

a99cc26e75915d680d95c07f342ba3d1c2286dc1f706b09f94b3e67d7ef71344
docker: Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error running hook #1: error running hook: exit status 1, stdout: , stderr: Auto-detected mode as 'legacy'
nvidia-container-cli: device error: GPU-a520d801-9ccc-8ee7-9e21-5eb3beeb7428: unknown device: unknown.

 

 

I have googled "Auto-detected mode as 'legacy'" and found that I need to run 'nvidia-persistenced' but that didn't make any noticable difference.

There is no Tdarr_Node_Log.txt and I'm not really sure where to go to investigate this?

Link to comment

I THINK the clue was in "Auto-detected mode as 'legacy'" but in a round about way.

 

I had followed SpaceInvaders video guide on Tdarr and he does state that there are issues with UEFI boot or at least he has issues with it so I have been using non-UEFI boot aka 'legacy'.

I have started using UEFI boot and re-installed unraid and Tdarr and have managed to get Tdarr node running.

 

So, for whatever reason SpaceInvader had to use legacy boot I have to use UEFI boot - it is a solution but I don't know why it is a solution!

Edited by MacOwens
spelling
Link to comment
  • 3 weeks later...

Hi Guys,
I need the plugin Tdarr_Plugin_DOOM_NVENC_Tiered_MKV_CleanAll
but i always get an error message

Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height

 

On all files. other plugins work fine.
someone an idea?

Link to comment
  • 2 weeks later...

Does tdarr work with AV1 encoder? I ordered a Intel Arc A770 16GB gpu just to encode my entire unraid library (170tb) more efficiently and started configuring my tdarr docker pre-emptively. Sadly I don't see an AV1 encoder in the list but on reddit I see people using it with tdarr. So I am curious if there are codecs that the docker does not have access to yet or what I need to do to make it work.

 

Any help is deeply appreciated. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...