Jump to content
Vlash

Parity rebuild troubles.

4 posts in this topic Last Reply

Recommended Posts

I've done a lot of searching and reading on my current state, or at least those similar to my situation, but thought it would be best to get feedback and possibly learn something from those more experienced than I.

 

My issues started after I had a disk red balled, and I replaced it. The very next drive I installed didn't last but 2 minutes on the rebuild before it too was red balled. Then yet again with a third disk. Also two other disk were reporting spin retry errors as well.

 

After some searching and almost everything I had found was saying the controller could be bad. I did make check all the cable connections before I done anything else and then decided to try another controller. I already had a backup in case something ever happened to the current controller. It solved these issues. And I got back up and running.

 

That only lasted for a few days. My parity drive dropped off line, it was red balled. So I replaced the drive. That's when the rest has come into play.

 

The parity was being rebuilt, and everything seemed normal. Then I started getting tremendous lag when I tried to access my movies share. Most of the time it would not even load a movie on Kodi on my Pi. Would load on my desktop but none of the Pi's, only it would freeze up. Sometimes it would play sometime it would not. Now my tv shared had no problem just the movie shares. Thought it might be one of the docker apps causing an issue. Well I noticed that the parity rebuild was going to take something like 400+ days to complete. I knew something wasn't right but I'm not exactly sure what it is. I made sure my docker apps were not running. All but MySQL docker as I use it for my database for my Kodi installs. I have noticed a odd sound around my drives the last few days. Like a tick the almost like I hear it writing data the the tick again, and it's almost always going. Stops for a few minutes then starts again. I can only assume something is wrong with this drive.

 

I have added my diagnostics zip and the drive in question is drive 2 (ST6000VN0033-2EE110 ZAD4Q85T) I know the parity drive is red balled right now, but could it be because it was unable to write data that it might not have been able to retrieve from drive 2?

 

Also many many more questions about the smart logs and those high numbers for raw read error rate that appeared recently, and if I'm even reading the right columns to check if my disk are going bad.

 

Sorry for this very long post, but wanted to get as much information as I could think of posted.

 

 

tower-diagnostics-20191009-0616.zip

Share this post


Link to post

Parity dropped offline so there's no SMART, but looks more like a connection/power problem, especially since it's been happening to multiple drives, since you already replaced the controller I would try a different PSU if you can.

Share this post


Link to post

Ok thanks.

As soon as I get home this weekend I will set to work on that.

Share this post


Link to post

That done the trick. Can't believe I didn't think of that tbh. Just had a nasty storm roll through a few days ago. Lightening strike was .2 miles from house. Lost a power line network adapter and two HDMI ports on a TV.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.