Jump to content
juan11perez

Unraid 6.7.2 on Ryzen - Cant Passthrough GPU

9 posts in this topic Last Reply

Recommended Posts

Good day. Looking for some guidance. I have migrated my setup to an asus AMD X470 ATX Gaming motherboard, ryzen 2700x, adata 512gb m.2, 2 x 16Gb gskill 3200 mhz ram and 3 x 4TB HDDs. I have installed 2 gpus: 1 x 570 Amd Sapphire (in pci 1) and 1 x Gigabyte 1650 (in pci 2).

I have attempted passing the 1650 to a windows, ubuntu and mint vm with no success. Have followed space invader tutorials, read the arch and also bound the gpu to vfio via boot/config/vfio-pci.cfg.

When I start the vm it takes about a minute to start, but all I get is a blank screen. I also started them via the virtmanager docker and was able to see that the vm os just locks. on the windows case i saw "windows repairing" or similar. On the linux machines I get a black screen.

 

the server side is stable, got 55 dockers running with no issues.

Any guidance, advice is much appreciated. 

Share this post


Link to post

Sorry, I'm just running off to bed lol, but suspect it will be a BIOS thing - so I'd look into that.  If you're running latest BIOS, I believe you have to downgrade it (spaceinvader has a quick tutorial on that I believe).  Alterntively there are other BIOS settings that need to be right.  I know that's not very specific, but might point you in a new direction to try.

Share this post


Link to post

@Marshalleq thank you for your response. The board is indeed in the latest bios. I just updated unraid to 6.8.0rc to try, but same result.

if you can point in the direction of alternative bios settings literature, I'd appreciate it. 

Share this post


Link to post

Good morning. :D

 

If I remember correctly it was to do with the Agesa version on the bios, so you need to go through the BIOS update notes for your particular motherboard and find the version with a previous agesa version.  From there the GPU passthrough should work.

 

I am assuming you're able to downgrade a BIOS given what you've achieved so far - the main thing is don't power off the computer in the middle or you will either brick your motherboard or if you've got one of those newer boards with protection - it'll just be harder for you to fix.

 

These topics should help.

 

https://community.amd.com/thread/241650

 

Marshalleq

Share this post


Link to post

@Marshalleq thank you again for your help. And you were absolutely correct. So I downgraded my bios to the version before the upgrade for the Ryzen 3000 series and success!!! 

I can pass through the graphics card.

Downgrading was a bit nerve-racking ;-) couldnt use space invaders guide as the asus bios extension is different and didnt pass the test he proposed in the vidio. So I found this video 

 which works perfect for Asus motherboards .....

 

Thank you again. I tried all sorts over the last 3 days and your tip pointed me in the right direction.

 

Edited by juan11perez

Share this post


Link to post

No problem.  These days BIOS updates are pretty safe, but it's still good to be mindful and understand the risks.

 

Regarding the keyboard - what should happen is it shows up like the attached and you can tick it on.  You can't tick it on though if another VM has it assigned AND it's running.  So check that.

 

If it doesn't show up, that's a concern.  If it does, you 'should' be able to tick it on.

 

Ignore the 'other PCI devices; section in this screenshot - that's what you can do when you stub a device to hide it from Unraid and show it to VM's.  You shouldn't have to ever do this for Network cards unless you're running a firewall or something (not recommended).  Or wanting to pass through a whole disk for a VM for speed - e.g. a gaming VM.

 

825964307_ScreenShot2019-10-13at11_22_40.thumb.png.a04fefca39d4d8c325d22b43cf0eb411.png

Share this post


Link to post

@juan11perez Would you mind telling us the exact model of your motherboard and the version of the BIOS that you found to work, please? It might help someone else with the same problem. Thanks.

Share this post


Link to post

@Marshalleq once again thank you. The issue was simpler than expected. I just had to select USB controller 3.0 and it worked.

 

@John_M off course. Asus ROG STRIX X470-F GAMING motherboard. And the working bios is Version 4207 2018/12/17

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.