Catalina network bridging weirdness


bland328

Recommended Posts

On 10/24/2019 at 11:03 AM, glennv said:


unfortunately that is the only real solid solution to proper network in osx vm. Fought with virtual nics for months . A setup i used for a while was use the vmnet3 for the main network card and the e1000 defined as en0 but disabled. Only its existance as en0 is relevant enough for icloud/appstore, does not have to be active.
But eventualy it was just too slow and moved to a cheap 4 port intel 1gb nic and give every vm its own physical network post passed thru. A world of difference in stability, speed (full line speed) and struggling with virtual io has looking back been a big waste of time.

Although it's been a while, but could you elaborate on that? For some reason I really struggle with the NIC passthrough, although I thought with Intel NICs it shouldn't be much of an issue. macOS doesn't recognize any ethernet devices when I pass the NIC through. I’ve tried passing through only one port or two ports with multifunction on (similar to a GPU passthrough). Have you installed any kexts? I have tried IntelMausiEthernet, I’ll probably remove that and see if it helps...

Link to comment

To answer my question myself: I finally succeeded by using the E1000 kext (https://github.com/chris1111/AppleIntelE1000e) with my Intel NIC. I haven’t really done any performance tests yet, but I suspect that with the real NIC in passthrough it should be much better than any virtual NIC. I haven’t completely figured out yet why the IntelMausiEthernet kext is not working yet, but as I read on another forum that the guy who built that kext removed some older chipsets, I guess he removed support for the chipset my NIC is using.

 

Edit: I could verify this assumption. My card seems to be using the 82571 chipset, which is not supported by IntelMausiEthernet anymore. Hopefully the older E1000 kext will prove to be stable, otherwise I might have to upgrade my card.

Edited by aureus
Link to comment

Sorry for the late reply. Missed your post but looks like you found a solution. Indeed i used a driver to get my intel up and running in OSX and similarly to my 10G intels i use Smalltree's drivers for both 1G and 10G.

For the 1G it only required a patch in clover and for 10G it required a small patch of the network card bios (super simple) so the driver thinks its a real smalltree card.

But good you got it working. Should be much faster and the fact thats its an old driver should (at least for 1G) not matter much. Run an iperf3 test between client and server and you will see how fast it is. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.