[Support] SpaceinvaderOne - Macinabox


Recommended Posts

14 minutes ago, frodr said:

I did. I have followed your video step by step. 

I deleted the Macinabox Container, deleted the template and  /appdata/macinabox. Pluss deleted the scripts. 

 

Then added the Macinabox Container as per video and edited the helper user script. Macinabox Container WebUI points to the Youtube video. 

Link to comment
59 minutes ago, shaunmccloud said:

Here you go.

2020-12-10_09-29-21.png

You havent finished the install.  The base system is the install media. The macOS installer is your big sur disk. Just select it and it will continue installing. (it has named itsself macOS installer because when you formatted the disk in disk utility you didnt name it)

It will restart to this bootloader a few times during install just keep pressing enter to continue each time and the install will finish

Link to comment
38 minutes ago, frodr said:

I deleted the Macinabox Container, deleted the template and  /appdata/macinabox. Pluss deleted the scripts. 

 

Then added the Macinabox Container as per video and edited the helper user script. Macinabox Container WebUI points to the Youtube video. 

If when clicking webui it goes to the old macinabox youtube video then the old template was still installed when you downloaded the container. (this is not in the new template - so it has now just merged the pld and new template together)

 

Please delete the container. Then goto the bottom of the docker page. Click add template. Then click select template. From the list of your previously installed templates choose macinabox. Then to the right of its name click the black cross. It will remove the template. Then goto the apps tab search for and install macinabox and it will download the template from ca and install the new one. :)

 

Link to comment

Any way to have the boot manager auto select the bigsur disk when starting?

 

I'm trying to have VM with graphics card pass through, and currently have a wireless keyboard/mouse (logitech) and on the bootloader screen, can't click the volume to boot.

 

Works fine when using VNC as obviously using the host keyboard/mouse.

Edited by digidep
Link to comment
8 minutes ago, digidep said:

Any way to have the boot manager auto select the bigsur disk when starting?

Set your boot disk from within mac os, then check ShowPicker property in the config.plist, to automatically boot without user interaction you need it set to false.

Otherwise, if you want the picker (what you call boot manager) to always show, set it to true, but change the timeout value.

I recommend all to read opencore documentation:

https://github.com/acidanthera/OpenCorePkg/blob/master/Docs/Configuration.pdf

 

All is well documented.

Edited by ghost82
Link to comment
48 minutes ago, SpaceInvaderOne said:

If when clicking webui it goes to the old macinabox youtube video then the old template was still installed when you downloaded the container. (this is not in the new template - so it has now just merged the pld and new template together)

 

Please delete the container. Then goto the bottom of the docker page. Click add template. Then click select template. From the list of your previously installed templates choose macinabox. Then to the right of its name click the black cross. It will remove the template. Then goto the apps tab search for and install macinabox and it will download the template from ca and install the new one. :)

 

This is exactly what I did. I double checked if it was deleted. I actually made a picture of it in case you said what you just stated. See screenshots. Do you want me to do the same process again?

Screenshot 2020-12-10 at 16.35.27.png

Screenshot 2020-12-10 at 16.37.25.png

Link to comment
18 minutes ago, frodr said:

This is exactly what I did. I double checked if it was deleted. I actually made a picture of it in case you said what you just stated. See screenshots. Do you want me to do the same process again?

Screenshot 2020-12-10 at 16.35.27.png

Screenshot 2020-12-10 at 16.37.25.png

Yes you can try again or if you would rather just change the location (in advanced view)  to http://[IP]:[PORT:7800] 

Link to comment
9 minutes ago, Cuacococo said:

Hi mickeyosm and thank to your reply,

 

I've done everything you've explained but I have this error message and I'm not sure what to do. I've only been on Unraid for a month, I'm a big beginner.

 

Have you a lead to give me.

Install netcat-openbsd-1.105 in Nerd Tools/Nerd Pack. If you haven't installed Nerd Pack, do so in Community Applications.

  • Thanks 1
Link to comment

Looks like after docker install its pulled down install and opencore into ISOS folder and I have a bigSur folder in domains with a 100GB disk however vmready_notify is still running and no VM is present in list. Been a few hours so i'm assuming its not still downloading. Any logs to check to help figure out where its stuck?

 

I regret every day when I setup UnRaid for the first time I changed "appdata" to "docker" :) updated both scripts to look in proper directory and poof there is a VM in my list!!

Edited by jsmontague
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.