[Support] SpaceinvaderOne - Macinabox


2140 posts in this topic Last Reply

Recommended Posts

  • Replies 2.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

PLEASE - PLEASE - PLEASE EVERYONE POSTING IN THIS THREAD IF YOU POST YOUR XML FOR THE VM HERE PLEASE REMOVE/OBSCURE THE OSK KEY AT THE BOTTOM. IT IS AGAINST THE RULES OF THE FORUM FOR OSK K

09 Dec 2020   Basic usage instructions.   Macinabox needs the following other apps to be installed. CA User Scripts (macinabox will inject a user script. This is what fixes th

Do you like this for an icon? I think its appropriate.

Posted Images

1 hour ago, PGC77 said:

So when I want both (Unraid Server and macOS VM) to be connected via 10 GbE, I need tow separate NICs, right?

 

Yes. Once passed through to a VM the NIC isn't available to Unraid.

 

Link to post

Has anyone an idea why the vm dont pop up in the VM Manager? Isos and img are created. I can see them in the shares.

 

edit. I tryed to create a custom VM. i could not safe because of some issues, but the Mac VM from the tool is now visible in the VM Manager ^^. Now i must fix the Network Issue

Edited by Paincookie
Link to post
4 hours ago, Paincookie said:

Has anyone an idea why the vm dont pop up in the VM Manager?

 

Have you changed any of the paths or the name of the container? The paths in the helper script are hard-coded and will fail if you don't use the defaults. Even changing the name from "macinabox" to "Macinabox" breaks the script.

 

Link to post
7 hours ago, redQs said:

does anybody know why the base system partition dont show up?..

 

You're pointing at it!

 

That utility is the EFI partition mounter and the volumes you're interested in are the bootloader, at the bottom, and the disk that you are in the process of making your system disk, above it. At the point you've reached the Base System has done its job and you don't need it any more.

 

See the video at timecode 11:18.

 

Link to post
15 hours ago, John_M said:

 

You're pointing at it!

 

That utility is the EFI partition mounter and the volumes you're interested in are the bootloader, at the bottom, and the disk that you are in the process of making your system disk, above it. At the point you've reached the Base System has done its job and you don't need it any more.

 

See the video at timecode 11:18.

 

oh wow.. you are right..

i was just confused becaus the 3. disk is missing by me but i dont even need it... 
realy thank you :D

Link to post

For some reason, the new macinabox won't download Big Sur. Its only downloading Catalina. Big Sur is selected but it downloads macOS Product 061-86291 which is Catalina. I've wiped out the appdata location, the docker template and any other trace of macinabox. Restart from scratch and it again downloads Catalina.  I'm using download method 2 right now but I am unsure if its doing anything.  My download speed is about what it is when my server is idle.  I let it sit for a good 10 minutes and nothing changed in the log.

 

Small side note...don't try to upgrade Catalina to Big Sur.  It uh, almost works.  

 

BIG side note.  I was wrong.  It does work.  Upgrade was successful.

Edited by johnomaz
Link to post
2 hours ago, johnomaz said:

For some reason, the new macinabox won't download Big Sur. Its only downloading Catalina. Big Sur is selected but it downloads macOS Product 061-86291 which is Catalina.

 

This is a know issue and has been mentioned many times before. If only people would read the previous two or three pages before panicking, you'd actually save yourself a lot of time.

 

 

Link to post

Wow! A few years back I built a hackintosh on an older dell 780. It took me about a month to figure it out. 

This is incredible!

 

One question....is it safe to install the updates? The warning popped up right after the install.

 

Also...I have an old GTX 580 graphics card....wasn't going to install it in my unraid but I think I will now just to try out the graphics pass through. I need to watch that part again.....I'm a little fuzzy on that process.

Edited by bclinton
Link to post

Just a heads up for anybody, do NOT follow the first part of the tutorial if your VM path is not the default in /mnt/user/.  The video briefly mentions to change a few paths if you do not use the default, but fails to mention that if you do not use the default paths, even if you have changed all the paths to where yours are in the template, the user script will still fail as no matter what, the script is set to work with the default path.

So here's what you do.

Setup everything in the video up to the 7:50 marker.  Make sure you swapped out all the custom paths fields.  These are: 

 

VM Images Location:
VM Images Location again:
Isos Share Location:
Isos Share Location again:
custom ovmf location:
(It says dont change this, but change it anyway, because if you run Vms off an unassigned drive or cache drive, you wont have a /mnt/user/system folder)
appdata:
Macinabox only data:

Basesystem: (This is just a temp folder, you dont need to change it but I did anyway)

 

First off, you might not see any user scripts appear because they are set to appear AFTER the download for some reason.  The best way to check on the download progress is to navigate to /Whatever.disk.or.path.your.app.data.folder.is.in/appdata/macinabox/basesystem .  Take a look and a file in there will be growing in filesize.  Once its done that file will disappear and the user scripts will appear.

 

Now ignore the macinabox_vmready_notify.sh user script.  Not only is the path for your appdata location going to be wrong, (which is why you were never notified on completion), but there's no point to it anyway because you know you're done downloading.  Now you need to edit the macinabox_helper_userscript.sh file.  You can do this in userscripts by selecting the gear icon and hitting edit. 

 

Change the line NAME="put the name of the vm from template here" to NAME="Macinabox Big Sur"
Now read through the script and edit all the paths to your custom paths.  So like /mnt/user/appdata becomes /Whatever.disk.or.path.your.app.data.folder.is.in/appdata and /mnt/user/system/custom_ovmf/ becomes /Whatever.disk.or.path.your.custom_ovmf.folder.is etc etc. 

 

Now run the script.  Hopefully it worked and you can head over to the VM tab and see your VM.  If it fails for whatever reason,  navigate to your /appdata/macinabox/macinabox folder and look for the file Macinabox BigSur_original.xml.  Open it up and change any paths inside to match your paths.  Now select all the text and hit copy.  Now goto the VM tab in unraid - Add New - Custom, and paste in the contents of that xml.  That should be it.  The VM should now be there and you can continue to follow the video.

Took me a while to figure all this out, hope it helps somebody else.

Edited by 007craft
Link to post

Hi, Firstly thank you for your work on this, it's all awesome.

 

I have used this and very happy, but want to start a fresh, so wanted to know how to basically trash and start again.

I have tried but after macinabox is downloaded again, I'm now missing the scripts and the virtmanager fails to load, so I've messed up something.

 

Any pointer or help would be appreciated.

Link to post

Everything used to work well. I then switched from GPU (passthrough) to VNC, which didn't work. I got some error message, which I didn't write down. I then switched back to GPU. Unfortunately, the VM now no longer starts. I don't have a minotor attached, so don't know what's going on. The log is not particularly helpful (see below). Any thoughts?

 

2021-02-13 10:22:29.526+0000: Domain id=2 is tainted: high-privileges
2021-02-13 10:22:29.526+0000: Domain id=2 is tainted: custom-argv
2021-02-13 10:22:29.526+0000: Domain id=2 is tainted: host-cpu
char device redirected to /dev/pts/1 (label charserial0)

Link to post

I wiped everything and tried to install Big Sur......it keeps installing Cataline which was the first thing I installed. I checked the ISO folder and it looks like Big Sur downloaded.

 

The only thing in my ISO folder is the Big Sur image. I am wondering how/why it is installing Catalina.

Edited by bclinton
Link to post
48 minutes ago, 007craft said:

That was a typo. /mnt/user as used throughout the rest of my post. I edited the post.

I figured as much, but small things like that can torpedo users who don't know any better and blindly follow what's typed. Accuracy is very important.

Link to post
11 minutes ago, 007craft said:

I have my Mac Big Sur Vm up and running without issue, but once I switch to my Graphcis card, how exactly do I view the VM?  Web Gui is now gone now that I'm not using VNCCapture.thumb.PNG.fb632e885d6e77f6cf4b3b48b189adfc.PNG

 

Same question here. When I did that and tried to go back to VNC the image no longer works. VNC says the session no longer send an image or something like that. 

Link to post
16 hours ago, bevinet said:

Hi, Firstly thank you for your work on this, it's all awesome.

 

I have used this and very happy, but want to start a fresh, so wanted to know how to basically trash and start again.

I have tried but after macinabox is downloaded again, I'm now missing the scripts and the virtmanager fails to load, so I've messed up something.

 

Any pointer or help would be appreciated.

 

Here is what I have had success with so far.....selected the Big Sur install.....the VM installed Catalina.....after the install and as soon as you get there is an upgrade available warning (do not go to the next step) immediately start the upgrade....after several reboots it will finish.....you will once again get an upgrade available message after it upgrades catalina to big sur.....do that too...it reboots a lot. After loading Catalina and installing the 2 upgrades you will have Big Sur running with the latest patches. That is when I went on and did the next step in the video and all is fine. I had no luck going back in and trying to pass through a video card after I was on Big Sur. It just made it unbootable for me. So, long story short I am stoked to have a working copy of Big Sur in my VM directory. I am not going to touch it as far as updating it for a while :)

 

Thanks SpaceInvaderOne! 

Link to post

Hi everyone, I’m having issue getting macinabox to work. Not sure what I did wrong, followed space invader video but I notice in the logs that big sur is not downloading nor VM tab shows any Mac vm. Anyone able to help?

 

TIA!

Link to post
3 hours ago, bclinton said:

 

Same question here. When I did that and tried to go back to VNC the image no longer works. VNC says the session no longer send an image or something like that. 

I am facing the same issue. Everything used to work well. Then switched back to VNC and I am getting the error above. And after switching back to GPU-passthrough, it no longer works. Used the script a few times both with and without GPU. But no luck!


Any ideas?

Link to post
1 hour ago, steve1977 said:

I am facing the same issue. Everything used to work well. Then switched back to VNC and I am getting the error above. And after switching back to GPU-passthrough, it no longer works. Used the script a few times both with and without GPU. But no luck!


Any ideas?

 

Yes you need to delete the VM (Just the VM, not the disks) and remake it.  But the easiest way to do it is just to edit the current VM.

Click the VM, then edit.  At the top, hit the "form view"  button to slide it over to XML view. 

Now navigate to \appdata\macinabox\macinabox and find the file called Macinabox BigSur_original.xml.  Copy the contents of this file and paste it into the XML for your VM that youre editing.  Look at all the paths in the code, make sure everything lines up with how your setup is.  Now save it and run the userscript again which edits the XML.  Should be fixed now.

Edited by 007craft
Link to post
2 hours ago, 007craft said:

 

Yes you need to delete the VM (Just the VM, not the disks) and remake it.  But the easiest way to do it is just to edit the current VM.

I need to delete or I can just edit the current one? ;-)

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.