Nvidia GTX 1660 drivers failed to load in Windows VM

Recommended Posts

I started the unraid server and setup the vm. First I downloaded the iso file for windows and and .virtio drivers. Downloaded the vbios for GTX 1660 and edited it as according to the SpaceInvader One video. I got the display and setup the vm using the graphics card passthrough. After setting up the vm, in display adapters in devime manager showed Microsoft Basic Adapter causing me to use 800*600 resolution. Then I tried using Geforce Experience, Nvidia Driver Setup and even the solution for code 43 which windows showed me. Hyper-V was disabled. I also tried setting up VM first using vnc and then changing to the graphics to GTX 1660, no improvement. The workaround method of code 43 given on unraid forums doesn't work as the Nvidia folder created doesn't have the folder Display.Drivers . So I tried installing windows, then dumping the vbios using GPU-Z, editing it according to SpaceInvader One's video. No improvement at all. Please give me some suggestions on how to solve this. PCI Override was on and GPU, there was no error in booting in windows, just can't load the gtx 1660 drivers and use the passthrough GPU fully. Thank you for giving your precious time.

Link to comment

I had to boot it for first install without VNC graphics.  No matter what I did, if I added VNC graphics, I got code 43.  So instead, I stubbed the card, dumped the bios, and then set only that card for video- then did a full windows install and added geforce drivers- that has worked for me every time.  Not sure why- but others have had success with that method.

Link to comment

Start fresh with new machine, attach GPU, windows iso, and peripherals. Upload modded GPU rom to share and point machine to use that rom.  Attach monitor physically with known good cable, boot machine- install windows.  On next boot, GPU should have generic drivers, then install geforce drivers and everything should be good. 

Link to comment

Thank you. But before I could follow your steps, i went to internet explorer, started downloading Geforce experience and went out for 5 minutes. I just came back and so that the drivers were loaded. Special Thanks to @SpaceInvaderOne, who in his busy schedule suggested me to untick the UEFI boot in sys_linux file. And now with God's grace all is working fine. Thank you @jorddanmw and @SpaceInvaderOne

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.