[Support] binhex - MinecraftServer


288 posts in this topic Last Reply

Recommended Posts

Is there an "idiots guide" to getting a vanilla MC server up and running - specifically for someone who doesn't play the game itself?

 

My son has been badgering me to get him the Java edition and so I have doe today but him and his mates want to play on a dedicated server.

 

I don't play the game myself and my only experience in using my unraid machine for a server is for 7 Days to Die - which has a very handy "config" file - this seems to have something similar but I can't see things such as what I want to call the server and a password field to join - are these doable?

 

Sorry if this is basic stuff, all I want is to host a dedicated server for 4 or 5 players!

Link to post
  • Replies 287
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I started understanding how to put this all together and wanted to throw some info out there for those that need it.    First of all, I would recommend that if you are going to use the Vanil

I am having issues with the latest Docker image and i cannot access the application, if i look in the log file located at '/config/supervisord.log' then i see the following message:- '/usr/lib/jvm

lol:- im off to test and ensure runc is the correct version.

Posted Images

Minecraft keeps crashing and I need to constantly restart the server for my kid. I'm wondering if there is a way to export his world data, save it, then delete/reinstall the binhex minecraft server to see if that fixes the issue. I've tried googling but haven't found exactly what I'm looking for. TIA.

Link to post
On 3/26/2021 at 8:40 AM, binhex said:

 

OK, the issue is all around glibc and the upgrade to the package on arch linux, this caused failure when attempting to build arch linux docker images, but looks to also cause other side effects, such as the ones above. The fix is actually included in the latest runc (part of docker) but unraid has not upgraded yet to the latest version, thus you are seeing the issues caused by glibc upgrade.

 

To manually upgrade you simply replace the existing statically built runc with the latest, this can be achieve by going to the unraid terminal and executing the following:-
 


curl -o '/usr/bin/runc' -L 'https://github.com/binhex/arch-packages/raw/master/static/x86-64/runc' && chmod +x '/usr/bin/runc'

 

Then start the container without privileged flag set and it should start fine (works for me). The reason i wasn't seeing the issue before was that i had completely forgotten i had upgraded by version of runc, thus i was not seeing any of these issues, doh!.

 

note:- the above command will need to be executed each time you reboot the server as everything is in ram, but you can automate this by adding that line into your 'go' file located at


\\<server ip>\flash\config\go

 

 

@binhex I have been unable to get the :latest version to work even when starting from scratch. I am running on ubuntu 20.04 (not unraid) I tried your above code but it didn't help. When I attempt to connect I just get a connection refused error if I try logging into the webUI terminal it logs in but then says "There is no screen to be attached matching minecraft."

 

If I instead use 1.16.5-02 everything works fine. No idea what is going on logs don't seem to be helpful.

 

Also just a heads up your docker/github template example has "-e WEBUI_CONSOLE_TITLE=Minecraft Server \" and the space in "Minecraft Server" throws an error. I think you used to have it as "Minecraft_Server"

 

Really appreciate your help I have been running 5 or 6 minecraft containers over the last year and everything has been great.

Link to post
1 hour ago, carvitup said:

I have been unable to get the :latest version to work even when starting from scratch. I am running on ubuntu 20.04 (not unraid) I tried your above code but it didn't help. When I attempt to connect I just get a connection refused error if I try logging into the webUI terminal it logs in but then says "There is no screen to be attached matching minecraft."

can you please attach the log /config/supervisord.log

Link to post

I just updated it now fails with:

 

<snip>
2021-03-30 11:50:46.532403 [info] CUSTOM_JAR_PATH not defined,(via -e CUSTOM_JAR_PATH), defaulting to '/config/minecraft/min
ecraft_server.jar' (Mojang Minecraft Java)
2021-03-30 11:50:46.584340 [info] JAVA_VERSION not defined,(via -e JAVA_VERSION), defaulting to '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

 

Edited by Simon
Edited for brevity as it's a known issue
Link to post
2 minutes ago, Simon said:

2021-03-30 11:50:46.584340 [info] JAVA_VERSION not defined,(via -e JAVA_VERSION), defaulting to '8' '/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

 

see recommended post at top of the screen 'glibc causing random errors'

Link to post
5 minutes ago, binhex said:

 

see recommended post at top of the screen 'glibc causing random errors'

Doh! Sorry for not reading first. Confirmed resolved by the updated runc version.

Link to post
1 hour ago, binhex said:

 

see recommended post at top of the screen 'glibc causing random errors'

I don't understand this reply?  I had a docker update and it is now no longer starting with the same error(s)

 

EDIT:  Neverminded. I found the post above that shows how to fix.

 

 

2021-03-30 13:18:28.402298 [info] WEBUI_CONSOLE_TITLE defined as 'Minecraft Java'
2021-03-30 13:18:28.442013 [info] CUSTOM_JAR_PATH not defined,(via -e CUSTOM_JAR_PATH), defaulting to '/config/minecraft/minecraft_server.jar' (Mojang Minecraft Java)
2021-03-30 13:18:28.479940 [info] JAVA_VERSION not defined,(via -e JAVA_VERSION), defaulting to '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

 

Edited by Dmtalon
Link to post

Hey guys,

I've tried to install the Docker with default settings. The Docker wont start and the log shows following errors:

2021-04-01 09:22:17.234741 [info] Host is running unRAID
2021-04-01 09:22:17.254309 [info] System information Linux b21aac0e4fe1 5.10.21-Unraid #1 SMP Sun Mar 7 13:39:02 PST 2021 x86_64 GNU/Linux
2021-04-01 09:22:17.275761 [info] OS_ARCH defined as 'x86-64'
2021-04-01 09:22:17.296742 [info] PUID defined as '99'
2021-04-01 09:22:17.319586 [info] PGID defined as '100'
2021-04-01 09:22:17.353932 [info] UMASK defined as '000'
2021-04-01 09:22:17.374131 [info] Permissions already set for volume mappings
2021-04-01 09:22:17.395496 [info] Deleting files in /tmp (non recursive)...
2021-04-01 09:22:17.417533 [info] CREATE_BACKUP_HOURS defined as '12'
2021-04-01 09:22:17.438475 [info] PURGE_BACKUP_DAYS defined as '14'
2021-04-01 09:22:17.458886 [info] ENABLE_WEBUI_CONSOLE defined as 'yes'
2021-04-01 09:22:17.479835 [info] ENABLE_WEBUI_AUTH defined as 'yes'
2021-04-01 09:22:17.501167 [info] WEBUI_USER defined as 'admin'
2021-04-01 09:22:17.522364 [info] WEBUI_PASS defined as 'test'
2021-04-01 09:22:17.543231 [info] WEBUI_CONSOLE_TITLE defined as 'Minecraft Java'
2021-04-01 09:22:17.564069 [info] CUSTOM_JAR_PATH defined as '/config/minecraft/minecraft_server.jar'
2021-04-01 09:22:17.584927 [info] JAVA_VERSION defined as '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

Where am I going wrong?

Link to post
On 4/1/2021 at 12:26 AM, MPHxLegend said:

Hey guys,

I've tried to install the Docker with default settings. The Docker wont start and the log shows following errors:


2021-04-01 09:22:17.234741 [info] Host is running unRAID
2021-04-01 09:22:17.254309 [info] System information Linux b21aac0e4fe1 5.10.21-Unraid #1 SMP Sun Mar 7 13:39:02 PST 2021 x86_64 GNU/Linux
2021-04-01 09:22:17.275761 [info] OS_ARCH defined as 'x86-64'
2021-04-01 09:22:17.296742 [info] PUID defined as '99'
2021-04-01 09:22:17.319586 [info] PGID defined as '100'
2021-04-01 09:22:17.353932 [info] UMASK defined as '000'
2021-04-01 09:22:17.374131 [info] Permissions already set for volume mappings
2021-04-01 09:22:17.395496 [info] Deleting files in /tmp (non recursive)...
2021-04-01 09:22:17.417533 [info] CREATE_BACKUP_HOURS defined as '12'
2021-04-01 09:22:17.438475 [info] PURGE_BACKUP_DAYS defined as '14'
2021-04-01 09:22:17.458886 [info] ENABLE_WEBUI_CONSOLE defined as 'yes'
2021-04-01 09:22:17.479835 [info] ENABLE_WEBUI_AUTH defined as 'yes'
2021-04-01 09:22:17.501167 [info] WEBUI_USER defined as 'admin'
2021-04-01 09:22:17.522364 [info] WEBUI_PASS defined as 'test'
2021-04-01 09:22:17.543231 [info] WEBUI_CONSOLE_TITLE defined as 'Minecraft Java'
2021-04-01 09:22:17.564069 [info] CUSTOM_JAR_PATH defined as '/config/minecraft/minecraft_server.jar'
2021-04-01 09:22:17.584927 [info] JAVA_VERSION defined as '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

Where am I going wrong?

see the pinned post at the top. it runs you through the fix.

Link to post

@jamerperson

open the unraid terminal

cmd: cd /boot/config (my flash drive is mounted as /boot.  seems other installs could be /flash, so YMMV.)

cmd: nano go

go to the first blank line, and type/paste:

curl -o '/usr/bin/runc' -L 'https://github.com/binhex/arch-packages/raw/master/static/x86-64/runc' && chmod +x '/usr/bin/runc'

type <ctrl+o>

type <y> to save

type <ctrl+x> to exit

close the console.

Edited by sota
uneducated info striked.
Link to post
2 hours ago, sota said:

seems other installs could be /flash, so YMMV.)

flash is the default share name if it's exposed over SMB, so the go file would be \\tower\flash\config\go if you wanted to edit it over the network, and the flash share was enabled.

Link to post

Just a quick shout out for for some guidance.

 

I used the @SpaceInvaderOne video to setup a Minecraft server and also used Cloudflare. Worked a treat. Ran for a week or so. Then had an update for Binhex's container (great work on all your containers, use them for everything!) and it updated with no errors but then the minecraft server was not available on the local network or via the internet. When you connect to the WebUI for the container (user name and password work fine) you get the following message in the window:

 

"There is no screen to be attached matching minecraft." 

 

and that's it. Previously the WebUI showed all the data for the minecraft server, who connected, what the world was doing, etc.

 

There was another container update and I had the glibc error which I corrected with the post in this thread and that's all fixed so no problems there. However, I still get the console window error and the minecraft server not being able to connect. The container starts and runs, had a look through logs and couldn't see anything obvious.

Log posted below. Any help is greatly appreciated (username and password deleted from logs).

Created by...
___. .__ .__
\_ |__ |__| ____ | |__ ____ ___ ___
| __ \| |/ \| | \_/ __ \\ \/ /
| \_\ \ | | \ Y \ ___/ > <
|___ /__|___| /___| /\___ >__/\_ \
\/ \/ \/ \/ \/
https://hub.docker.com/u/binhex/

2021-04-05 03:28:04.575012 [info] Host is running unRAID
2021-04-05 03:28:04.620424 [info] System information Linux 85aa981c4a94 5.10.21-Unraid #1 SMP Sun Mar 7 13:39:02 PST 2021 x86_64 GNU/Linux
2021-04-05 03:28:04.675189 [info] OS_ARCH defined as 'x86-64'
2021-04-05 03:28:04.730666 [info] PUID defined as '99'
2021-04-05 03:28:04.793458 [info] PGID defined as '100'
2021-04-05 03:28:04.905287 [info] UMASK defined as '000'
2021-04-05 03:28:04.956405 [info] Permissions already set for volume mappings
2021-04-05 03:28:05.109976 [info] Deleting files in /tmp (non recursive)...
2021-04-05 03:28:05.163616 [info] CREATE_BACKUP_HOURS defined as '12'
2021-04-05 03:28:05.217617 [info] PURGE_BACKUP_DAYS defined as '14'
2021-04-05 03:28:05.276984 [info] ENABLE_WEBUI_CONSOLE defined as 'yes'
2021-04-05 03:28:05.329073 [info] ENABLE_WEBUI_AUTH defined as 'yes'
2021-04-05 03:28:05.382607 [info] WEBUI_USER defined as '*********'
2021-04-05 03:28:05.435596 [info] WEBUI_PASS defined as '********'
2021-04-05 03:28:05.489763 [info] WEBUI_CONSOLE_TITLE defined as 'Minecraft Java'
2021-04-05 03:28:05.540730 [info] CUSTOM_JAR_PATH defined as '/config/minecraft/minecraft_server.jar'
2021-04-05 03:28:05.593004 [info] JAVA_VERSION defined as '8'
2021-04-05 03:28:05.671902 [info] JAVA_INITIAL_HEAP_SIZE defined as '2048'
2021-04-05 03:28:05.724184 [info] JAVA_MAX_HEAP_SIZE defined as '4096M'
2021-04-05 03:28:05.780979 [info] JAVA_MAX_THREADS defined as '8'
2021-04-05 03:28:05.834088 [info] Starting Supervisor...
2021-04-05 03:28:06,622 INFO Included extra file "/etc/supervisor/conf.d/minecraft-server.conf" during parsing
2021-04-05 03:28:06,622 INFO Set uid to user 0 succeeded
2021-04-05 03:28:06,628 INFO supervisord started with pid 6
2021-04-05 03:28:07,631 INFO spawned: 'backup-script' with pid 124
2021-04-05 03:28:07,635 INFO spawned: 'purge-script' with pid 125
2021-04-05 03:28:07,638 INFO spawned: 'shutdown-script' with pid 126
2021-04-05 03:28:07,641 INFO spawned: 'start-script' with pid 127
2021-04-05 03:28:07,642 INFO reaped unknown pid 7 (exit status 0)
2021-04-05 03:28:07,650 DEBG 'backup-script' stdout output:
[info] Waiting 12 hours before running worlds backup...

2021-04-05 03:28:07,650 INFO success: backup-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-04-05 03:28:07,651 INFO success: purge-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-04-05 03:28:07,651 INFO success: shutdown-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-04-05 03:28:07,651 INFO success: start-script entered RUNNING state, process has stayed up for > than 0 seconds (startsecs)
2021-04-05 03:28:07,652 DEBG 'purge-script' stdout output:
[info] Removing any Minecraft worlds backups with a creation date older than 14 days...

2021-04-05 03:28:07,659 DEBG 'start-script' stdout output:
[info] Minecraft folder '/config/minecraft' already exists, rsyncing newer files...

2021-04-05 03:28:07,726 DEBG 'start-script' stdout output:
[info] Checking EULA is set to 'true'...

2021-04-05 03:28:07,728 DEBG 'purge-script' stdout output:
[info] Checking for old backups in 12 hours...

2021-04-05 03:28:07,731 DEBG 'start-script' stdout output:
[info] EULA set to 'true'

2021-04-05 03:28:07,733 DEBG 'start-script' stdout output:
[info] Starting Minecraft Java process...

2021-04-05 03:28:07,740 DEBG 'start-script' stdout output:
[info] Minecraft Java process is running

2021-04-05 03:28:07,740 DEBG 'start-script' stdout output:
[info] Starting Minecraft console Web UI...

2021-04-05 03:28:07,797 DEBG 'start-script' stderr output:
2021/04/05 03:28:07 Permitting clients to write input to the PTY.
2021/04/05 03:28:07 Using Basic Authentication
2021/04/05 03:28:07 Server is starting with command: screen -x minecraft

2021-04-05 03:28:07,798 DEBG 'start-script' stderr output:
2021/04/05 03:28:07 URL: http://127.0.0.1:8222/
2021/04/05 03:28:07 URL: http://172.17.0.2:8222/

2021-04-05 11:12:06,558 DEBG 'start-script' stderr output:
2021/04/05 11:12:06 192.168.1.180:50349 401 GET /

2021-04-05 11:12:07,979 DEBG 'start-script' stderr output:
2021/04/05 11:12:07 Basic Authentication Succeeded: 192.168.1.180:50349

2021-04-05 11:12:07,980 DEBG 'start-script' stderr output:
2021/04/05 11:12:07 192.168.1.180:50349 200 GET /

2021-04-05 11:12:08,008 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 Basic Authentication Succeeded: 192.168.1.180:50349

2021-04-05 11:12:08,020 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 Basic Authentication Succeeded: 192.168.1.180:50352

2021-04-05 11:12:08,020 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 Basic Authentication Succeeded: 192.168.1.180:50350
2021/04/05 11:12:08 192.168.1.180:50350 200 GET /auth_token.js
2021/04/05 11:12:08 192.168.1.180:50352 200 GET /js/gotty.js

2021-04-05 11:12:08,021 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 192.168.1.180:50349 200 GET /js/hterm.js

2021-04-05 11:12:08,052 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 New client connected: 192.168.1.180:50353

2021-04-05 11:12:08,366 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 Command is running for client 192.168.1.180:50353 with PID 151 (args="-x minecraft"), connections: 1
2021/04/05 11:12:08 192.168.1.180:50353 101 GET /ws

2021-04-05 11:12:08,400 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 Command exited for: 192.168.1.180:50353

2021-04-05 11:12:08,401 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 read tcp 172.17.0.2:8222->192.168.1.180:50353: use of closed network connection
2021/04/05 11:12:08 Connection closed: 192.168.1.180:50353, connections: 0

2021-04-05 11:12:08,422 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 Basic Authentication Succeeded: 192.168.1.180:50349

2021-04-05 11:12:08,422 DEBG 'start-script' stderr output:
2021/04/05 11:12:08 192.168.1.180:50349 200 GET /favicon.png
 

Link to post

Is it possible to use a custom jar with this container?

 

I tried adding "CUSTOM_JAR_PATH: /config/minecraft/spigot-1.16.5.jar" as a variable but it still launches the minecraft default jar.

Link to post
57 minutes ago, oko2708 said:

Is it possible to use a custom jar with this container?

 

I tried adding "CUSTOM_JAR_PATH: /config/minecraft/spigot-1.16.5.jar" as a variable but it still launches the minecraft default jar.

yes, that was added in and tested so it should work, please can you attach the file /config/supervisord.log 

Link to post
On 4/5/2021 at 11:23 AM, RallyGallery said:

"There is no screen to be attached matching minecraft." 

try a different browser, i have a funny feeling ive seen this before and it was browser related, if you are using firefox try chrome, if chrome try firefox.

Link to post
3 minutes ago, binhex said:

your image is out of date, please go to unraid web ui/docker/click on 'check for updates' then click on 'update all'

It is purposely out of date. Does it not work for 1.16.5-02?

Link to post
Just now, oko2708 said:

It is purposely out of date. Does it not work for 1.16.5-02?

no, it was introduced later on, but if you run latest then you can run whatever version of minecraft you want right :-).

Link to post
10 minutes ago, binhex said:

no, it was introduced later on, but if you run latest then you can run whatever version of minecraft you want right :-).

Ahhh I didn't know it was such a new feature. I was trying to avoid the current workaround for the current glibc issue, but I guess thats no longer an option for me. Thanks.

Link to post
1 hour ago, suppenloeffel said:

Hi,

I can't start my Docker container. I left all settings as they were during installation, but when I press "Start" nothing happens.

 

This is what the logs say:

grafik.thumb.png.0b53b61587758cd93b07bf6a537adcec.png

 

Anyone know what I can do?

top of the screen, recommended post 'glibc causing random errors'

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.