[Support] binhex - MinecraftServer


Recommended Posts

14 minutes ago, suppenloeffel said:

So I understand correctly that you can also just wait for the next Unraid version to fix the problem?

indeed, but there is no guarantee, latest docker version will have to go through their testing, if its ok then yes it should be included in the next release, and it could be a while off (months).

Link to comment
20 minutes ago, binhex said:

indeed, but there is no guarantee, latest docker version will have to go through their testing, if its ok then yes it should be included in the next release, and it could be a while off (months).

lol:-

im off to test and ensure runc is the correct version.

  • Like 1
  • Haha 1
Link to comment

I am getting

 

"2021-04-15 18:12:00.934970 [info] CUSTOM_JAR_PATH defined as '/config/minecraft/minecraft_server.jar'
2021-04-15 18:12:00.975017 [info] JAVA_VERSION defined as '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path"

 

I have been running fine until the update. Did something change in the settings that I need to repath this?

 

 

Link to comment
10 hours ago, ku8475 said:

I am getting

 

"2021-04-15 18:12:00.934970 [info] CUSTOM_JAR_PATH defined as '/config/minecraft/minecraft_server.jar'
2021-04-15 18:12:00.975017 [info] JAVA_VERSION defined as '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path"

 

I have been running fine until the update. Did something change in the settings that I need to repath this?

 

 

see top of the screen recommended post 'glibc causing random errors'

Link to comment
All off a sudden I am no longer able to connect to the Web Console. I give's me a 401 error: Bad Request. I've been experimenting with some settings, but I am having the same problem on a clean docker images.
 
Here is the log
 
supervisord.log
Try different browsers, I have seen issues with certain browsers

Sent from my CLT-L09 using Tapatalk

  • Thanks 1
Link to comment

So I set up the server to use a max amount of 20480M, at start its says it uses ~7GiB but when one person joins it shots up to ~20GiB. When more people join they quickly get a server time out screen on there end.  Request help troubleshoot problem and hopefully steps to fix error.  

Link to comment
On 5/2/2021 at 10:53 AM, binhex said:

Try different browsers, I have seen issues with certain browsers

Sent from my CLT-L09 using Tapatalk
 

Sorry for the late reply. Different browser fixes the problem. Thanks!

Link to comment

So i've started getting this error about 48 hours ago and can't find a work around.  I'm using cloudflare-ddns and using my own domain name instead of just the IP address (found how to do it in a spaceinvader one youtube tutorial)  It's been working fine for weeks but now I'm getting this error.  If I put in the ip address of my host machine I can connect fine but for people outside of my network that want to connect I can't give them my public IP besides it being an unsafe practice dynamic and not always constant.  Any advice on how to fix this would be greatly appreciated.image.thumb.png.fa15baea8f5c2b8ac4493895972408d6.png

Link to comment
On 1/31/2021 at 1:06 AM, dkerlee said:

[SOLVED]

edit /config/minecraft/eual.txt and set it to true

thank you @RasmusR

 

original post below

===================================================

Hello folks, been trying to get this container up and running and have not been able to get the game to connect to the server.

 

Two issues, as far as I know:

There is a service listening on the 8222 port. I am prompted for the username and password. But when I enter them, I get a black screen "There is no screen to be attached matching minecraft."

 

(A suggestion: under the docker, put in a note saying what the two ports are for. I assume 25565 is the game connection server, and 8222 is the web gui (which, is it a gui, or only a command line?).  )

 


root@rubble:~# curl -v localhost:8222
*   Trying 127.0.0.1:8222...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 8222 (#0)
> GET / HTTP/1.1
> Host: localhost:8222
> User-Agent: curl/7.67.0
> Accept: */*
>
* Mark bundle as not supporting multiuse
< HTTP/1.1 401 Unauthorized
< Content-Type: text/plain; charset=utf-8
< Server: GoTTY/1.0.1
< Www-Authenticate: Basic realm="GoTTY"
< X-Content-Type-Options: nosniff
< Date: Sun, 31 Jan 2021 04:12:32 GMT
< Content-Length: 12
<
Bad Request
* Connection #0 to host localhost left intact

 

 

I did change the port from default, 25565 to 25348 - but it doesn't look like anything is listening on that port.

 


root@rubble:~# curl -v localhost:25565
*   Trying 127.0.0.1:25565...
* TCP_NODELAY set
* connect to 127.0.0.1 port 25565 failed: Connection refused
* Failed to connect to localhost port 25565: Connection refused
* Closing connection 0
curl: (7) Failed to connect to localhost port 25565: Connection refused
root@rubble:~# curl -v localhost:25348
*   Trying 127.0.0.1:25348...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 25348 (#0)
> GET / HTTP/1.1
> Host: localhost:25348
> User-Agent: curl/7.67.0
> Accept: */*
>
* Recv failure: Connection reset by peer
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer
root@rubble:~#

 

 

The docker log (I redacted the admin password)

https://pastebin.com/87tbGufS

 

root@rubble:~# nc -v localhost 25348

Connection to localhost 25348 port [tcp/*] succeeded!

 

root@rubble:~# nc -v localhost 25565
nc: connect to localhost port 25565 (tcp) failed: Connection refused

 

so that's good, but still Minecraft just won't connect to anything. When connecting, I should go to Multiplayer > Direct Connection > "192.168.11.53:25348"

 

I've forwarded the port 25348 on my router from external to my internal unRaid box port, just like I do other services that do work, and head to my duckdns subdomain, and no luck there either.

 

Error in Minecraft is "Failed to connect ot the server.

io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information.

8RaIeu5.png

 

The other settings from the docker
Repository: binhex/arch-minecraftserver

network type: bridge

Console Shell command: Shell

Privileged: OFF

Host Port 1: 25348

Host Port 2: 8222

Key 1: 12

Key 2: 14

Key 3: yes

Key 4: yes

5: admin

6: xxxxxx

7: Minecraft Java

8: 512M

9: 1024M

10: 1

11: 000

12: 99

13: 100

 

I am sure I forwarded the port correctly through the router - but using ismyportopen.com, I get a negative.

QcIPq4m.png

How did you fix this?  The EULA is already set to true for me and I'm getting the io.netty. . . error  

Link to comment

Hi guys, I just installed this (binhex-minecraftserver) docker image on my unraid.

The pull went all right, but my container stopped working with this error line in the log file:

 

xxxx-XX-xx xx:XX:xx.964990 [info] JAVA_VERSION defined as '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

 

Not so weird at all, because I never installed any java on my tower.

I had already did a repull force last version update, in the hope it would also immediatly instaal java or openjdk8.
That is what I found with a simple google search.

Unlucky me, it did not install java or even a open source version of the needed data....

 

My question is how can I install java or openjdk on my unraid tower...?

I have already tried to install that via a dockerhub container called openjdk8, and furthermore running that installed docker, but that didn't solve a thing.

 

I am a huuuuge newbie with docker and unraid so how do I get the right files needed for the container "binhex-minecraftserver"?

So that I can at least change the path or so that the files are on the right place as for the docker.

 

Thanks in advance.
Regards, Rik

Link to comment
  • 2 weeks later...
On 5/24/2021 at 3:28 AM, rikdegraaff said:

Hi guys, I just installed this (binhex-minecraftserver) docker image on my unraid.

The pull went all right, but my container stopped working with this error line in the log file:

 


xxxx-XX-xx xx:XX:xx.964990 [info] JAVA_VERSION defined as '8'
'/usr/lib/jvm/java-8-openjdk/jre' is not a valid Java environment path

 

Not so weird at all, because I never installed any java on my tower.

I had already did a repull force last version update, in the hope it would also immediatly instaal java or openjdk8.
That is what I found with a simple google search.

Unlucky me, it did not install java or even a open source version of the needed data....

 

My question is how can I install java or openjdk on my unraid tower...?

I have already tried to install that via a dockerhub container called openjdk8, and furthermore running that installed docker, but that didn't solve a thing.

 

I am a huuuuge newbie with docker and unraid so how do I get the right files needed for the container "binhex-minecraftserver"?

So that I can at least change the path or so that the files are on the right place as for the docker.

 

Thanks in advance.
Regards, Rik

If you scroll up in this thread someone else has had the same Problem und the Solution is at the top of the page "glibc causing random errors". 

 

Link to comment
23 hours ago, binhex said:

In preparation for the onslaught of 'I've just updated to Cliffs and Caves update 1.17 and now it won't start' messages that will hit tomorrow, please see Q2. from the FAQ:-

https://github.com/binhex/documentation/blob/master/docker/faq/minecraftserver.md

 

Hint:- Cliffs and Caves ver 1.17+ requires Java 16

 

I hit [edit]  on the container, and while I see OTHER Java-related variables, I don't see one for JAVA_VERSION.  Do we need to add this manually?   Just trying to stay ahead of impatient 10 year-olds. :)

Link to comment
Just now, TD2779 said:

 

I hit [edit]  on the container, and while I see OTHER Java-related variables, I don't see one for JAVA_VERSION.  Do we need to add this manually?   Just trying to stay ahead of impatient 10 year-olds. :)

ahh it sounds like you have an outdated template, short answer is yes you will need to add it in that case, see here Q8:- https://github.com/binhex/documentation/blob/master/docker/faq/unraid.md

  • Like 1
Link to comment

just curious how to actually update my server to 1.17 sorry if this easy i just cant seem to figure it out.

i did the java - 16 thing. even tried switching out the jar files within but it just switched back? so idk.

Link to comment

So to clarify an easy path for people, do we just shut down the docker and then change the java version in the edit menu to 16 and fire it back up? Is there an official way to update the server to 1.17? I saw online some people say just replace the .jar with a new one of the same name.

Link to comment
Posted (edited)

I didn't find any update feature or script.  This is what I did for a manual update: maybe it will help someone.

 

I'm new to Minecraft.  If it updates often, I'll get a script together.

 

1. stop the container

2. ssh root@<my unraid raid server>

3. cd /mnt/user/appdata/<my minecraft container config directory>/minecraft

4. wget https://launcher.mojang.com/v1/objects/0a269b5f2c5b93b1712d0f5dc43b6182b9ab254e/server.jar -O minecraft_server.jar

5. chmod 775 minecraft_server.jar && chown nobody:users minecraft_server.jar

6. start the container

 

-Brian

Edited by TheBrian
Link to comment
5 minutes ago, TheBrian said:

I didn't find any update feature or script.  This is what I did for a manual update: maybe it will help someone.

 

I'm new to Minecraft.  If it updates often, I'll get a script together.

the image will get auto updated once my trigger script kicks in and detects a new version of minecraft, so you will see a new image land probably in the next 30 mins or so, its fully automated.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.