[Support] binhex - MinecraftBedrockServer


375 posts in this topic Last Reply

Recommended Posts

38 minutes ago, sleeper37 said:

Is it possible to set up a second Minecraft Bedrock server?  I looked at the Apps section and when I bring up binhex minecraftbedrockserver, it only allows me to Edit the one I currently have installed.  I'd like to set up a second one on a different port.  Thanks.

See third from last question in the general section.

Link to post
  • Replies 374
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

new feature coming soon, minecraft console accessible via web ui, thought this might please a few people, no nasty docker exec

yes, create a /config/permissions.json file, edit it and add your xuid and grant yourself whatever permissions you need, e.g.:-   [ { "permission": "operator","xuid": "12345678123

Also note that the order of the pack you have selected (once you fix the comma) will mean fuserealism is secondary to peegs, so if peegs has any textures it will overwrite fuses's. They apply bottom t

Posted Images

I just tried to set up a server using this container and everything seems to show up correctly but when I try to join it tells me "Could not connect: Outdated Server!". Is there some process I need to go through the bring it up to date or is there just an update to the container that's necessary?

Screenshot 2021-01-30 165806.png

Edited by wr1williams
Included photo
Link to post

Just installed this for the first time. Anyone else getting extremely high CPU usage? I go from about 5% to 100% when a single user logs in. It stays that way until I leave the world. Connecting from an iPhone.

 

I'm using an old 4/4 core Xeon (1220v1), but I still feel like this is unusually high? 

Edited by FTLAUDMAN
Link to post
On 1/30/2021 at 9:57 PM, wr1williams said:

I just tried to set up a server using this container and everything seems to show up correctly but when I try to join it tells me "Could not connect: Outdated Server!". Is there some process I need to go through the bring it up to date or is there just an update to the container that's necessary?

Screenshot 2021-01-30 165806.png

make sure your server is up to date, click on check for updates and apply any that are outstanding.

Link to post
9 hours ago, FTLAUDMAN said:

Just installed this for the first time. Anyone else getting extremely high CPU usage? I go from about 5% to 100% when a single user logs in. It stays that way until I leave the world. Connecting from an iPhone.

 

I'm using an old 4/4 core Xeon (1220v1), but I still feel like this is unusually high? 

i use this docker myself and have not seen this, processor is AMD 2700X, it maybe related to storage, are you running this on array, cache pool, or single cache drive?

Link to post
On 1/27/2021 at 4:06 PM, jonathanm said:

See third from last question in the general section

 

Thanks!  That helped.

 

But, now my new issue is I can't connect to the new server using Web UI.

 

Original server is 19132, 19133, 8222.. and the new one is 19134, 19135, 8223.  I am able to connect to both servers, but when using Web UI, they both go to 8222, the original server.  I can't connect to the new one.  I tried changing Host Path 5 to 8221 to try it and no dice.

Link to post
5 hours ago, sleeper37 said:

 

Thanks!  That helped.

 

But, now my new issue is I can't connect to the new server using Web UI.

 

Original server is 19132, 19133, 8222.. and the new one is 19134, 19135, 8223.  I am able to connect to both servers, but when using Web UI, they both go to 8222, the original server.  I can't connect to the new one.  I tried changing Host Path 5 to 8221 to try it and no dice.

If you manually type in the 8223 port on the address bar, does it work?

Link to post
12 hours ago, binhex said:

i use this docker myself and have not seen this, processor is AMD 2700X, it maybe related to storage, are you running this on array, cache pool, or single cache drive?

Cache pool, using an Oracle F80 (PCIE, using 3 of the 4 200GB drives in the pool).

Link to post
2 hours ago, sleeper37 said:

Nope, just says site can’t be reached.  I’ve forwarded the ports.  Must be something I’m missing.

You only changed the host side on the second instance, right? The container side should be the same on both containers.

Link to post
1 hour ago, jonathanm said:

You only changed the host side on the second instance, right? The container side should be the same on both containers.

That was it.  I thought I had to change both Container and Host ports.  It works perfect now.  Appreciate the help.  Thank you very much!!

Link to post
7 hours ago, KLLSWITCH said:

is there a webui for this like mineos?

no, the link to the web ui links you to the minecraft console, which is cli based. tbh you don't really need a web ui to get you up and running with bedrock edition.

Link to post

My son asked me about setting up a Minecraft server for him and his friends, and after some research I found this thread.  I installed the Bedrock version of the Docker and am able to connect to it through the Docker UI.

 

Is the console the only way to interact with the server, or is there a UI available?  

Is there a list of common commands to set/update?

How do users inside my house connect to this server?

How do I open access to this for users outside my house?

 

Thank you in advance!

Edited by Glimmerman911
Link to post
32 minutes ago, Glimmerman911 said:

Is the console the only way to interact with the server

yes

32 minutes ago, Glimmerman911 said:

or is there a UI available?

nope

32 minutes ago, Glimmerman911 said:

Is there a list of common commands to set/update?

that depends on what you want to achieve, there are numerous guides on the internet for the list of commands.

33 minutes ago, Glimmerman911 said:

How do users inside my house connect to this server?

 

depends on the device, if xbox or minecraft pe (android) then the server should be visible in the 'friends' tab in the menu screen once running.

34 minutes ago, Glimmerman911 said:

How do I open access to this for users outside my house?

again, this depends on device as to whether its possible, minecraft pe and windows minecraft can connect over the internet you just need port forwarding in place, everything else is more tricky, or impossible.

Link to post
3 hours ago, binhex said:

yes

nope

that depends on what you want to achieve, there are numerous guides on the internet for the list of commands.

depends on the device, if xbox or minecraft pe (android) then the server should be visible in the 'friends' tab in the menu screen once running.

again, this depends on device as to whether its possible, minecraft pe and windows minecraft can connect over the internet you just need port forwarding in place, everything else is more tricky, or impossible.

Thanks for the quick reply!  

 

Here are my issues:

I do not see anything in Friends from a device on my network, I should be seeing LAN game but I don't?

I have setup port forwarding, but external users cannot connect to my server, "Unable to connect" error

I have tried an internal network user connecting to my server IP and the external IP address and port, they get "unable to connect" as well

What can I check or modify to get this server running?

 

I also get the following two messages when I login to the webui:

     NO LOG FILE! - Failed to up file descriptor limit Operation not permitted

     NO LOG FILE! - setting up server logging...

 

And after the server has been running 15+ minutes, when I try to access the webui for consol, I get:

"There is no screen to be attached matching minecraft."

and in big letters "Connection Closed"

If I reset the Docker, I can login to the webui again, then it fails after a while again.

 

Thanks again for the help

Edited by Glimmerman911
Link to post
  • 4 weeks later...

EDIT: Nevermind, I figured it out. I used Krusader and I had no permissions issues. Thanks!

 

Hi everyone, I'm new to docker and running a Minecraft Bedrock server. I'm having trouble moving my existing world to the server's Worlds folder. I'm getting "Permission Denied. You need to be granted permission by user/nobody." I'm accessing the appdata share from Windows 10. How do I grant my self access? Thanks so much! So far, everything else is working great!

Edited by JohnyClassic
Link to post
On 3/2/2021 at 5:25 AM, CSIG1001 said:

Trying to do simple task


Change player count from 10 to like 20?

simple - edit the file /config/minecraft/server.properties and change line 17:-

 

max-players=10
# The maximum number of players that can play on the server.
# Allowed values: Any positive integer

 

Link to post
  • 2 weeks later...

Just set up my first server.  Also getting an "outdated version" error connecting.  

 

[2021-03-17 17:37:23 INFO] Version 1.16.210.06

 

Windows 10 Minecraft says 1.16.220.51.  

 

Checking for updates still says up-to-date.  Is there an update coming or am I on the wrong server?

 

EDIT:  I figured it out.  Somehow I was a member of the "Insider" program and was running beta.  I opted out and all is well.

Edited by slider162
Link to post
  • 4 weeks later...

Hello!
First of all thank you very much for your app!

 

I just have a small question: in order to gracefully stop the server, can I simply stop the related docker or should I always issue a "stop" command with the console first?

 

Thanks again!

Link to post
3 hours ago, Artanis said:

can I simply stop the related docker

yes, i have code in place to do a graceful kill of the process.

Link to post

hey all i was wondering who has been able to run a second server.. i can get one running fine but the second one is getting the best of me.. 

 

Here is what is happening and my settings i have set 

 

Also this is the only way it will show up is if i manually add the IP in servers

 

if any one can let me know what im doing wrong this would be great 

 

I have the First server Down but it does show up under friends when i start it.. with all default settings for ports

 

explorer_jBj0bTtHFs.png

ApplicationFrameHost_cWUuihg8PA.png

notepad_gTg8bcY86l.png

Edited by i3u5hy
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.