Jump to content
Joeyleigh

Disk Failure, SMART test says disk failing now within 24hrs, save all data!

8 posts in this topic Last Reply

Recommended Posts

Hi Chaps, been running some 4 x 3tb reds for 4-5 years now on Unraid - 

 

Tried to find out the incredibly slow read rates recently (kept hanging on VM) 

 

Found out SMART test says your screwed in 24hrs - save data!

 

Any knowledgeable guys hanging around they could take a glance over my disk report attached and confirm im in for s **t storm?

quick trip to amazon i think.....

 

Thanks

 

WDC_WD30EFRX-68N32N0_WD-WCC7K3ZJ05RV-20191106-2316.txt

Share this post


Link to post

You only included the SMART report from one disk. It is failing and needs to be replaced. I don't know the state of your other disks. Post your full diagnostics.

Share this post


Link to post

Thanks John,

 

Pretty much came to the conclusion it was screaming. only 8 months Old WD Red as well. :(

 

Rest of disks attached.... I think Disc 1 is getting some side pains as well?? Not sure

Parity Check is also running incredibly slow 1.5MB/s - 33 days to complete....

 

smart.zip

Edited by Joeyleigh

Share this post


Link to post

Running a parity check with a disk already flagged as in trouble does not seem a good idea and likely to tip the disk into final failure (and potentially corrupting parity if you have set it to be a correcting check).

 

if you want any informed feedback as to why things are running slow you should provide the full diagnostics zip file, not just the SMART data.

Edited by itimpi

Share this post


Link to post

@itimpi Thanks, pretty much what you explained above started to happen. Logs for the Disk was spewing out errors - The speed of the parity was clearly affected by these read errors so i'm assuming this may not be set as the correcting check. Hope not 🤞

 

Creating RMA with WD considering 8 months old. Will add a second parity - Paranoia kicking in!

 

Image of disk errors after 0.1% of parity check 😨, been saying 4 errors last 24 hours.

Was hoping it may be a data cable if continuous error reads all of a sudden

 

I've stopped the Array until the new HDD arrives tomorrow. 

2019_11_07_01_45_27_NYX_Main.jpg

Edited by Joeyleigh

Share this post


Link to post
1 hour ago, Joeyleigh said:

i'm assuming this may not be set as the correcting check.

Correcting parity checks are the default (wrongly, IMO) so unless you unchecked the "Write corrections to parity" box it was. Your diagnostics, assuming you haven't rebooted since starting the check, would confirm. This is the third time of asking for them. Go to Tools -> Diagnostics and attach the resulting zip file to your next post.

Share this post


Link to post

John,

 

Zip attached - 

 

Ordered a new drive yesterday, its sat on the table downstairs but i had 1 more idea before i install - i hear a lot about cable problems and seeing the errors hit me quickly, i took the array off-line disconnected and re-connected the SATA cables.  

 

I have booted the system and its not coming up with any errors, i can't complete a Smart test though as it seems to still be in error mode even though the logs show its working fine - Read rates are high again and i'm not hanging anymore?

 

I have checked the Raw values over the last 30 mins - transferring and sending data across different disks, its still the same.

 

Is there a more complex way of testing the disk now its working again, or resetting the smart test error?

 

Thanks

nyx-diagnostics-20191109-1402.zip

Edited by Joeyleigh

Share this post


Link to post

Never-mind - errors are coming back - New HDD going in now!

 

UPDATE  - New drive in. rebuilding array - party data build is at full 145MB/s - 5Hrs40mins

Edited by Joeyleigh

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.