Jump to content
bobo89

Edit VM without GUI or having VMs enabled

3 posts in this topic Last Reply

Recommended Posts

So I tried to pass through the onboard audio card to a vm, and that made the server lockup.

 

Unfortunately that VM is set to autostart, so the second the server reboots, it locks up again.

 

I am trying to do "virsh edit VM" from the command line, however get a "failed to connectd to the hypervisor"

I'm also trying to turn off autostart on the VM so I can get into the XML from the GUI, but get the same error.

 

How do I disable autostart on a VM, or edit the XML without having VM enabled (cause pc locks up the second I enable it)

Edited by bobo89

Share this post


Link to post

Could manually rename that VMs disk images which should prevent it from starting.

Share this post


Link to post
9 minutes ago, BRiT said:

Could manually rename that VMs disk images which should prevent it from starting.

Primitive, but it worked, thanks!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.