Jump to content
Sign in to follow this  
ki11gar

Can't do a clean shutdown [Solved]

7 posts in this topic Last Reply

Recommended Posts

Hi all, new to unraid. 

 

Setup my server 10 days ago and have never been able to shut it down cleanly.

I always get stuck on shutting down services, one core of the CPU will be running at 100%.

 

I have tried Fix Common Problems, nothing to fix. 

I have tried shutting down VM, docker (1 of each) and the array and then shutting down but no luck. 

Updated to Version: 6.8.0-rc5 from the last stable to see if that would help. 

Installed plugins:

  • Community applications
  • Dynamix S3 Sleep
  • Dynamix SSD trim
  • Dynamix System buttons
  • Dynamix system information
  • Dynamix system stats
  • Fix common problems
  • Unassigned devices

 

My hardware:

System Overview

unRAID system:unRAID server Trial, version 6.8.0-rc5

Model:Custom

Motherboard:ASUSTeK COMPUTER INC. - PRIME Z270-K

Processor:Intel® Core™ i7-6700 CPU @ 3.40GHz

HVM:Enabled

IOMMU:Enabled

Cache:L1 Cache = 256 kB (max. capacity 256 kB)

L2 Cache = 1024 kB (max. capacity 1024 kB)

L3 Cache = 8192 kB (max. capacity 8192 kB)

Memory:32 GB (max. installable capacity 64 GB)

ChannelA-DIMM2 = 16384 MB, 2667 MT/s

ChannelB-DIMM2 = 16384 MB, 2667 MT/s

Network:bond0: fault-tolerance (active-backup), mtu 1500

eth0: 1000Mb/s, full duplex, mtu 1500

eth1: 1000Mb/s, full duplex, mtu 1500

Kernel:Linux 5.3.8-Unraid x86_64

OpenSSL:1.1.1d

P + Q algorithm:22140 MB/s + 35152 MB/s

 

Latest shutdown was a disaster. Mover got stuck, docker wouldn't stop or start (couldn't see the docker tab, loading not showing anything).

 

Attached my log file before and the shutdown log automatically generated. 

 

If this were a windows pc I would try reinstalling windows, that is my feeling. Not working version on unraid, try again but this is not windows. 

 

My other issue is that my 2nd cache drive is a NTFS format but I don't get the option to format it, it is part of the array as a second cache drive and when I fill up the first drive it runs out of space without touching the second. How do I format it? I tried to change its format but it just says format unknown with no option to change it. I also tried a cache balance in case that might help. 

turrim-diagnostics-20191108-0746.zip turrim-diagnostics-20191108-1059.zip

Edited by ki11gar
Solved

Share this post


Link to post

Have you done memtest?

 

3 hours ago, ki11gar said:

Installed plugins:

Have you tried SAFE mode?

 

3 hours ago, ki11gar said:

My other issue is that my 2nd cache drive is a NTFS format

This may be the root of your problems but I don't know how you could have gotten to that state. I am going to ping @johnnie.black and see what he thinks is the best way to proceed to get your cache pool fixed.

Share this post


Link to post

Cache pool was likely created with v6.7.x and because of a bug with that release metadata isn't redundant, so Unraid can't delete the missing device, also btrfs is crashing on the current pool so possibly related to your shutdown problem.

 

Since the cache isn't redundant and a device is missing you need to backup any data you can from current pool and then reformat.

Share this post


Link to post

After all data is copied stop the array and wipe the SSD(s) with

 

blkdiscard /dev/sdX

 

Replace X with correct identifier, then make sure all members are assigned to the pool, start the array and format pool.

Share this post


Link to post

Thanks I will try once the mover is done and the parity check finishes. Likely tomorrow only. 

Share this post


Link to post

I had a few little issues along the way but I found the answers on this forum and was then able to do as you said. That has solved my overall problem!

For reference the fault was mine. I had installed windows 10 on the 2nd cache drive after I had installed unraid, so that I could install a driver to remove a raid config on my PCIE to SATA card. I had thought that adding it back would be harmless and was dealing with another issue but as you two pointed out it was the 2nd cache drive that was the main issue. 

 

I can now shut down and use the server as intended, gone with a raid 0 single disk mode (to use the full capacity) for my cache and both fill up  properly. 

 

Thank you for you help!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this