Dell T310 trying install unraid


Spaniel

10 posts in this topic Last Reply

Recommended Posts

I have a Dell t310 server that I am having trouble installing via USB. I can't get it to boot via the USB stick. So I tried to boot via uefi and I get the following error. Anyone have a suggestion as this is my first time trying to use unraid.  

 

Also I have tried with the uefi checked and not checked when I made my USB stick.

 

20191124_201151.jpg

Link to post
1 hour ago, Spaniel said:

For some reason in my bios I don't get the option to boot from USB stick

I can't speak with certainty about your T310 but booting from usb was definitely a two step process on my T410.

 

Your first image shows the unraid menu so I feel like the usb is being read, are you able to run memtest from that menu, if not follow jonathanm's advice and run it from an optical drive if need be, this should defintely be your first step.

 

If I'm mistaken and your usb is not able to boot from bios then here is what I do on mine.

  • I boot my dell T410 from bios not uefi
  • The line item you're in currently, Boot Settings, is the second thing I did to get mine working
  • First I went into the other menu item, (probably the one above that says sata...) and move the USB up to the top of the list
  • Then I went into the Boot Settings menu and enabled it

Why there are two menu items involved I'm not sure, but it took me a minute to realize that this was necessary when I first loaded unraid on my server. If this doesn't work, you may not be able to boot from usb, or your usb may not be bootable, read up and see if a bios update would make booting from usb possible. If you don't see the first menu item where you bring the usb to the top if the list let me know, I'll attach a monitor and reboot to take a picture of mine...

Edited by Dissones4U
Link to post
20 hours ago, jonathanm said:

Since the error seems to reference memory, my first troubleshooting step would be a memory test. Since you say you can't get the Unraid stick to boot without UEFI, I'd recommend downloading and running memtest86 from www.memtest86.com

Ok did that like you said. I'm going to put in bigger hard drives but wanted to try and get unraid installed first to make sure it's worth it. Here was my results anything you see???

 

 

20191125_170635.jpg

Link to post

  

4 hours ago, jonathanm said:

You may want to take a look at @rollieindc setup, I believe he's got the same dell server.

Thanks for the handover @Jonathanm! 

 

Ok, first, the system will boot on 2GB - but you will definitely want to get more memory. (And I have 8GB if you want to buy or trade for it. I upgraded to 32GB, and not going back.) 😃 At 2GB, you can't do much, but it's enough to "play with" unRAID.

 

Next, you can boot unRAID in the T310 from the internal (or external) USB. I know, I do it with mine. (See >My first hobby “TOWER”< postings and updates. Have lots of photos of my system for other to follow.)

 

Here is my suggestion: Put the USB key into the inside or front USB port BEFORE powering up the system. As it starts, press the <F11> key to get into the BIOS setup menu. (You do not want the iDRAC or RAID menus!) Once into the BIOS screen, set the boot mode to "BIOS" - not UEFI. Then the boot field selector should provide for the USB as a location of the operating system files for startup - and you have to move the specific USB up (using +/- keys) to the top of the boot list. One thing to note, that the make/kind of USB drive is also important, and it must be a bootable drive type! I tried a "non-standard" (non-bootable) drive, and the drive choked repeatedly (not unlike yours). After rebuilding unRAID on a better USB drive that I had, it booted without issue. 

 

Important Note: IIRC - If you move the USB drive in the T310, then you need to change the boot drive in the BIOS! The T310 server treats the internal, external front and external rear as separate, unique drive location options.

Edited by rollieindc
Link to post
18 hours ago, jonathanm said:

Maybe I'm misreading that screen. Do you really only have 2GB of RAM? If so, I'm not sure that's enough any more. It's possible 4GB may be required.

 

Ok definitely going to update that. We can close this post for now I got it to boot from the front USB slot so I think it installed.  It's at the tower login. So going to mess with it more tonight after work. Thanks and can close this now.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.