Jump to content
Trylo

Machine freezing: end Kernel panic - not syncing: Machine halted

10 posts in this topic Last Reply

Recommended Posts

Hi!

 

I've just upgraded my Unraid and I'm having issues. The machine is freezing.

First I've got this:

 

---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) ]---

So I created a new USB drive, copied config folder and moved a key to the new USB drive, started parity check and after few minutes I've got this:

 

---[ end Kernel panic - not syncing: Machine halted. ]---

Please have a look at the screen shots. I don't know what to do...

 

 

20191202_211035.jpg

20191202_212730.jpg

Share this post


Link to post

I prepared a USB drive with the latest stable version of Unraid and got this:

20191202_230501.thumb.jpg.f60cf7e0d0161f9dba19763a46f2801b.jpg

Share this post


Link to post

I have disabled C-states and inserted rcu_nocbs=0-15 into the syslinux configuration.

After that the system was stable for around 10h and then when I tried to power it down to move it, it hang again.

I'm really clueless and spent countless hours. Should I just buy Intel CPU?

Share this post


Link to post

If you have ryzen go into the bios go to the Power Supply Idle Control option and enable "Typical current Idle". It should be in the CPU freq options of your bios. This is a old ryzen bug. With the typical current idle option enabled you should not need any rcu_nocbs or any tweaks to the C states. Im running a Gigabyte gaming 5 ax370 using a 2700x and its rock solid. Also remember to keep your motherboard updated.

 

https://bugzilla.kernel.org/show_bug.cgi?id=196683

Share this post


Link to post

David literally JUST beat me to the punch on this.  Thanks @david279!  This is exactly what the user needs to do and should resolve the issue.

 

Generally speaking, AMD hardware can be more problematic than Intel for various reasons, so if you want to have a smoother experience in the future, switch to Intel and NVIDIA.

Share this post


Link to post

Or purchase one or two generations back so you're not having to deal with bleeding-edge issues of hardware not entirely supported by a free Open Source OS (Linux as the base).

Share this post


Link to post

Ryzen 7 2700 has been launched a year ago so I thought that by today all issues would be resolved.

 

I couldn't find said option in bios. The version on my bios is 5.8 from 2019/7/5. Next is 6.0 from 2019/8/16, but next to it I have this message: "* ASRock do NOT recommend updating this BIOS if Pinnacle, Raven or Summit Ridge CPU is being used on your system."

https://www.asrock.com/MB/AMD/X370M Pro4/index.asp#BIOS

 

Should I update to 6.0 anyway?

Share this post


Link to post

Solved:

 

For anyone planning on a Ryzen build. Make sure the motherboard you buy has "Power Supply Idle Control". After returning Asrock X370 board and getting a Asus X470 board the system has been finally stable for 1 day and 7 hours.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.