Jump to content

Unraid crashing when starting VM

10 posts in this topic Last Reply

Recommended Posts

Hi there.

I downloaded unraid with the goal of being able to run two systems from a single computer.

My Setup is as follows:
Ryzen 3700x

MSI X470 Gaming Plus MAXX

Patriot Viper 3400 MHz 2x8GB
Crucial P1 1TB SSD

2x RX580 GPUs


So I downloaded unraid, set up the flash drive, made it bootable and enabled SVM and IOMMU in bios. When I booted in unraid, I formated the SSD and assigned it to the array. Once the array was up and running, I transfered a Windows ISO and tried setting up a W10 VM. However the issue was that when I clicked start VM, the system always got super slow (like slow enough to not register keyboard strokes) and eventually died after a minute or two. There was no sign of the VM having started anywhere either. Because this kept repeating itself, I tried assigning different cores and with and without GPU passthrough, I even tried an Ubuntu VM too, but it's always the same scenario. I also tried disabling c-states, adding rcu_nocbs=0-15 to the kernel and setting idle power to typical in bios. None of this seems to have made any difference.

Does anyone have any idea where to start looking for the problem? So far I haven't been able to get a single instance where the system hasn't crashed upon pressing Start on the VM, seemingly no matter the settings/circumstance. 

Share this post

Link to post

Start your VM, make sure you have the problem and then Tools -> Diagnostics -> attach zip file.

Share this post

Link to post

Here is the Diagnostics file 

EDIT: having looked at the log file myself, it seems that it only contains the data since last boot. Hopefully there is something else in the logs to help, because I can't really download the diagnostics data in the same boot cycle since the whole unraid server is the one that locks up, not the VM.


Edited by Creepop

Share this post

Link to post

Since you are running 6.7.2 you should enable the syslog server (under Settings->Syslog Server) to get logs that survive a reboot.

Share this post

Link to post
1 hour ago, Creepop said:

I formated the SSD and assigned it to the array.

Just thought I would mention that SSDs in the array can't be trimmed, and if you intend to have parity in the array you don't want to have SSDs in the array anyway. People usually put SSDs in the cache pool. But you must have at least one disk in the array so if this is the only disk you intend to have then I guess it is the only way to do it.

Share this post

Link to post

In addition to what the guys above suggested, you can also give this a try.

  1. Change the name of your problematic VM to Test_VM (or create a new template called Test_VM)
  2. Install User Scripts plugin from the CA store.
  3. Create a new script like below.
  4. Run it and wait 3 minutes. Hopefully the script works and kill the offending VM 
  5. Tools -> Diagnostics -> attach zip file.


virsh start Test_VM
sleep 120s
virsh destroy Test_VM


Edited by testdasi

Share this post

Link to post

Ok, so I was able to get a log file from the system.

Downloading the diagnostics still seems to only contain info from one boot cycle (maybe I did something wrong, no idea), but I was able to mirror the log to the USB drive. See the attached file.
Please note that the log likely contains multiple boot cycles.


Share this post

Link to post

A small update: While playing around, I was able to start the ubuntu virtual machine in VNC mode for around 40 seconds, after which the host crashed again. 

Tried the VMWare Workstation software and it exhibited simillar behaviour. Normally the VM simply shows a black screen but I was able to get it to show the display once. Again, after around 40 seconds, the VM crashed. While the machine shows a black screen or has crashed, I am unable to power the VM's off, but the host software seems to be responding. 

Other than VM's crashing or causing crashes, the system seems to be stable and I haven't observed anything else that I would call an issue.


Any ideas, where to start digging?

Share this post

Link to post
On 12/6/2019 at 4:06 PM, Creepop said:

Any ideas, where to start digging?



got pretty much the same problem. I am on a Ryzen 3600 with a GTX 970. All was ok for a VM without GPU, then I added the GPU (primary GPU) and that seems to start the problem for me. After that it starts by not showing any VMs in the VMS Tab and than starts freezing.


I will post Logs the next days.

Edited by sub6

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.