Jump to content
unevent

XFS Errors, disk unmountable

9 posts in this topic Last Reply

Recommended Posts

Looking for advice on cause and how to do xfs_repair without causing further damage.  Oldest diagnostics syslog had bunch of errors, looks to be caused after file system was taken offline after xfs error.  Powered down and checked SATA cables, brought back up and disk 2 was unmountable and left it for advice to minimize loss.

 

Edit: Ran xfs_repair -n on disk2 and it is a mess (1900+ lines).  Last parity sync was 14 days ago and was clean. Format and rebuild?  Replace disk2 and rebuild?

 

 

Edited by unevent

Share this post


Link to post

Rebuilding a disk won't fix filesystem corruption, you need to run xfs_repair without -n.

Share this post


Link to post

Ran xfs_repair without options and completed on disk2.  Will look in lost+found later today to see what was trashed.  What would be recommended path to get back online at this point?  Never had corruption and been using since 4.7 days.  Never even had parity sync issue.

Share this post


Link to post
16 minutes ago, unevent said:

What would be recommended path to get back online at this point?

Not sure I understand the question, just start the array.

Share this post


Link to post

Thanks for the help.  I had started array in maintenance mode and still showed unmountable.  Remember stories inthe past about starting array with a troubled disk and loosing data.  Started array normally and now sorting through lost+found to see what I need to replace.  Thanks again.

Share this post


Link to post
14 hours ago, unevent said:

Ran xfs_repair without options and completed on disk2. 

When doing filesystem repair you should capture exactly your input and the resulting output so you can post them.

Share this post


Link to post
6 hours ago, unevent said:

I had started array in maintenance mode and still showed unmountable. 

Disks won't mount in maintenance mode.

Share this post


Link to post
14 hours ago, trurl said:

When doing filesystem repair you should capture exactly your input and the resulting output so you can post them.

I have the logs.  Just had no need to post drive contents to the world.  Lost 1.25TB on this drive.  Perhaps a feature request is to halt parity when xfs reports first error so instead of parity protecting the corruption it keeps the parity intact as much as possible.  Seven plus years with unRaid and first case of corruption and with xfs and data loss.  No power loss, no unclean shutdowns.

Share this post


Link to post
9 hours ago, johnnie.black said:

Disks won't mount in maintenance mode.

lol...yes and second sentence further from that was I started the array normally.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.