Jump to content
MrGrumpie

2 unraid servers on same network (issues!)

7 posts in this topic Last Reply

Recommended Posts

I'm running 2 unraid servers, one named tower and the other named tower2 - they have static IPs so no conflicts.  However, when I'm in the GUI, say for Tower, and I make a change (could be anything, spin down drives, or just refreshing a page) all of a sudden the GUI randomly switches to the other server.  This happens both ways, and happens randomly. 

 

I've also had issues where on reboot I can't connect to network shares for one of the servers - it just returns a "share is already in use" error (Windows 10). 

 

Any ideas for why I keep coming across these issues?

 

 

Share this post


Link to post

 

1 hour ago, MrGrumpie said:

'm running 2 unraid servers, one named tower and the other named tower2 - they have static IPs so no conflicts.  However, when I'm in the GUI, say for Tower, and I make a change (could be anything, spin down drives, or just refreshing a page) all of a sudden the GUI randomly switches to the other server. 

I looked at your logs and did not really see anything out of the ordinary.  You are the first one who has posted about this type of problem.  (There are a lot of folks who have two or more servers in the Unraid community.)  But I do have a couple of thoughts. 

 

First, are you using https to access your servers?  If you are, compare the two addresses (a string of Hexadecimal numbers followed by .unraid.net) and make sure they are unique!  Should you find an identical address, there is probably some issue with your security certificates.

 

Second, is the possibility of operator error.  I know that I have opened up the wrong GUI on several occasions and I have radically different banners on my two server and each one has the server name in 3/4" high letters!  And when having both Gui's open, I  have ended up in the wrong one by mistake.  (And your having two servers with virtually identical names does not help.)  Which brings up another question?  Are you using banners?  If not, I would suggest that you consider using them.  There is a thread that has a lot of examples that you can use if you don't want to create your own.  Here is a link to  it:

 

      https://forums.unraid.net/topic/40389-share-your-banners/ 

 

Share this post


Link to post

I often have both my servers live but have never seen this issue.  I also wonder whether the similarity in the naming may have been helping your browser to auto-fill the address.  I use IP addresses to direct the broswer rather than the server names (and have them stored in bookmarks) and that helps to avoid the problem  I also have one server set to the black display theme and the other set to white, just to help make sure I know what I am doing.

Share this post


Link to post

Did you just change the name for Tower from Tower2?  The diagnostics in the syslog for "Tower" show that it's name was Tower2

 

Having 2 servers named the same would cause nothing but problems, and you may need to clear out the DNS cache or something from Windows in order for it to reflect that change you made.  (I've never been a fan of unRaid having a static default name for the servers for this very reason)

Share this post


Link to post
1 hour ago, Squid said:

Did you just change the name for Tower from Tower2?  The diagnostics in the syslog for "Tower" show that it's name was Tower2

Good catch.  @MrGrumpie, I would suggest rebooting both servers.  Clear your browser cache.  Then check on your router to make sure that make that the Hostnames(/Server_names) correspond to the proper IP addresses. 

 

If they should not match on the router, you will have to shutdown/powerdown everything on the network and reboot the system starting with the router.  You also have both servers setup to be the Local Master.  You should really only have one of your servers designated for this duty.  (It should be the one that you intend to have on 24/7.)  By the way, if you do have to so a complete reboot, it could take a half hour to an hour for everything to stabilize on SMB.  (The polling times for SMB is in the tens of minutes range!)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.