Mac OS VM - USB devices hang


5 posts in this topic Last Reply

Recommended Posts

Hi all,

I recently installed Mac OS Catalina with the help of the amazing Spaceinvader One and his latest guide.
Everything went smooth and Catalina is now installed on its own SSD drive.

The problem is as shown on the video attached.

Video showing the problem

The USB devices hang and/or seem unresponsive for seconds making the system unusable.
When I move the mouse for example on the login screen, it moves extremely slow and the movement is choppy as it doesn't have a good connection (it is a wired mouse and keyboard).
That seems to be better when I login through Anydesk as I cannot type my password with the keyboard at all (keystrokes never register).
Mouse movement is choppy and unusable after login but with a slight better performance (see video for more).
Bluetooth discovers and connects to devices (Magic Mouse, magic keyboard, Magic Trackpad) and seems to drop the connections every second and tries to reconnect all the time.
Everything USB related is unreliable.

Tried all 3 options on USB controller in the template but the result is always the same.

My Setup:
Unraid Version: 6.8.0
M/B: ASRock X99 Extreme4 Version 
CPU: Intel® Core™ i7-5820K CPU @ 3.30GHz (6 cores)
HVM: Enabled
IOMMU: Enabled
Memory: 32 GiB DDR4

VM Setup:
4 cores
16GB Ram
Machine: Q35-3.1
Bios: OVMF
USB Controller: 3.0 (nec XHCI)
GPU: AMD Radeon 480x
The PCI device that I Passthrough is: 
Intel C610/X99 series chipset USB xHCI Host Controller | USB controller (00:14.0)

Any help will be appreciated.


Link to post
16 hours ago, david279 said:

Is it 10.15.2? I would have have everything USB  running thru the USB controller. Get a USB hub if needed. I found directly passing thru USB device to be a little flakely sometimes. Especially for Mac VMs.

Hi @david279 and thanks for the response.
I've tried several times installing Mac Os since 2017 with guides from @SpaceInvaderOne.
All succesfull BUT with the same issue regarding the USB Controller.
So i dont think that its tied to the version of the Mac os, which is btw 10.15.2.

I do not have the option to passthrough only the Mouse for example because the USB devices are not at all visible under that section as you can see bellow.image.png.f4585121cfed6b0cc7be8b2618872610.png

That is why i pass-though the entire USB controller to the VM.
I read in forums about some kexts that are helpful in these situations but couldn't find any for my X99 that are compatible.
The most easy thing to do is buy a new PCI USB Controller that is compatible with Unraid and Mac os.
But apart from the fact that i don't want have a free PCI slot, i don't know which USB controllers are compatible for Unraid and Mac os.

Maybe some kexts will do the job and im trying to focus there first to see if i can find a sollution 

Link to post
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.