[Support] spaceinvaderone - Shinobi Pro


334 posts in this topic Last Reply

Recommended Posts

1 hour ago, neow said:

hello all,

 

i have 4 reolink cam, 1unraid nuc, 1syno

everything runs smooth on syno

 

with nuc and shinobi pro one camera (always the same) has problem time to time :

https://d.pr/i/mFDaQC

https://d.pr/i/Pdl8Zs

left synology right unraid at the same moment : https://d.pr/i/8LMOFw the camera isn't working

 

4 cam are identicals and have the exact same settings

 

Any idea?

i solved the problem, the bugging reolink cam had not the same firmware than the 3 others . it has an older one.

 

the procedure is :

 

1- to go in a browser to the reolink interface : https://d.pr/i/2muUCs

2- login

3- i downloaded here the new firmware : https://github.com/hn/reolink-camera

4 - https://d.pr/i/ppAfsh

 

hope this will help someone i searched 2 hours :)

Link to post
  • 2 weeks later...
  • Replies 333
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I got this figured out and am able to use the MariaDB inside the container to make this work. No need to run a dedicated MariaDB docker instance.   First, make sure the shinobipro docker con

Overview:  Support for Docker image Shinobi Pro Documentation: https://shinobi.video/docs/ Video Guide:  Showing how to setup and configure Shinobi Pro.     If you w

Update to the container. Changing tag to :nvidia will allow you to use you nvidia gpu with the container. Thankyou  @gshlomi for your message  regarding this.    There are some cha

Posted Images

On 12/14/2020 at 1:41 PM, damnshaneisthatu said:

Apologies in advance for my lack of networking savvy here.

 

Was following spaceinvader's incredible tutorial for setting up Shinobi. Am using the same switch as specified in Part 2 of the series: GS324TP S350 Series 24-Port switch.

 

So my issues are two-fold:

  1. Unsure how to set/determine the IP of my VLAN eg ports 7 & 8.
  2. As a result of 1, can't access Shinobi docker web UI.

Thank you in advance!

Screen Shot 2020-12-14 at 12.35.58 PM.png

Screen Shot 2020-12-14 at 12.35.20 PM.png

I have the same issue, still looking how I can have access to shinobi form other PC on my LAN. I am able to ping the IP but not able to access the webUI. I know the webUI is working because if I curl shinobi from the server I am able to see html. I f some one has any idea it will be great thanks.

 

PS: I try to add a vlan in windows 10, so I created a new vlan adapter with the same vlan that shinobi and got the same issue. If I curl from windows, I got connection refused.

Link to post
On 12/14/2020 at 9:07 PM, skois said:

Hey, is there any way to remove the playback delay at all? 
I can't understand why it have so much delay (10sec+) I saw on a lot of posts that is because we are playing from browser.

Blue iris does play via browser too but the delay is max 1sec. (Note that this delay is while 3 users watching all the streams *3 for now*)
I really like shinobi, but this delay is a deal breaker :(
I have tried every codec and "fix" i found online but cant get it down from 8-10 secs..

 

you are using H.264 to show in Browser?

i havent compared the delay by second, but when i try via "Guarding Vision" app on Win is much more smoother then via Shinobi, seems like is not the best option for Cams :(

Link to post

I do use Shinobipro now for a while.

I do have some questions:

  1. Is it possible to set a time schedule for activating motion detection? (Only at night for example?) If yes how to set up?
  2. I do see that after a while the Shinobipro docker is using a lot off cpu capacity. After stopping and starting the docker, the cpu use is normall again.
    Is there a reason for that? And how to prevent?

Thansk for the answers

Link to post

I should add a note from a while back:

For those with Reolink cameras, at least the RLC-520 series, there was a firmware update that cured all of my stuttering and image corruption problems.

Build No. build 20103112
Hardware No. IPC_51516M5M
Config Version v3.0.0.0
Firmware Version v3.0.0.116_20103112
Details IPC_51516M5MS10E1W01100000001

 

Also, Reolink, in a rather stupid move in my opinon, are shipping RLC-520 cameras with a different hardware version: IPC_515B16M5M

There's no indication on the outside of the cameras that the hardware inside is different, and it takes a completely different firmware as well.

Quite annoying.

Link to post

Now to my question of the day:

For reasons I won't get into, I need to store a tremendous number of days of video footage from my 4 current cameras.  I'm planning on adding more cameras soon, which will only exacerbate the problem.  I'm currently storing over 50TB of footage, which I just got permission to edit down in the future.  Each camera has an SD card for local storage as well, and is basically a backup in case Shinobi does something weird.  The cameras only record on motion detection.  Shinobi records 24/7.

 

What I need to know is, can I leave the cameras at their maximum 25fps rate, but have Shinobi safely and cleanly record at a lower FPS rate? Say 15fps?  Will I experience any issues if I do so? Should I set the cameras to a frame rate that's divisible by 2? say camera 24fps and Shinobi 12fps?

Edited by sota
Link to post

So here's an oddity...

When I restart shinobi with a fresh storage disk, the still frames I have it capturing also, start out at about 1.75MB/image, 2560x1920 24bpp.

Roughly 43 minutes later, those same snapshots have dropped to .81MB/image.  It's a steady, progressive drop between those two sizes, starting about 10 minutes in to recording/capturing.

that's just weird.

 

Link to post
On 5/16/2020 at 11:10 PM, jevan23 said:

Thought I'd expand on this as it took some time for me to figure out what changes were needed in the shinobi container, and it might help out someone else:

 

Created a mariadb database as follows:

CREATE USER ‘shinobi’ IDENTIFIED by ‘password’;

CREATE DATABASE IF NOT EXISTS shinobi;

GRANT ALL PRIVILAGES ON shinobi.* TO ‘shinobi’ IDENTIFIED BY ‘password’;

 

now you can edit the shinobipro container and make the following changes based on the new mariadb database created above:

 

MYSQL_USER: shinobi

MYSQL_DATABASE: shinobi

MYSQL_HOST: IP address of unraid

maria db database location, change it to: /mnt/user/appdata/mariadb/databases/shinobi/

MYSQL_PASSWORD: password

 

Wondering if anyone can help. I tried the hotfix as above, and the docker container logs show shinobi as ready.

 

I go to the landing page, and my username/password are not accepted. I've tried a combination of the default user/pass, the docker container user/pass. None of these seem to work and the logs don't show anything. Any thoughts?

Link to post
  • 2 weeks later...

I have reverse proxy set up and the Shinobi dashboard is not working properly... No Camara, CPU/RAM, etc. Showing.

When connected to Shinobi locally it works fine.

I have Nextcloud working fine on the proxy. I have followed instructions above, etc. But can't get it to work.

 

Any suggestions ? 

Link to post

Gday all,

 

Recently started installing camera's and was planning on using shinobi docker on unraid (for now without hardware acceleration).

Have been having some issues, primarily with setting up the monitor. The feeds just keep freezing up, runs for 10 seconds roughly.

 

This happens both on the mainstream and substream, and both on a Dahua and my 8 Reolink C410's, all are powered via PoE.

 

Main stream is set to 3mp resolution with 3000kb/ps bandwidth, codec set to main on the Reolink cam's. Substream is set to main other settings unchanged.

 

Anyone have an idea why the live views from the Shinobi monitor keep freezing? logging in directly, the streams work just fine.

Also happens both on local client, and a VM running on unraid itsself, using VNC. CPU assigned cores to the VM hit about 50% with 5 camera's showing.

 

//Caen

Link to post
On 1/1/2021 at 10:47 PM, canedje said:

I do use Shinobipro now for a while.

I do have some questions:

  1. Is it possible to set a time schedule for activating motion detection? (Only at night for example?) If yes how to set up?
  2. I do see that after a while the Shinobipro docker is using a lot off cpu capacity. After stopping and starting the docker, the cpu use is normall again.
    Is there a reason for that? And how to prevent?

Thansk for the answers

There is an option for this yes. If you look under the monitor settings, you will find a 'presets' section. In this you can schedule the presets via a schedule. 

 

Simply make a preset, add the camera's to them and apply an schedule.

Link to post

Hi Everyone,


I think I have most of the shinobi setup done now.  I'm currently using a vlan (555) and also a reverse proxy through Swag.

 

When I'm on the network, everything works fine.  I can access everything perfectly.  The weirdness happens when I try and access outside of the network.

 

- I'm using the Beta Shinobi app as well, and if I'm on cellular, and using that app to login to myshinobidomain.duckdns.org, I can see my cameras and it works as expected (although i'm using "legacy loading").

 

- When I try and use safari to login to myshinobidomain.duckdns.org, I can log into shinobi, but I do not see any cameras.  

 

Any ideas?

 

 

Screen Shot 2021-01-16 at 2.28.33 PM.png

Screen Shot 2021-01-16 at 2.29.59 PM.png

Link to post
On 1/26/2021 at 2:23 PM, Caennanu said:

Gday all,

 

Recently started installing camera's and was planning on using shinobi docker on unraid (for now without hardware acceleration).

Have been having some issues, primarily with setting up the monitor. The feeds just keep freezing up, runs for 10 seconds roughly.

 

This happens both on the mainstream and substream, and both on a Dahua and my 8 Reolink C410's, all are powered via PoE.

 

Main stream is set to 3mp resolution with 3000kb/ps bandwidth, codec set to main on the Reolink cam's. Substream is set to main other settings unchanged.

 

Anyone have an idea why the live views from the Shinobi monitor keep freezing? logging in directly, the streams work just fine.

Also happens both on local client, and a VM running on unraid itsself, using VNC. CPU assigned cores to the VM hit about 50% with 5 camera's showing.

 

//Caen

 

So after a bit of testing, i have come to a somewhat conclusion, and i hope others can confirm i'm right or know a bit more tweaks, as i'm not out of the woods yet.

 

I was using poseidon as the codec, when switching to HLS i seem to have atleast a near constant stream on the dashboard. The C410's are running about a minuten behind on reality and the Dahua is running about 5 minutes behind (the substream refuses to work now?)

 

However, also with FLV i seem to have issues. Every so often (its sporadic) the camera's go black.

The recordings are fine and do not have this issue.

 

Any1 know why the camera on the dashboard / monitor go black? or why my substream on the dahua doesn't want to work?

Edited by Caennanu
Link to post
On 12/31/2020 at 6:48 PM, killeriq said:

you are using H.264 to show in Browser?

i havent compared the delay by second, but when i try via "Guarding Vision" app on Win is much more smoother then via Shinobi, seems like is not the best option for Cams :(

I had tried everything. Nothing was good enough for live view. I'm back with Blue Iris. Just need to find some time to configure AI Tools/ Deepstack / Motion Detection to get proper alerts

Link to post

I'm running into excessive memory usage again.

 

eb 5 15:10:13 Cube kernel: Task in /docker/973fc918d6f3ca143c8c5bb531b666066c0b41cef6cde6296e630d4c68ebf763 killed as a result of limit of /docker/973fc918d6f3ca143c8c5bb531b666066c0b41cef6cde6296e630d4c68ebf763
Feb 5 15:10:13 Cube kernel: memory: usage 8388608kB, limit 8388608kB, failcnt 157206156
Feb 5 15:10:13 Cube kernel: memory+swap: usage 8388608kB, limit 16777216kB, failcnt 0
Feb 5 15:10:13 Cube kernel: kmem: usage 102184kB, limit 9007199254740988kB, failcnt 0
Feb 5 15:10:13 Cube kernel: Memory cgroup stats for /docker/973fc918d6f3ca143c8c5bb531b666066c0b41cef6cde6296e630d4c68ebf763: cache:22676KB rss:8263024KB rss_huge:2912256KB shmem:3408KB mapped_file:396KB dirty:0KB writeback:2112KB swap:0KB inactive_anon:1584KB active_anon:8264524KB inactive_file:17288KB active_file:1420KB unevictable:0KB
Feb 5 15:10:13 Cube kernel: Tasks state (memory values in pages):
Feb 5 15:10:13 Cube kernel: [ pid ] uid tgid total_vm rss pgtables_bytes swapents oom_score_adj name
Feb 5 15:10:13 Cube kernel: [ 39251] 0 39251 394 1 45056 0 0 start.sh
Feb 5 15:10:13 Cube kernel: [ 39348] 100 39348 122168 47390 499712 0 0 mysqld
Feb 5 15:10:13 Cube kernel: [ 39894] 0 39894 55941 6802 1245184 0 0 node
Feb 5 15:10:13 Cube kernel: [ 39933] 0 39933 345587 29628 3170304 0 0 node /opt/shino
Feb 5 15:10:13 Cube kernel: [ 39940] 0 39940 57366 6237 1622016 0 0 node /opt/shino
Feb 5 15:10:13 Cube kernel: [ 32967] 0 32967 52263 2786 892928 0 0 node
Feb 5 15:10:13 Cube kernel: [ 33078] 0 33078 576946 364428 3301376 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 65072] 0 65072 52301 2886 888832 0 0 node
Feb 5 15:10:13 Cube kernel: [ 65160] 0 65160 15112 1290 139264 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 6989] 0 6989 52303 2784 901120 0 0 node
Feb 5 15:10:13 Cube kernel: [ 7005] 0 7005 52249 2869 880640 0 0 node
Feb 5 15:10:13 Cube kernel: [ 7160] 0 7160 15121 1853 151552 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 7199] 0 7199 599354 400451 3563520 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 7430] 0 7430 52302 2736 872448 0 0 node
Feb 5 15:10:13 Cube kernel: [ 7625] 0 7625 15122 832 147456 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 27318] 0 27318 47413 1116 483328 0 0 node
Feb 5 15:10:13 Cube kernel: [ 27326] 0 27326 77773 62416 655360 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 45713] 0 45713 52260 2610 884736 0 0 node
Feb 5 15:10:13 Cube kernel: [ 45815] 0 45815 15128 1836 151552 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 63470] 0 63470 52241 2586 888832 0 0 node
Feb 5 15:10:13 Cube kernel: [ 63691] 0 63691 601871 387489 3514368 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 19495] 0 19495 52189 2588 872448 0 0 node
Feb 5 15:10:13 Cube kernel: [ 19510] 0 19510 593045 393270 3555328 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: [ 15708] 0 15708 52226 2595 876544 0 0 node
Feb 5 15:10:13 Cube kernel: [ 15912] 0 15912 531656 320391 2957312 0 0 ffmpeg
Feb 5 15:10:13 Cube kernel: Memory cgroup out of memory: Kill process 7199 (ffmpeg) score 191 or sacrifice child
Feb 5 15:10:13 Cube kernel: Killed process 7199 (ffmpeg) total-vm:2397416kB, anon-rss:1601800kB, file-rss:0kB, shmem-rss:4kB
Feb 5 15:10:13 Cube kernel: oom_reaper: reaped process 7199 (ffmpeg), now anon-rss:0kB, file-rss:0kB, shmem-rss:0kB

Link to post
On 1/26/2021 at 5:23 AM, Caennanu said:

Gday all,

 

Recently started installing camera's and was planning on using shinobi docker on unraid (for now without hardware acceleration).

Have been having some issues, primarily with setting up the monitor. The feeds just keep freezing up, runs for 10 seconds roughly.

 

This happens both on the mainstream and substream, and both on a Dahua and my 8 Reolink C410's, all are powered via PoE.

 

Main stream is set to 3mp resolution with 3000kb/ps bandwidth, codec set to main on the Reolink cam's. Substream is set to main other settings unchanged.

 

Anyone have an idea why the live views from the Shinobi monitor keep freezing? logging in directly, the streams work just fine.

Also happens both on local client, and a VM running on unraid itsself, using VNC. CPU assigned cores to the VM hit about 50% with 5 camera's showing.

 

//Caen

Have you tried this?

 

https://hub.shinobi.video/articles/view/PHPllc46JMDm83W

 

Which Dahua camera do you have ?

Link to post
On 9/28/2020 at 7:20 PM, sota said:

are there any suggestions for cheap GPUs that would benefit Shinobi and would work with unRAID?

and how do I determine if such an addition is of value?

Thoughts on this one as well?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.