Jump to content

WIN 10 VM - DEll R710 - VirIO Driver?

6 posts in this topic Last Reply

Recommended Posts

Hello all,


I have been messing with unraid for a while and just migrated to a Dell R710 rack server. 

Now I would like to try installing a Win10 VM.

Set up is done and we get to the install stage but can't find a driver in the "virtio-win-0.1.160-1.iso" file that works. 

Tried everything and no disk shows up....

I have tried all of the possible options and the only one that shows a driver that is compatible and it doesn't work.


I have also search the $#^& out of this forum with no joy.





This is the sheet but can't find a driver that works. 

If anyone has one of these servers and/or has a suggestion please let me know.

Is it the vdisk type? vDisk bus? CPU mode?

Just too many options and combinations to do trial and error.


Thanks in Advance



Share this post

Link to post

The VirtIO driver should be in every virtio ISO, I remember a user recently that was having a similar issue and the problem was the Windows ISO, you can try redownloading it from MS website.

Share this post

Link to post



Well I am not sure what did it but I have a Windows 10 VM up and running. I changed a few things in my property sheet and that seems to have done it.


First is my hardware setup:

Dell R710 server, 12 Xeon 5600 Series processors (24 with HT), 48G memory, 6 Sata HD


This is what I did to the best of my recollection:


1. Grabbed a new copy of windows 10 from Microsoft using the Media Creation Tool - https://www.microsoft.com/en-ca/software-download/windows10

2. Updated driver files to virtio-win-0.1.171.iso at https://docs.fedoraproject.org/en-US/quick-docs/creating-windows-virtual-machines-using-virtio-drivers/

3. Changed the OS Install CDROM bus to Sata

4. VM Property sheet:




It then booted into Windows install.

5. To get the disk to work I had to use the Fedora Red Hat AMD dirvers (?!?!? not sure why this worked since this is a Xeon system).

6. Install completed .... but I had no internet so .....

7. Installed the network driver ....

8. Up and running


I also installed a graphics driver to get a more reasonable screen size:

and a virtual sound device....


Thats it and it works wonderfully.




PS: Thanks Johnnie Black for the redirection. 😁

Edited by toolmanz
added thanks

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.