Jump to content
limetech

Unraid OS version 6.8.1 available

109 posts in this topic Last Reply

Recommended Posts

Upgraded from 6.8.0 a few days back without issue -- still have WSDD disabled, have not tried to see if it's still a CPU HOG or not.

Share this post


Link to post
43 minutes ago, SpecFroce said:

WSDD? @BRiT

 

This bug where WSDD for Samba Discovery pegs 1 CPU core at 100%:

 

 

Share this post


Link to post
2 hours ago, Ginfrecss said:

Ok thx !

I did this and it reported 0 errors / issues.  I doubt it's the problem ?  Using the same USB as in 6.8.0 and I did not have that issue.

Share this post


Link to post

updated without issues, no far so good.

Thank you guys for all the hard work.

Share this post


Link to post

Upgrade seemed to work, but... system won't boot, it's in a loop

boot:
Undef symbol FAIL: openConsole
Failed to load libutil.c32
Failed to load COM32 file menu.c32
boot:
...

I'm going to go with the assumption that my USB stick is corrupt and hope to recover. But...any suggestions or insights are appreciated.

Share this post


Link to post
5 minutes ago, rbroberts said:

I'm going to go with the assumption that my USB stick is corrupt and hope to recover. But...any suggestions or insights are appreciated.

Well, that's disappointing. I just pulled the USB stick and and ran chkdsk on it from my Windows 10 laptop; chkdsk reports it is just fine.

Share this post


Link to post

Okay, so...in spite of the BIOS boot menu having the USB stick as the first choice, it seems to be dropping all the way down to PXE boot which is where that message is coming from. So it looks like the upgrade somehow made the USB stick unbootable. Is there a standard way to recover from that?

Share this post


Link to post
17 minutes ago, rbroberts said:

Is there a standard way to recover from that?

try running makebootable again would be my first choice.

Share this post


Link to post
8 hours ago, Frank1940 said:

try running makebootable again would be my first choice.

No joy on that. make_bootable.bat ran normally, looks like it worked, but it's going into exactly the same loop.

Based on this page: https://wiki.unraid.net/Files_on_v6_boot_drive, I can't see anything obvious I'm missing, the files in syslinux look normal. menu.c32 is there.  I've not no clue at this point.

D:\>dir
 Volume in drive D is UNRAID
 Volume Serial Number is 1EC4-B638

 Directory of D:\

01/11/2020  03:17 AM         7,483,392 bzfirmware
01/11/2020  03:17 AM         4,682,400 bzimage
01/13/2018  01:23 AM    <DIR>          EFI
01/13/2020  09:55 PM    <DIR>          config
01/11/2020  03:22 AM                65 bzfirmware.sha256
01/11/2020  03:22 AM                65 bzimage.sha256
01/11/2020  03:17 AM         9,515,008 bzmodules
01/11/2020  03:22 AM                65 bzmodules.sha256
01/13/2020  09:54 PM    <DIR>          syslinux
01/03/2017  01:42 AM    <DIR>          custom
04/13/2017  05:14 AM            14,322 readvz
10/21/2019  08:42 AM    <DIR>          logs
01/13/2020  09:54 PM    <DIR>          previous
01/11/2020  03:22 AM       129,684,628 bzroot
01/11/2020  03:19 AM        71,207,536 bzroot-gui
01/11/2020  03:22 AM                65 bzroot-gui.sha256
01/11/2020  03:22 AM                65 bzroot.sha256
01/11/2020  03:17 AM             1,760 make_bootable.bat
01/11/2020  03:17 AM             3,291 make_bootable_linux
10/21/2018  02:14 AM    <DIR>          preclear_reports
01/11/2020  03:17 AM             2,428 make_bootable_mac
01/11/2020  03:17 AM           150,024 memtest
01/11/2020  03:17 AM            14,391 changes.txt
01/11/2020  03:17 AM             7,975 license.txt
01/11/2020  03:17 AM               492 syslinux.cfg-
              18 File(s)    222,767,972 bytes
               7 Dir(s)  31,198,527,488 bytes free
D:\syslinux>dir
 Volume in drive D is UNRAID
 Volume Serial Number is 1EC4-B638

 Directory of D:\syslinux

12/17/2016  08:19 PM    <DIR>          .
12/17/2016  08:19 PM    <DIR>          ..
01/12/2018  11:23 PM           122,308 ldlinux.c32
01/12/2018  11:23 PM           186,500 libcom32.c32
01/12/2018  11:23 PM            24,148 libutil.c32
01/12/2018  11:23 PM             1,767 make_bootable_mac.sh
01/12/2018  11:23 PM            10,772 mboot.c32
01/12/2018  11:23 PM               447 mbr.bin
01/12/2018  11:23 PM            26,596 menu.c32
01/12/2018  11:23 PM           238,836 syslinux
01/12/2018  11:23 PM               492 syslinux.cfg
01/12/2018  11:23 PM           243,712 syslinux.exe
01/12/2018  11:23 PM             1,654 make_bootable_linux.sh
01/12/2018  11:23 PM           272,848 syslinux_linux
              12 File(s)      1,130,080 bytes
               2 Dir(s)  31,198,527,488 bytes free

 

Share this post


Link to post
7 minutes ago, rbroberts said:

No joy on that. make_bootable.bat ran normally, looks like it worked, but it's going into exactly the same loop.

Backup config folder from flash then recreate it with the USB tool or manually, finally restore config folder.

Share this post


Link to post

Is anyone else experiencing slower copy speeds? Previously I was on 6.5.3 and upgraded to 6.7.2, but went back to 6.5.3 because copying speeds from my SSD cache drive to the array went down substantially: from about 74 MB/s to  52 MB/s. Now I've upgraded from 6.5.3 to 6.8.1 and unfortunately am experiencing the same slow copy speeds (in fact possibly even slightly slower).

Share this post


Link to post

I have a quick question: To be cautious as a lot of us have invested lots of time in our Unraid setups and configuration, what would be the best suggestion to backup unraid before attempting an upgrade? Just in case something goes wrong. Also, are there any suggestions on running chkdsk or anything before attempting the update?

 

Thanks

Share this post


Link to post
1 minute ago, mwoods98 said:

I have a quick question: To be cautious as a lot of us have invested lots of time in our Unraid setups and configuration, what would be the best suggestion to backup unraid before attempting an upgrade? Just in case something goes wrong. Also, are there any suggestions on running chkdsk or anything before attempting the update?

 

Thanks

I just download a backup of flash. That contains everything you need to revert to the current OS if you can’t access the webUI after an upgrade.

Share this post


Link to post
3 minutes ago, wgstarks said:

I just download a backup of flash. That contains everything you need to revert to the current OS if you can’t access the webUI after an upgrade.

@wgstarks Would that be as simple as just browsing to the flash drive and just copying everything over? to a backup folder? 

Share this post


Link to post
21 minutes ago, mwoods98 said:

@wgstarks Would that be as simple as just browsing to the flash drive and just copying everything over? to a backup folder? 

The easier way is click on the flash drive on the Main tab and select the Backup option.

  • Like 1
  • Haha 1

Share this post


Link to post
4 minutes ago, mwoods98 said:

@wgstarks Would that be as simple as just browsing to the flash drive and just copying everything over? to a backup folder? 

Main>flash>flash backup. There will probably be a short delay while the zip is created.

Share this post


Link to post
3 minutes ago, mwoods98 said:

@wgstarks Would that be as simple as just browsing to the flash drive and just copying everything over? to a backup folder? 

It's as simple as browsing to Flash page via Main and clicking Flash Backup button.  This downloads a zip file containing everything on your usb flash boot device.  You can then use this file to feed into the USB Creator tool.

  • Like 1
  • Thanks 1

Share this post


Link to post

A few days in: No issues with upgrade or in the days since. I had no issues with 6.8.0 either.

Share this post


Link to post

OK. 6.8.1 won't boot unless I use safe mode. Unraid has been stable for me for 12 years.

How do I fix or downgrade back to 6.8.0?

IMG_1158.jpeg

Share this post


Link to post
8 minutes ago, klevans69 said:

6.8.1 won't boot unless I use safe mode.

Which tells you that its a plugin interfering (probably way out of date or something)

9 minutes ago, klevans69 said:

How do I fix

What's the contents of /config/plugins on the flash drive?

9 minutes ago, klevans69 said:

downgrade back to 6.8.0?

Tools - Upgrade OS will allow you to downgrade

Share this post


Link to post
10 hours ago, johnnie.black said:

Backup config folder from flash then recreate it with the USB tool or manually, finally restore config folder.

Thanks, that worked perfectly and was relatively painless.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.