Jump to content
cuutip

Another USB Ethernet Passthrough issue

2 posts in this topic Last Reply

Recommended Posts

I have been reading about these posts how folks are moving their pfsense boxes
over to an unraid VM, and I have been been shooting to do the same with my Sophos UTM.
well, the vm runs faster (clearly) and I have already seen some better performance from
running it for a small amount of time.

My main issue is I cannot get the USB ethernet dongle that is on my current Sophos box to
be passed in successfully. the VM sees the dongle but errors out durrng the modprobe with


r815x: probe of 1:1-2.0 failed with error -32

 

I have a USB dongle that has no issue being passed through but it is only 10/100, and I have
noticed degraded performance using it, so I dont want to keep using it. I have read the following

community/forum posts for research:

 

***GUIDE*** Passthrough Entire PCI USB Controller
 ***GUIDE*** Passing Through Network Controllers to unRAID 6 Virtual Machines
 USB Ethernet Passthrough - Is it possible?
 How to pass through a physical Network Controller in unRAID

 

my failed troubleshooting includes:
 adding the USB device directly into the 70-persistent-net rules file: didn't work
 probing the r815x and attempting to force it to take: didn't work
 i tried adding <driver name == r815x/> into the VMs XML configuration: didn't work
 I've deleted the 70-persistnent-net-rules and crossed-my fingers and hoped it would configure it.: didst work
 for my 10/100 dongle, this works just fine. UnRaid lists it as an ICS Advent DM9601 (0fe6:9700)
 letting the system configure the 70-persistent-net rules file then switching the usb information with the 0bda:8153 and MAC from the r815x chipset. this breaks it and I have to reload from snapshot.
 I thought the issue was using ehci instead of xchi cause it was a USB 3.0 dongle. didn't work.
 so I put the dongle on the other USB busses and tried both ehci and xhci configurations, that didn't work.
 I even purchased 3 different dongles and ALL of them, once I plugged it in, came up as 0bda:8153 (ppl should be forced to list their chipsets :( smh) didnt work

 

My unraid config:
unRAID version: 6.41
Model: Custom
M/B: Dell Inc. - 0GXM1W
CPU: Intel® Core™ i7-3770 CPU @ 3.40GHz
HVM: Enabled
IOMMU: Enabled
Cache: 256 kB, 1024 kB, 8192 kB
Memory: 32 GB (max. installable capacity 32 GB)
Network: bond0: fault-tolerance (active-backup), mtu 1500
 eth0: 1000 Mb/s, full duplex, mtu 1500
Kernel: Linux 4.14.16-unRAID x86_64
OpenSSL: 1.0.2n

 

Not sure my VM config would be helpful considering that it does work, just not with this ONE instance of an r815x passthrough. this is the SAME dongle that is being used right now on the hard box.

I have tried upgrading to 6.8 but doing so killed my SMB shares. I did some initial reading/research on it and I am not using SMBv1/cifs for my windows 10. I downgraded cause 6.41 has no issues with Windows 10 and SMBv1 turned off. So, Im trying to pick my battles here.

 

please help. I've been pounding my head on this one for awhile.

Edited by cuutip

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.