Jump to content
martinf

Vlans not available in-for docker

3 posts in this topic Last Reply

Recommended Posts

Greetings

I'm working on setting up some ip cameras and shinobi_pro after looing at the excellent videos from spaceinvader one.

First, the vlans would not stick but after turning off vlans and then enable vlans and create the first vlan at the same time, I got the vlans to stick and work.

I now have the vlans I need and I can  also see them in cli "ip addr" show them as br0.[nr].

In docker, I have pulled down shinobi_pro and I can only choose between [bridge, host, none, custom:br0]

None of the vlans is shown in the list. The same if I change to advanced mode.

Any suggestions what I'm doing wrong?

Thankfull for any hints.

Cheers

 

Share this post


Link to post

I'm currently trying to add it manually via cli.

docker network create -d macvlan --subnet=192.168.15.0/24 --gateway=192.168.15.1 -o parent=br0.15 CCTV

 

Any better ways?

Cheers

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.