USB is Not Read-Write


Recommended Posts

Hi all,


Pretty sure I've seen this posted before but I couldn't find it.

I've just tried to update my server to the latest version of Unraid but I received an error:

plugin: run failed: /bin/bash retval: 1

Trying to update plugins errored out with either the same error or a general failure:

plugin: updating: community.applications.plg

Cleaning Up Old Versions

plugin: downloading: ... failed (Generic error)
plugin: wget: download failure (Generic error)

I've then got a small notification that the USB drive was not read-write.

The server was rebooted "just in case" and on loading, just before the final console login, it listed a bunch of dockers that couldn't open temp folders because of read-only.


I'm a little nervous as this is the first time I've actually had anything "go wrong" with my server.

The server booted up, has let me log into the WebGUI and has begun its usual parity check but the error saying USB was not read-write appeared again.


As a precaution, I've downloaded a flash backup.


The flash drive is only a few years old and is a Sandisk Cruzer Fit 16GB drive from Amazon.


Background aside, is this indicative of a failing USB drive?

Here's the disk log information:




If this disk is failing, can I take the backup I've just made, get a new 32GB cruzer drive from Amazon, copy the contents of the zip over, re-licence the USB drive and carry on like nothing else happened?





Link to comment
On 1/19/2020 at 2:22 AM, trurl said:

Put flash in your PC and let it checkdisk.


Are you booting from a USB2 port? You should.



Yes it's booting from a USB 2.0 port.

I've run check disk, I got the message that there were errors and prompted to fix them, which I confirmed to do.



This takes a few seconds before returning this message:



I've gone into CMD prompt, into DISKPART and run to clear the readonly attribute from the drive but it never changes the current read only state from the disk.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.