ASRock x570 Taichi has no options to passthrough ANY PCIe devices in VM creation? Wrong BIOS settings? Help!


jazzy192

3 posts in this topic Last Reply

Recommended Posts

Hello,

 

Just wondering if anyone has the same board as I cannot get PCIe passthrough to work/show as option for anything? I have tried stubbing the GPU (Nvidia 1080 Ti) but it’s not even a option for passthrough but shows up in Unraid ‘System Devices’ (posted on Pastebin in link below).

 

I have tried simply passing the PCI USB 3.0 Controller:

 

- [1b73:1100]    0c:00.0 USB controller: Fresco Logic FL1100 USB 3.0 Host Controller (rev 10)

 

Which is in its own IOMMU Group but is not a option in VM creation at all, again, tried stubbing it at boot, editing the VM XML etc but still will not show up as an option to passthrough?

 

It’s the same for the NVMe drives etc. Nothing comes up as a option when editing or creating a VM?

In ‘System Profiler’ (I think it may be a plug-in?) it says that IOMMU is disabled, could that be the problem? If so, how do I enable it? I guess it’s a BIOS setting? I’m running version 2.70 by the way and the CPU is a Ryzen 3950x.

 

System devices:

 

https://pastebin.com/q4tch0Kd

 

Cheers

Edited by jazzy192
Typo
Link to post
7 hours ago, jazzy192 said:

 

It’s the same for the NVMe drives etc. Nothing comes up as a option when editing or creating a VM?

In ‘System Profiler’ (I think it may be a plug-in?) it says that IOMMU is disabled, could that be the problem? If so, how do I enable it? I guess it’s a BIOS setting? I’m running version 2.70 by the way and the CPU is a Ryzen 3950x

You require IOMMU to be enabled before anything can be passed through.     If your hardware supports it then you need to find the relevant BIOS setting to enable it.    I know it can often be hard to find being several layers down in the BIOS settings tree.

Link to post
8 hours ago, jazzy192 said:

Hello,

 

Just wondering if anyone has the same board as I cannot get PCIe passthrough to work/show as option for anything? I have tried stubbing the GPU (Nvidia 1080 Ti) but it’s not even a option for passthrough but shows up in Unraid ‘System Devices’ (posted on Pastebin in link below).

 

I have tried simply passing the PCI USB 3.0 Controller:

 

- [1b73:1100]    0c:00.0 USB controller: Fresco Logic FL1100 USB 3.0 Host Controller (rev 10)

 

Which is in its own IOMMU Group but is not a option in VM creation at all, again, tried stubbing it at boot, editing the VM XML etc but still will not show up as an option to passthrough?

 

It’s the same for the NVMe drives etc. Nothing comes up as a option when editing or creating a VM?

In ‘System Profiler’ (I think it may be a plug-in?) it says that IOMMU is disabled, could that be the problem? If so, how do I enable it? I guess it’s a BIOS setting? I’m running version 2.70 by the way and the CPU is a Ryzen 3950x.

 

System devices:

 

https://pastebin.com/q4tch0Kd

 

Cheers

For the X570 Taichi go to
Advanced>AMD CBS>NBIO Common Options
Make sure you have “IOMMU” set to “Enable” (Auto doesn’t work).
Also make sure “Enable AER Cap.” is set to “Enable”
Once you’ve set that an option called “ACS Enable” will show up, I left that set to “Auto”.

After that’s done you’ll have the normal X570 IOMMU groupings.

 

Source: https://forum.level1techs.com/t/x570-taichi-iommu-groups/145762/3?u=kiljacken

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.