[Support] selfhosters.net's Template Repository

Recommended Posts

2 hours ago, tzahi12345 said:

Are there really no logs? This is quite strange behavior, if the video shows up in the home screen, the subscriptions *must* exist. Maybe something is preventing them from being shown UI-wise.. do you see any errors in the browser console when you try to look at the subscription? Also, try clicking the dropdown for the subscription's videos and click Go to subscription to see if that works.

Sorry, I already readded all the subscriptions. I only have the default log level set, so I wasn't expecting much info there.


When I went to the subs page, it displayed the same message of no items for both playlists and subscriptions, I've never put in any playlists, but the message was displayed for both. When I readded the subs, they showed up properly, both on the left column and the subs list. One anomaly to note is that even though adding the sub closes the add sub popup, the new sub doesn't show in the list until the browser is refreshed.


At the moment I'm getting the 429 too many requests, so I've shut down the container until tomorrow, I'll post back. Prior to shutting down I added a cookie and a youtube API key and the 429's continued, but I don't know if that makes a difference once the 429 is already happening.



Link to comment

I really liked the fundamental idea behind Scrutiny, but I don't think it's really ready for primetime yet - the UI kept reporting duplicates for SAS devices (I'm guessing it doesn't understand dual port connections, scanning the scsi bus or something?), and that's only when I could actually get the web UI to do anything other than show the spectacles with the loading dots.


Could we perhaps get this marked as a beta or something? I really like the basic idea, it just needs some polish before I think it could be considered fully fledged.

Link to comment

I have the speedtest tracker docker running and it's working well with Organizr.  However, I'd like to utilize it for a Grafana Dashboard that requires speedtest-cli and the below added to telegraf.  I believe the reason it's not working is because the "/usr/bin/speedtest -f json-pretty" needs to be changed.  Any ideas on how to change this for unRAID? 



# Install speedtest cli from SpeedTest.net first

# https://www.speedtest.net/apps/cli


# And then run speedtest once to accept the license



commands = ["/usr/bin/speedtest -f json-pretty"]

name_override = "Speedtest"

timeout = "1m"

interval = "5m"

data_format = "json"

json_string_fields = [ "interface_externalIp",





"result_url" ]

Link to comment

@mmag05 you sure you have accepted the licence agreement from wherever you are calling the binary directly?


Have not had any experience with using telegraf, but have written some small scripts to send data to influxdb. Would it not be easier to write a script that checks the latest test run in the speedtest-tracker and inserts it into the db? That way you are not running any additional speedtests that won't be recorded by the docker container


You can get the latest result in cli by running:

php /config/www/artisan speedtest:latest


Link to comment

Hello unRAID forums.

Great pluings you have, I've just installed Speedtest Tracker.

It's working as intended, but I want, or rather, my ISP wants to use a specific server before they'll do any trouble shooting, if there's issues with the connection.

I found the list of servers here:

This is the one I need:

<server url="http://linespeed3.nms.tele.dk:8080/speedtest/upload.php" lat="56.0900" lon="10.1337" name="Tranbjerg" country="Denmark" cc="DK" sponsor="TDC Group" id="8763" host="linespeed3.nms.tele.dk:8080"/>

But I can't seem to figure out, what I need in order to use that server specifically.
Does anyone know what needs to be in the box for it to use that server?


Edited by Nanobug
Link to comment
37 minutes ago, henryw3 said:

Pop 8763 into the server box in the general settings section and it should work. You can then click on the arrow icon next to a tests in the all tests table to make sure it's using the right one

I didn't realize you had to put the ID number in.

It works now, thanks!

Link to comment

Haven't written any code for email notifications, so not atm. Closest you can get right now is a daily slack/discord/telegram notifications with a summary of the past 24 hours.


I'm going to be re-writing the notifications for it soon though, so add a feature request as a GitHub issue so I don't forget to add emails.

Link to comment
29 minutes ago, henryw3 said:

Haven't written any code for email notifications, so not atm. Closest you can get right now is a daily slack/discord/telegram notifications with a summary of the past 24 hours.


I'm going to be re-writing the notifications for it soon though, so add a feature request as a GitHub issue so I don't forget to add emails.

I tried setting that up, I just don't know why it doesn't work.

Do you have a place that explains how it works so I can figure out how it works, and how to fix it?

Link to comment
5 minutes ago, henryw3 said:

You will need to put "/slack" at the end of the webhook URL

So, if I have this webhook (I've typed in random numbers and letters as well)



I need to add /slack at the end, so it looks like this:


And I'm good to go?

Link to comment
2 minutes ago, henryw3 said:

Yeah pop that in the box, click save and it should work. There's a test button that will send a test notification through so you can check it's working okay

That worked like a charm!
I don't know if it will be a help. But I can write down some documentation for you, that you can use however you like. 
Just to help and, and ease up your work a bit.

The Slack/Discord Webhook, is that a general thing that you just add /slack at the end, and it will work?
I've tried to set up other Webhooks, but it doesn't work, and if it's a general thing, then that could be why.

Link to comment
42 minutes ago, henryw3 said:

Yeah that would be great mate, thanks. Yeah so different services format the data they send in a webhook differently, so you can put /{service_name} at the end of the URL for a bunch of services to get it to work.

I'll PM/DM you with what I have, and possibly some more questions on things so I can try to write it down.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.