YOURLS NGINX error


3 posts in this topic Last Reply

Recommended Posts

Hi Everyone

 

Im trying to setup the YOURLS app, I have gotten as far as getting the url.mydomain.com/admin page to load but none of my links work.


I think I have some issues with My NGINX config.
Im getting this error in the YOURLS log:
 

Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.php,index.html) found, and server-generated directory index forbidden by Options directive

Im using the letsencrypt docker that contains NGINX.

 

My NGINX config looks like the below.

 

server {

listen 443 ssl;
listen [::]:443 ssl;

server_name url.*;

include /config/nginx/ssl.conf;

client_max_body_size 0;

root /config/www/YOURLS;
index index.php index.html index.htm;

# enable for ldap auth, fill in ldap details in ldap.conf
#include /config/nginx/ldap.conf;

location / {
    # enable the next two lines for http auth
    #auth_basic "Restricted";
    #auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth
    #auth_request /auth;
    include /etc/nginx/fastcgi_params;
    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_unraid url;
    proxy_pass http://192.168.86.41:8088;
}

}

Im getting this issue when I try my shortened links. I get the Forbidden page.

Can anyone help please?

Edited by lordvaderxiii
Link to post
  • 5 months later...
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.