[Support] knex666 - Tor Relay Server


Recommended Posts

Application Name: Tor Relay Server

Overview: Support for Docker image of Tor Relay Server

Application: https://www.torproject.org/

Docker Hub: https://github.com/DarkIsDude/tor-server

GitHub: https://github.com/maschhoff/docker/tree/master/tor-relay


Please read all information in the Overview Box

Please use the sample configuration on the GitHub Repo

Be shure you have a working IPV4 it will not work without.

Please use Tor for good reasons!

For any question - dont mind to ask!

Edited by knex666
Link to comment

Due to a template mistake, the instructions referenced in the OP do not show up when installing the container (PR has been issued).  What you're missing is



This docker image will install the latest current stable version of Tor server. It will run Tor as an unprivileged regular user, as recommended by torproject.org.

It includes the latest Tor Debian package from torproject.org which is installed and configured according the Tor project recommendations. Additionally it can be run as a hidden bridge using obfs4proy as well as meek.

The Tor network relies on volunteers to donate bandwidth. The more people who run relays, the faster the Tor network will be. If you have at least 2 megabits/s for both upload and download, please help out Tor by configuring your server to be a Tor relay too.


Create a folder appdata/tor-data/config

Download sample Config: https://github.com/maschhoff/docker/tree/master/tor-relay

Edit the config at least NICKNAME and CONTACTINFO in the config file

Put this into the config folder.

Edit the docker parameters and run it.



  • Like 1
Link to comment
2 hours ago, Cbrooker said:

Thansk knex666. I grabbed the new container and configure it. It fails to start as the user "tord" doesn't exist.


Feb 07 11:10:13.285 [warn] Error setting configured user: tord not found

Do you know the correct user?

The user is "debian-tor". The included torrc needs to have the line "User tord" changed to "User debian-tor"

Link to comment
  • 1 month later...


I've tried to install the Tor Relay Docker but had a problem: 


When I start the container it crashes and the log says: "cat: /etc/tor/torrc: No such file or directory" 

I copied the torrc file in the "appdata/tor-data/config" folder and the path should be correct. 

Also the update statu so f the container can't be checked. 


What file-type should the torrc file have? 

Can someone help me? 

Thank you 


Link to comment
  • 2 weeks later...
  • 9 months later...
  • 2 weeks later...

Can not get the docker to work either.  Tried moving/renaming the file to tor standards and could not get it working.  There's also no documentation about this docker.  Probably just going to setup the relay myself until a better docker comes around or this is fixed.

Link to comment

The description on how to run it is not accurate anymore but it's pretty easy:

1 . Open a terminal and create the folder and sub-folder

mkdir mnt/user/appdata/tor-relay

mkdir mnt/user/appdata/tor-relay/config
2. Create the config file by opening it with nano

nano mnt/user/appdata/tor-relay/config/torrc

3. Copy-paste the configuration information from here https://github.com/DarkIsDude/tor-server#tor-configuration and change whatever you want there.

4. Save the file and start the docker



  • Thanks 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.