[support] Vaultwarden (formerly Bitwarden_rs)

Recommended Posts

9 hours ago, Supershocker said:

I recently tried to add another user to my server but the system is unable to send an email to the new user for account creation. The same account and SMTP settings for Gmail work on another service. Is anyone else having this issue?

Are your SMTP email settings corectly configured in Admin panel, did you test it (test SMTP on the bottom)?

Do you have send invitations enabled?

Link to comment
On 9/2/2021 at 9:26 PM, Twix said:


can anyone tell me, where SERVER_ADMIN_EMAIL is for?

I couldn't find it in the documentation. Does it differ from SMTP_FROM?

thank you!

I don't think it differs from SMTP_FROM. I think this is address from which emails are sent from, if configured correctly.

Link to comment

Having an issue with sync between my devices.  Sometimes logging out of my ios app and back in, seems to refresh, to my phone.  But I'm noticing that many items created on my ios app have not synced back to my vaultwarden database.  Sync says it's up to date on my phone.  How do I force an item to repopulate?


Link to comment
  • 2 weeks later...

Is this a general question or specific to vaulwarden and in the relation of using proxy manager. If the latter then it depends what proxy manager are you using. I can help you with Nginx Proxy Manager which is rather simple and straightforward.

Edited by yogy
Link to comment

My instance of vaultwarden is functioning properly from the user POV. I can log into the admin page, but none of the subject headers open up. I can't adjust any of my admin parameters. I can click on "general settings" (or any of the others) all day long, but it doesn't open the drop down. I can click along the top row to move to the different pages (Settings, Users, Orgs, Diags, Vault) and all of the other pages appear normal, it's JUST the settings page. I don't even know where to start with this oddity. Any advice?

Link to comment
On 10/2/2021 at 9:40 PM, damnshaneisthatu said:

@BMCave did you find a solution? I'm currently experience the same thing.

I cant say I found the solution for this but in the end I did get this working. I do think it had something to do with the network allocations.
I made a copy of all the files and deleted the files and folders in the app data.
I cleaned up docker networks making sure nothing was interfering.
I reinstalled the Docker for Bitwarden and made the network on host since I was using reverse proxy I also made sure that the proxy manager was also on the host network. It seemed to work and I managed to log in and saw that the account and data was still present thankfully. I then changed the network to a virtual bridge network.

Link to comment
  • 2 weeks later...

Has anyone got this working with webauthn on android?

I applied the update which appears to have added webauthn support and no matter if I connect my yubikey through usb or tap for nfc it doesn't take.

u2f works on my usual browser in windows if that matters. I should also mention webauthn doesn't work in the windows desktop client either(just says loading... indefinitely).


Apparently the cause of this is because windows registers your fTPM as a webauthn device and what's worse is a microsoft account with a fido2 key attached hides the fact that it's not the security key being directly attached to your vaultwarden or bitwarden account.

Edited by ikkuranus
Link to comment

Okay, so I was checking out my docker containers and saw there was an update for my bitwarden_rs container. Tried to update it and got the message that basically told me something was wrong/usually a repository change.

Here's where I am now stuck. The instructions to upgrade said to stop the container, edit the repository, fix common problems, etc. Except I can't edit the container to update the repo. My guess is I need to basically start fresh. How can I do that without losing all my passwords?


Link to comment
3 hours ago, yogy said:

OK, try to left click on the name of the container, not the icon. That should show you the template and try to change the repository there.

The name isn't clickable. Like if I go to the container above it, it will underline it showing it's a link and I can do that. Can't do that with the bitwarden one for some reason.

Link to comment
12 minutes ago, yogy said:

Hmm, can you access the log files. Post them here if you can.

I'm at work right now so unfortunately I won't be able to get to that till tonight. Do you want a screenshot of the left-click Show Logs or is there a particular log file you want me to upload? I can do either tonight.

Link to comment

No worries, upload logs (left clink on bitwardenrs icon>>logs>>copy and paste here), maybe something is there that could help us solve this. In worst case scenario, you'll make a backup of your passwords, delete current container and make a new one and then just import your passwords.

Link to comment
11 hours ago, yogy said:

No worries, upload logs (left clink on bitwardenrs icon>>logs>>copy and paste here), maybe something is there that could help us solve this. In worst case scenario, you'll make a backup of your passwords, delete current container and make a new one and then just import your passwords.

So unfortunately, I don't think there's much here to go on:


| Starting Vaultwarden |
| Version 1.22.2 |
| This is an *unofficial* Bitwarden implementation, DO NOT use the |
| official channels to report bugs/features, regardless of client. |
| Send usage/configuration questions or feature requests to: |
| https://vaultwarden.discourse.group/ |
| Report suspected bugs/issues in the software itself at: |
| https://github.com/dani-garcia/vaultwarden/issues/new |

[INFO] No .env file found.

[WARNING] The following environment variables are being overriden by the config file,
[WARNING] please use the admin panel to make changes to them:

[2021-10-28 22:13:43.893][parity_ws][INFO] Listening for new connections on
[2021-10-28 22:13:43.895][start][INFO] Rocket has launched from
[2021-10-28 22:13:50.440][parity_ws::io][INFO] Accepted a new tcp connection from


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.