[Support] kru-x - wordpress


Recommended Posts

Strange problem after wordpress import.

 

I have just finished importing 13 existing wordpress installations into Unraid, each in a separate docker and separate databases. everything works almost perfect.  excelpt TOTP.

All sites is secured with TOTP for login, and I can't login with my generated code. I renamed the plugin folder so that I could log in and after I logged in I changed the folder back and reset the TOTP code... Then I created a new code and set TOTP as enables and primary.

 

The problem is that the new code is is not saved and setting TOTP as enabled and primary is not saved either so when I log out and try to log in again I only need username/password.

 

Any ideas out here? Is there something special to consider when using "old" wordpress installations like this?

 

All wordpresses was at latest versions, the import process was like this:

1. Create database and wordpress docker in Unraid

2. dump DB at old server and import it to new DB in Unraid MariaDB

3. copy wp-content folder from old installation to docker installation

 

Like this:

Create wordpress docker in unraid
Create database and user
mysqldump -h oldserver -u root -p <db> > <db>.sql
mysql -h unraidserver -u root -p <db> < <db>.sql

scp -pr /var/www/<site>/wp-content/* unraidserver:/mnt/user/appdata/wordpress/<site>/wp-content/.

Edited by shalafi
Link to comment
37 minutes ago, shalafi said:

Strange problem after wordpress import.

 

I have just finished importing 13 existing wordpress installations into Unraid, each in a separate docker and separate databases. everything works almost perfect.  excelpt TOTP.

All sites is secured with TOTP for login, and I can't login with my generated code. I renamed the plugin folder so that I could log in and after I logged in I changed the folder back and reset the TOTP code... Then I created a new code and set TOTP as enables and primary.

 

The problem is that the new code is is not saved and setting TOTP as enabled and primary is not saved either so when I log out and try to log in again I only need username/password.

 

Any ideas out here? Is there something special to consider when using "old" wordpress installations like this?

 

All wordpresses was at latest versions, the import process was like this:

1. Create database and wordpress docker in Unraid

2. dump DB at old server and import it to new DB in Unraid MariaDB

3. copy wp-content folder from old installation to docker installation

 

Like this:

Create wordpress docker in unraid
Create database and user
mysqldump -h oldserver -u root -p <db> > <db>.sql
mysql -h unraidserver -u root -p <db> < <db>.sql

scp -pr /var/www/<site>/wp-content/* unraidserver:/mnt/user/appdata/wordpress/<site>/wp-content/.

Have u tried to use a migration tool, such as wp-migration? Seems to be a permission problem. 

Kru-x

Link to comment

I tried setting this in wp-config.php and wp-config-docker.php:
define( 'WP_DEBUG', !!getenv_docker('WORDPRESS_DEBUG', 'true') );
define( 'WP_DEBUG_LOG', '/var/www/html/wp-errors.log' );

 

But no debug log is created in the dockers /var/www/html folder

 

Did some more testing, I can change and save other information in the user profile but the TOTP will not save..

Plugin folder (and files) has correct user/group
image.png.bdd8d2223fb34195173982a1e887bb97.png

 

 

Link to comment
14 minutes ago, shalafi said:

I tried setting this in wp-config.php and wp-config-docker.php:
define( 'WP_DEBUG', !!getenv_docker('WORDPRESS_DEBUG', 'true') );
define( 'WP_DEBUG_LOG', '/var/www/html/wp-errors.log' );

 

But no debug log is created in the dockers /var/www/html folder

 

Did some more testing, I can change and save other information in the user profile but the TOTP will not save..

Plugin folder (and files) has correct user/group
image.png.bdd8d2223fb34195173982a1e887bb97.png

 

 

The log would be in the container itself, sorry not sure but still think it is a permission error. Try the migration tool, usually solves any problems, especially DB troubles. 

Kru-x 

Link to comment

It was in the container I looked for the missing log.

Anyway, tried the export/import and that didn't change anything. Since the only thing that didn't work after the migration was this plugin I removed it from my 13 sites for the time being 🙂

 

Trying to understand the permission issue.... The database has full permissions, the files/folders has either www-data or root... I'll do some more thinking....

 

Edited by shalafi
Link to comment
On 2/21/2022 at 9:48 AM, Kru-x said:

The log would be in the container itself, sorry not sure but still think it is a permission error. Try the migration tool, usually solves any problems, especially DB troubles. 

Kru-x 

 

I found the error 😃

 

Time difference on my unraid server, had to disable NTP and set time manually. Now everything words!

  • Thanks 1
Link to comment

Running a fresh install of wordpress and went through setup process. 

Settings>General - Site Address (URL) and WordPress Address (URL) changed to http://myhostname.com

Everything working as expected up to this point

Settings>Permalinks - Changed to Post Name

At this point no pages other then the homepage work producing a 404 error

If I try to create a new page I get 

Publishing failed. The response is not a valid JSON response

What am I doing wrong?

Link to comment
8 minutes ago, shiftylilbastrd said:

Running a fresh install of wordpress and went through setup process. 

Settings>General - Site Address (URL) and WordPress Address (URL) changed to http://myhostname.com

Everything working as expected up to this point

Settings>Permalinks - Changed to Post Name

At this point no pages other then the homepage work producing a 404 error

If I try to create a new page I get 

Publishing failed. The response is not a valid JSON response

What am I doing wrong?

Did you start to install WP on your local address? Start your install after making sure you can connect to the installer through your Domain, then you shouldn't need to do the steps above.

 

Kru-x

Link to comment
On 2/25/2022 at 9:01 PM, Kru-x said:

Did you start to install WP on your local address? Start your install after making sure you can connect to the installer through your Domain, then you shouldn't need to do the steps above.

 

Okay. Wiped out and started fresh and didn't need to adjust the URLs. I'm still unable to change the permalink setting. I can physically get to the setting and change it to post name but after that nothing works. When I try to create a new page I get the same error as before 

Publishing failed. The response is not a valid JSON response

 

Link to comment
3 hours ago, shiftylilbastrd said:

Okay. Wiped out and started fresh and didn't need to adjust the URLs. I'm still unable to change the permalink setting. I can physically get to the setting and change it to post name but after that nothing works. When I try to create a new page I get the same error as before 

Publishing failed. The response is not a valid JSON response

 

Clear the browser cache? Try your site in a private window in your browser.

Link to comment
  • 5 weeks later...
4 hours ago, DaButterGamer said:

Hi All,

 

Just did a oopsie and changed the url with in the admin panel of wordpress to another port number and saved it. Can no longer access the admin panel through the webui. What file do i need to edit to change it back

 

Many thanks,

Hi,

 

There is some things to try,

  • Change it back in wp-config.php
  • Clear your cache

There is heaps of info on it doing a Google search, here is one https://wp-me.com/cant-access-wordpress-after-changing-site-url/ 

 

Hope it helps,

 

Kru-x

Link to comment
  • 2 weeks later...

Hello, Im trying to use this for a private web server for my own uses within my LAN network. No outside www. needed. will be accessed by IP and Port when needed.

I installed MariaDB, and went through the steps in the french walkthrough posted earlier.

I also have a Unifi docker running (relevance next)

After installing the wordpress docker, the webGUI takes me to the Unifi webGUI, easy enough, Unifi uses port 8080, change the port for wordpress.......

I changed the Wordpress port to 8085, and when i manually navigate a web broswer to ip:8085, it cannot connect. I tried a few different ports from 8081-8090.

Any tips?

My setup is here:

Wordpress.png

Link to comment
5 hours ago, TurboStreetCar said:

Hello, Im trying to use this for a private web server for my own uses within my LAN network. No outside www. needed. will be accessed by IP and Port when needed.

I installed MariaDB, and went through the steps in the french walkthrough posted earlier.

I also have a Unifi docker running (relevance next)

After installing the wordpress docker, the webGUI takes me to the Unifi webGUI, easy enough, Unifi uses port 8080, change the port for wordpress.......

I changed the Wordpress port to 8085, and when i manually navigate a web broswer to ip:8085, it cannot connect. I tried a few different ports from 8081-8090.

Any tips?

My setup is here:

Wordpress.png

Reinstall from the beginning on the new port and/or change the site adress to ip:port-number 

 

Kru-x 

Link to comment

I accidentally messed up my installation by, presumably, using the `New Permissions` tool of unRAID. I ran this over appdata to fix an issue I had with a different container, only realizing now, weeks later, when trying to install plugins or upload files to my Wordpress site that it does seem to have permission issues. It keeps asking for connection information to the storage via FTP.

 

Is there an easy fix, eg. using `chown` on the folder?

Link to comment
On 4/14/2022 at 5:54 PM, DesertCookie said:

I accidentally messed up my installation by, presumably, using the `New Permissions` tool of unRAID. I ran this over appdata to fix an issue I had with a different container, only realizing now, weeks later, when trying to install plugins or upload files to my Wordpress site that it does seem to have permission issues. It keeps asking for connection information to the storage via FTP.

 

Is there an easy fix, eg. using `chown` on the folder?

Sorry for the late reply, but I think you are on the right track. The container needs to have write and read privileges, so chmod should do it.

 

Kru-x

Link to comment
On 4/19/2022 at 5:35 PM, DesertCookie said:

What chmod would I have to do? What are the default owner permissions for this/a container?

 

Thanks, again.

Sorry,

 

I am the worst person to ask about premission's, still after all these years I am still just 777 everything!

 

Kru-x

Link to comment
On 4/12/2022 at 5:28 PM, Kru-x said:

Reinstall from the beginning on the new port and/or change the site adress to ip:port-number 

 

Kru-x 

Hello, tried reinstalling, Still no luck. 

Trying to install and use on vlan network. Installation completes but all i get is "refused to connect". 

I CAN ping the address however. 

Is there anything special about the network that needs to be set up to use on a vlan? How would i change the site address to IP:Port-number? Do you mean in the network field? OR in the configuration somehow?

 

Edited by TurboStreetCar
Link to comment
  • 2 weeks later...

Hello!

 

I wonder how to migrate and host 13 personal wordpress sites to my Unraid server.

 

1 option is to use dockers. For each wordpress site I will need redis, nginx fastcgi and phpfsp. Is there some kind of stack which includes all these or should I create a different container for each?

 

Another option is to create a ubuntu VM and configure the web server there, including a panel where I can manage all the projects.

 

Which option would be better?

Link to comment
17 minutes ago, Rocka374 said:

Hello!

 

I wonder how to migrate and host 13 personal wordpress sites to my Unraid server.

 

1 option is to use dockers. For each wordpress site I will need redis, nginx fastcgi and phpfsp. Is there some kind of stack which includes all these or should I create a different container for each?

 

Another option is to create a ubuntu VM and configure the web server there, including a panel where I can manage all the projects.

 

Which option would be better?

Whoooa,

 

That's a request and a half ;-) and I am not sure about the answer. I doubt that you would have a stack for that. I know Redis can be used as a separate docker container in Unraid.

 

I am using Nginx Proxymanager, but you would have to have a container with Nginx and fastCGI + PHP-FMP as I understand it. There is a way as I understand it, read quickly about it https://blog.joshwalsh.me/docker-nginx-php-fpm/ if you could use that container and make your own template for it in Unraid it could be possible I guess.

 

You would be running each site in a separate container + DB and possible Redis in one and the Nginx as per above in one. but this is way over my head.

 

Hope it gives you a few ideas but sorry I couldn't help more,

Kru-x

Link to comment
7 minutes ago, Kru-x said:

Whoooa,

 

That's a request and a half ;-) and I am not sure about the answer. I doubt that you would have a stack for that. I know Redis can be used as a separate docker container in Unraid.

 

I am using Nginx Proxymanager, but you would have to have a container with Nginx and fastCGI + PHP-FMP as I understand it. There is a way as I understand it, read quickly about it https://blog.joshwalsh.me/docker-nginx-php-fpm/ if you could use that container and make your own template for it in Unraid it could be possible I guess.

 

You would be running each site in a separate container + DB and possible Redis in one and the Nginx as per above in one. but this is way over my head.

 

Hope it gives you a few ideas but sorry I couldn't help more,

Kru-x

 

Thanks for the quick answer, I will look into this.

 

In case I can't manage the container with my own template and I decide to make a VM, that VM should have 80 and 443 ports forwarded too. Also, the VM will be with different internal IP. Will my router be able to have 80 and 443 forwarded on both my IPs?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.