[Support] knex666 - Nextcloud 21


knex666

Recommended Posts

I have add swag as trusted proxy but i get the error

"The reverse proxy header configuration is incorrect or you are accessing Nextcloud through a trusted proxy. If this is not the case, then there is a security problem that allows an attacker to spy out the IP address visible to Nextcloud. More information can be found in the documentation."

Link to comment
  • 2 weeks later...

Hey guys, my docker instance is online and bound to a port. its worked for a month and since last week i havent been able connect to it at all.
i even tried spinning up fresh instances in new folders, and cant connect to that either.
Any ideas? fyi i can access other hosted containers fine.
only found this in the logs

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.3. Set the 'ServerName' directive globally to suppress this message
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.3. Set the 'ServerName' directive globally to suppress this message
[Wed Nov 11 15:59:47.193870 2020] [mpm_prefork:notice] [pid 1] AH00163: Apache/2.4.38 (Debian) PHP/7.4.12 configured -- resuming normal operations
[Wed Nov 11 15:59:47.193891 2020] [core:notice] [pid 1] AH00094: Command line: 'apache2 -D FOREGROUND'

image.thumb.png.c04f1859f12ab05cbc456f29f941c18d.png

Edited by acoop133
Link to comment
  • 2 weeks later...
On 9/21/2020 at 4:24 AM, rob_robot said:

I have been experimenting with different sql databases in nextcloud after installing it based on the instructions in the first post. 

My recommendation would be to go with Postgres11 instead of MongoDB in general. The main difference is CPU utilisation of the NAS and achievable upload speed. With MongoDB my i3 processor was at 100% utilisation when uploading larger amounts of files. In general the upload was pretty slow and also the web performance of Nextcloud was not great. With MongoDB, on local ethernet with 1 Gbit/s I got a poor 5-15 MB/s of upload speed. With postgres11, I get around 40-100 MB/s, which is pretty good considering the available 1 Gbit/s. CPU usage went down to 50-70%, so looks like postgres is way more performant than MongoDB.

 

Here the instructions how to set up Postgres11 in unraid:

 

1.) install postgres11 from CA. In the template you need to create a postgres user and password. My user was simply "postgres"


2.) console into the postgres11 docker and run (it will ask you for the password you created):


su - postgres
createuser --interactive --pwprompt

 

3.) type "nextcloud" to create the user nextcloud and chooser again a password for the user account. 

Type no for following questions:
super user: No
db create: No
role create: No

 

4.) Type in the following commands to create a new database for nextcloud:


createdb nextcloud
psql

GRANT permissions ON DATABASE nextcloud TO nextcloud  

In the above command the first "nextcloud" is the database name whereas the 2nd "nextcloud" is the name of the user. 

 

5.) Set-up a clean Nextcloud docker container and select postgres for the database. 

Enter username, database name and password (the one for the nextcloud user) that we previously created. You need to replace localhost by the IP address and port name of the postgres11 docker container (the IP on the right side shown in port mappings next to the postgres docker container inside the unraid docker tab. 

 

In general the instructions are quite similar as for MongoDB, so whoever has done the MongoDB set-up will feel that this is very familiar. 

 

 

Hi, the idea was good, thanks for your input. However, when I configure nextcloud I get a message telling me that there is an internal server error:
"the server can not complete your request."

Then asks me to contact my "server administrator" ( me ).

Is the same if I restart both nextcloud and postgre11 dockers.

Thx!

 

Link to comment
  • 2 weeks later...

Update:

 

Fixed everything by just installing new and made a clean reconfiguration. The integrated Code Server of collabora doesnt just works as intended, so I installed the dedicated docker in UnRaid like spaceinvader showed in his videos. Dont forget to add the subdomain in the letsencrypt settings, this is the step spaceinvader forgot to show.

 

Friendly reminder to myself: learn the occ commands and upgrade via cli. 😉

 

Hey guys!

 

Little question: Im using the Password App in NC20 and it tells me that it need some higher php version above 7.4. How do I check for the php version and upgrade?

 

And additionally, there is some odd behaviour with my Collabora installation. I cannot install the integrated Server. When I type 

 

sudo -u abc php -d memory_limit=512M occ app:install richdocumentscode

nothings gonna happen. The installation in the apps section isnt working either...

 

 

Thanks in advance friends!

Edited by hundsboog
Link to comment
On 11/25/2020 at 5:48 AM, rojarrolla said:

Hi, the idea was good, thanks for your input. However, when I configure nextcloud I get a message telling me that there is an internal server error:
"the server can not complete your request."

Then asks me to contact my "server administrator" ( me ).

Is the same if I restart both nextcloud and postgre11 dockers.

Thx!

 

did you ever fix this issue? Im having it currently

 

EDIT: Nvm fixed it. If anyone sees this in the future. Make sure you clear out every folder in your Nextcloud share you probably already made

Edited by Abhi
  • Like 1
Link to comment

I was running the linuxserver docker before successfully, but decided to give the official docker a try. I installed it and connected it to a mariadb docker and everything went fine. After setup was complete and i logged into the GUI it was horrendously slow. Is there anything I need to do out of the box to get the GUI to be faster? For example, if i click the file's menu or like settings it can take up to like 2 min to load. With the linuxserver docker everything was fast. Any ideas? Even logging into it can take 1-2 min.

 

Edited by mikel632
Link to comment
On 12/9/2020 at 8:43 PM, Abhi said:

did you ever fix this issue? Im having it currently

 

EDIT: Nvm fixed it. If anyone sees this in the future. Make sure you clear out every folder in your Nextcloud share you probably already made

Well, I hadn´t but I read your post and it made lot a sense to me so I did as you said, because I was not deleting the Nextcloud folder. Now it works.

 

Thanks a lot!

Edited by rojarrolla
Link to comment
  • 4 weeks later...

Hi everybody, 

 

I use a reverse proxy (SWAG), and nextcloud doesnt work, it will refused the connexion  automatically of the reverse proxy. So I can't access to the web page of Nextcloud because i have a "502 Bad Gateway" error. Anybody know how to fix it ?

 

Thanks

Link to comment
Hi everybody, 
 
I use a reverse proxy (SWAG), and nextcloud doesnt work, it will refused the connexion  automatically of the reverse proxy. So I can't access to the web page of Nextcloud because i have a "502 Bad Gateway" error. Anybody know how to fix it ?
 
Thanks
Hi,

setting up nginx behind a reverse is not that easy which guide did you follow?

502 is somehow maybe a general Problem.

Have you got Connection from the swag Server to the nc docker? Thats the First thing to Check.

Cheers

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk

Link to comment
41 minutes ago, knex666 said:

Hi,

setting up nginx behind a reverse is not that easy which guide did you follow?

502 is somehow maybe a general Problem.

Have you got Connection from the swag Server to the nc docker? Thats the First thing to Check.

Cheers

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk
 

Hi, 

 

thank you for your quick answer

I follow the official guide of the nc Docker Hub Page. but i have this error in the error log of nginx (SWAG)

 

2021/01/06 22:09:41 [error] 461#461: *4 connect() failed (111: Connection refused) while connecting to upstream, client: x.x.x.x, server: cloud.*, request: "GET / HTTP/2.0", upstream: "https://x.x.x.x444/", host: "cloud.xxxxxxxxxxx.com"
2021/01/06 22:09:41 [error] 461#461: *4 connect() failed (111: Connection refused) while connecting to upstream, client: x.x.x.x, server: cloud.*, request: "GET /favicon.ico HTTP/2.0", upstream: "https://x.x.x.x:444/favicon.ico", host: "cloud.xxxxxxxx.com", referrer: "https://cloud.xxxxxxxxx.com/"

 

What do you mean by Connection ? I have network which my swag and nc are conected

 

Thank you :)

 

 

Link to comment
Hi, 

 

thank you for your quick answer

I follow the official guide of the nc Docker Hub Page. but i have this error in the error log of nginx (SWAG) : 

 

2021/01/06 22:09:41 [error] 461#461: *4 connect() failed (111: Connection refused) while connecting to upstream, client: x.x.x.x, server: cloud.*, request: "GET / HTTP/2.0", upstream: "https://x.x.x.x444/", host: "cloud.xxxxxxxxxxx.com"

2021/01/06 22:09:41 [error] 461#461: *4 connect() failed (111: Connection refused) while connecting to upstream, client: x.x.x.x, server: cloud.*, request: "GET /favicon.ico HTTP/2.0", upstream: "https://x.x.x.x:444/favicon.ico", host: "cloud.xxxxxxxx.com", referrer: "https://cloud.xxxxxxxxx.com/"

 

What do you mean by Connection ? I have network which my swag and nc are conected

 

Thank you

 

 

If you have both running in a docker doesnt mean that they can find each other just ping that host or better use curl to get a response.

 

Refused can although mean that its not a trusted ip set this up in nc.

 

I although dont understand why you reverse to a public adresss cloud.xxxx.com so everyone can connect direct too? Makes no sense ;)

 

Cheers

 

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk

 

 

 

Link to comment

 

On 3/26/2020 at 6:50 AM, robertoal said:

THank you for this quick reply!

 

With me the onlyoffice didn't work out of the box? 

Which addres should I use in the nextcloud: onlyoffice settings then?

 

Finally: Where can I change the php settings? Memory is limited now to 512...

 

Very much appreciated all the work you put into this!!!

 

edit: I think i found it by: php --ini in the console:

/usr/local/etc/php/conf.d/memory-limit.ini

 

Changed it there and seems to work so far!

 

On 3/26/2020 at 12:23 PM, knex666 said:

Hi

 

Are you shure you are running this Image and not lsio linuxserver Image. Since if you choose to install Apps at the Start it works fine (See Page 1)

 

Please try to Mount the php ini Since your change get lost Else 

 

Cheers

 

I'm having a hard time to find the memory-limit.ini. What am I doing wrong? This is the path I'm looking for:

 

/usr/local/etc/php/conf.d/memory-limit.ini

 

I'm having the "Allowed memory size of xxx bytes exhausted" message pop up when using ONLYOFFICE and I'll change the memory limit to see if that works..

 

Here is what I get when I try php --ini in the console:

 

# php --ini
Configuration File (php.ini) Path: /usr/local/etc/php
Loaded Configuration File:         (none)
Scan for additional .ini files in: /usr/local/etc/php/conf.d
Additional .ini files parsed:      /usr/local/etc/php/conf.d/docker-php-ext-apcu.ini,
/usr/local/etc/php/conf.d/docker-php-ext-bcmath.ini,
/usr/local/etc/php/conf.d/docker-php-ext-exif.ini,
/usr/local/etc/php/conf.d/docker-php-ext-gd.ini,
/usr/local/etc/php/conf.d/docker-php-ext-gmp.ini,
/usr/local/etc/php/conf.d/docker-php-ext-imagick.ini,
/usr/local/etc/php/conf.d/docker-php-ext-intl.ini,
/usr/local/etc/php/conf.d/docker-php-ext-ldap.ini,
/usr/local/etc/php/conf.d/docker-php-ext-memcached.ini,
/usr/local/etc/php/conf.d/docker-php-ext-opcache.ini,
/usr/local/etc/php/conf.d/docker-php-ext-pcntl.ini,
/usr/local/etc/php/conf.d/docker-php-ext-pdo_mysql.ini,
/usr/local/etc/php/conf.d/docker-php-ext-pdo_pgsql.ini,
/usr/local/etc/php/conf.d/docker-php-ext-redis.ini,
/usr/local/etc/php/conf.d/docker-php-ext-sodium.ini,
/usr/local/etc/php/conf.d/docker-php-ext-zip.ini,
/usr/local/etc/php/conf.d/memory-limit.ini,
/usr/local/etc/php/conf.d/opcache-recommended.ini

 

And here is what I have mounted:

 

hPrtyfc.jpeg

 

Thanks!!

 

Link to comment
  • 3 weeks later...

Don't know if it was already mentioned. This is how to re-index the file folders if files were added through SMB etc:

docker exec --user www-data Nextcloud php occ files:scan --all

 

Replace "Nextcloud" against your Container name if it was changed.

 

You could add a script which executes it on file changes similar to this:

https://askubuntu.com/a/339241/227119

 

But add a pause so its not executed every millisecond ;)

Link to comment
14 minutes ago, mgutt said:

Don't know if it was already mentioned. This is how to re-index the file folders if files were added through SMB etc:


docker exec --user www-data Nextcloud php occ files:scan --all

 

Replace "Nextcloud" against your Container name if it was changed.

 

You could add a script which executes it on file changes similar to this:

https://askubuntu.com/a/339241/227119

 

But add a pause so its not executed every millisecond ;)

 

AFAIK, adding...

'filesystem_check_changes' => 1,

...to config.php automatically scans the filesystem when a listing is needed. I wish more settings in Nextcloud were in the interface.

Link to comment
16 minutes ago, Cessquill said:

automatically scans the filesystem when a listing is needed

Nice to know. Docs:

https://docs.nextcloud.com/server/stable/admin_manual/configuration_server/config_sample_php_parameters.html#:~:text=filesystem_check_changes

 

Not sure how huge the impact is, but it can be lowered as follows which scans only in 10% of all page loads:

'filesystem_check_changes' => intval(str_shuffle('0000000001')[0]),

 

 

Link to comment

Hi @knex666
Thank you so much for this docker app!

Did something change recently with the template?

 

I installed the docker for the first time and follow all the steps outlined. I need ONLYOFFICE and checked "Install recommended Apps" but it installs Collabra and not ONLYOFFICE. Did I do something wrong?

2021-02-04 15_09_12-Settings.png

Link to comment
1 hour ago, CyberDuckie said:

Hi @knex666
Thank you so much for this docker app!

Did something change recently with the template?

 

I installed the docker for the first time and follow all the steps outlined. I need ONLYOFFICE and checked "Install recommended Apps" but it installs Collabra and not ONLYOFFICE. Did I do something wrong?

 

 

Hi, there have been some updates since the first release of this template.

The Nextcloud Team will not longer support ONLYOFFICE and switched the service. That works well too.

 

Cheers

 

PS: If you like my stuff dont mind to buy me a pizza ;-)

 

Link to comment
15 minutes ago, knex666 said:

 

Hi, there have been some updates since the first release of this template.

The Nextcloud Team will not longer support ONLYOFFICE and switched the service. That works well too.

 

Cheers

 

PS: If you like my stuff dont mind to buy me a pizza ;-)

 

Thank you for the prompt reply! Looks like it's time to re-isntall from scratch and try the ONLYOFFICE docker and link them. Thanks again

Link to comment
Thank you for the prompt reply! Looks like it's time to re-isntall from scratch and try the ONLYOFFICE docker and link them. Thanks again
Dont you like collabora? Then give that a try. I have never tested that. I dont think that its supported

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk


Link to comment
31 minutes ago, knex666 said:

Dont you like collabora? Then give that a try. I have never tested that. I dont think that its supported

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk

 

Collabra is expensive when you need to license it. ONLYOFFICE is $149 for 10 users ONE TIME PAYMENT.

Where Collabra wants to charge monthly per user. Not worth it IMO. Nextcloud supports it! I will figure it out others have done it.

  • Like 1
Link to comment
  • 1 month later...

Hi everyone

 

First of all, thank you to @knex666 for that Docker Template, for me it works really good.

 

But I have two things that I would like to comment/ask. When i open the Overview Page in the Settings i get this:

 

Quote

There are some warnings regarding your setup.

  • Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.
  • Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.
  • Module php-imagick in this instance has no SVG support. For better compatibility it is recommended to install it.

 

For the caldav and carddav i could fix it by editing the .htaccess file in the Nextcloud folder.

 

RewriteRule ^\.well-known/carddav https://sub.domain.tld/remote.php/dav/ [R=301,L]
RewriteRule ^\.well-known/caldav https://sub.domain.tld/remote.php/dav/ [R=301,L]

 

If I understand correctly, this will only remain until the next update is installed or? Is there another way to fix that permanently?

 

For the php-imagick i didn't find a fix by now, any tips for that?

 

Many thanks

Marzel

Link to comment
1 minute ago, Marzel said:

If I understand correctly, this will only remain until the next update is installed or? Is there another way to fix that permanently?

 

Yes, by adding the rule to your proxy.

Link to comment
  • knex666 changed the title to [Support] knex666 - Nextcloud 21

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.