[Support] knex666 - OpenProject


knex666

28 posts in this topic Last Reply

Recommended Posts

Hi Knex.

The Network type what should this be set to? I seem not to be able to access the webui.

Sorry, I am still getting used to unraid and dockers in general.

D.

 

Well did it host, but just saw DockerPolice comment and went over the others and they bridge so is that better?

Edited by CJandDarren
fixed one error
Link to post

As for every docker you can use host or bridge with Port mapping (Please add the portmapping to Port 8080 to your template) or a very easy way is using br0 with an IP of your subnet

Please have a look at the logs it takes a long time at the First Start.

Cheers

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk

Link to post
  • 4 weeks later...
21 minutes ago, theshabobo said:

Has anyone set this up with letsencrypt yet? I am going to be attempting this soon and wanted to know if anyone had the .conf file already made and available to share.

That should be no problem at all. Best way is to use a subdomain/domain for this.

 

This is a sample config that should work

 

server {
    listen 80;
    listen [::]:80;
	listen 443 ssl default_server;
	listen [::]:443 ssl default_server;
	
	root /config/www;
	index index.html index.htm index.php;

	server_name openproject.yourdomain.com;
	
	ssl_certificate /config/keys/letsencrypt/fullchain.pem;
	ssl_certificate_key /config/keys/letsencrypt/privkey.pem;
	ssl_dhparam /config/nginx/dhparams.pem;
	ssl_ciphers ###################
	ssl_prefer_server_ciphers on;

	client_max_body_size 0;
	
	 location / {
        proxy_pass https://[####OpenProjekt IP####]/;
        proxy_buffering off;
		proxy_http_version 1.1;
		proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
		proxy_set_header Upgrade $http_upgrade;
		proxy_set_header Connection $http_connection;
		access_log off;
	}
}

 

 

Link to post
  • 1 month later...
8 hours ago, Heciruam said:

Thank you for this template.

I just have one problem... I have no idea what the default admin account and password is or how to create that.
 

login: admin, password: admin

Link to post
On 5/1/2020 at 8:22 AM, knex666 said:

login: admin, password: admin

Thank you that was it.

However I now have tried to install it on a remote second machine that I connect to via VPN.

 

On the first machine where I succeded I was accessing it via a VM on the same machine. It was only reachable though that until I changed the Host name in the Openproject settings page from localhost to the ipadress:port. So my guess it is only reachable from localhost.

Since I can't do that on my second remote machine (inless I install a VM) I was wondering if I can change that setting somewhere else? I couldn't find a config file on the appdata that let me do that.

Thanks in advance.
 

Link to post
2 hours ago, Heciruam said:

Thank you that was it.

However I now have tried to install it on a remote second machine that I connect to via VPN.

 

On the first machine where I succeded I was accessing it via a VM on the same machine. It was only reachable though that until I changed the Host name in the Openproject settings page from localhost to the ipadress:port. So my guess it is only reachable from localhost.

Since I can't do that on my second remote machine (inless I install a VM) I was wondering if I can change that setting somewhere else? I couldn't find a config file on the appdata that let me do that.

Thanks in advance.
 

Are you talking about unraid? This should be a docker network think.

Link to post
  • 3 weeks later...

Thank you so much for setting this up, I have been using it and I am happy with the results. So I am sorry to ask if this is super easy, but I am a total noob. How do we set this docker up to be able to reach it from outside our internal network? With port forwarding, are there easy instructions posted somewhere?

Thanks for your time,

Link to post
Thank you so much for setting this up, I have been using it and I am happy with the results. So I am sorry to ask if this is super easy, but I am a total noob. How do we set this docker up to be able to reach it from outside our internal network? With port forwarding, are there easy instructions posted somewhere?

Thanks for your time,

You re welcome, thanks for the flowers.

You can buy me a Pizza if you like to donate wink.gif&key=d3c6549607c72aed6def273c71cc80b3186cd205c48720b7aab10366b7e3549f

 

So if you ask me I would redommend using a reverse proxy and port forward that ports. For security reasons.

 

Just an example how to do that, we can set this up together on discord if you want but there are videos and tutorials out. A hell lot.

 

Use let's encrypt from the community apps and get it working. Edit the config to that it will reverse proxy to your openproject docker as already mentioned in this thread

 

Port forward 80 and 443 to the evil internet and maybe setup a dyndns or subdomain to your ip.

 

Second and more secure is to use a vpn. So you setup a vpn Service like wireguard or openvpn port forward those ports and connect to vpn.

 

Cheers

 

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk

 

 

 

Link to post
On 5/21/2020 at 4:28 PM, knex666 said:

You re welcome, thanks for the flowers.

You can buy me a Pizza if you like to donate wink.gif&key=d3c6549607c72aed6def273c71cc80b3186cd205c48720b7aab10366b7e3549f

 

So if you ask me I would redommend using a reverse proxy and port forward that ports. For security reasons.

 

Just an example how to do that, we can set this up together on discord if you want but there are videos and tutorials out. A hell lot.

 

Use let's encrypt from the community apps and get it working. Edit the config to that it will reverse proxy to your openproject docker as already mentioned in this thread

 

Port forward 80 and 443 to the evil internet and maybe setup a dyndns or subdomain to your ip.

 

Second and more secure is to use a vpn. So you setup a vpn Service like wireguard or openvpn port forward those ports and connect to vpn.

 

Cheers

 

Gesendet von meinem Redmi Note 8 Pro mit Tapatalk

 

 

 

Thanks for responding and the suggestions, you said a lot of BIG Words in that!! 😂😂 I think you got me headed in the right direction and I have some more research to do. I love learning about this stuff and again thanks for the help. I sent you some Pizza funds, so I hope it's hot and fresh! - Cheers!

Link to post
  • 4 weeks later...

Has anyone set this up with letsencrypt? I try to put it into my proxynet and the IP addresses it gets assigned (on br0)  disappears and it becomes inaccessible.

 

Leaving it on br0 gives it an IP address separate than my server. Am I doing something wrong since it won't work on the proxynet?

Edited by dallus
Link to post
On 6/16/2020 at 3:49 AM, dallus said:

Has anyone set this up with letsencrypt? I try to put it into my proxynet and the IP addresses it gets assigned (on br0)  disappears and it becomes inaccessible.

 

Leaving it on br0 gives it an IP address separate than my server. Am I doing something wrong since it won't work on the proxynet?

have you try to use bridge mode for proxynet?
I got it runnig with br0 and letsenc but without proxynet

 

Cheers

Link to post
  • 2 months later...

I'm trying to get OpenProject to work on UNRAID via a reverse proxy but am currently at a stopping point. I tried creating my own .conf file based upon the above template. I can't seem to get it to work. Does anyone have a .conf file to share or can provide some guidance on what should be included in the file?

Link to post
  • 3 weeks later...

Dear anyone that can help? 

 

I was having permission issues on one of our unraid servers, so I ran New Permissions under tools. Now, my docker "OpenProject" won't start up, stating the error: 

 

Starting PostgreSQL 9.6 database server: mainError: The cluster is owned by user id 99 which does not exist ... failed!

 

Although I own the company, my employees are going to hang me and stone me if I don't have this up and running by tomorrow. I really did try to google this issue, even deleted, reinstalled (backing up before hand). However, I can't seem to figure out what to do to get this container up and running. 

 

Furthermore, I am considering making a new server and taking this data and dedicating it to a new machine altogether. So, backing up, creating a dedicated server is something I think is warranted. But for now, I need this back up before I am stoned above a flaming pile of steaming ****. 

 

Can anyone help? I need to have it up before our staff meeting tomorrow! 

Link to post
2 hours ago, CaddisArt, Inc. said:

New Permissions

should only be used on specific user shares, mostly because appdata has the permissions required by each container. There is a Docker Safe New Permissions which will do everything except appdata. 

 

I don't use this application. Presumably you could delete its appdata and really start from scratch but maybe not what you want. 

 

Maybe someone else will have an idea. 

Link to post

Oh damn! trurl is right that feature is only for user shares. 

 

try to exec this inside your Postgre container:

Maybe the user/group is postgres:postgres - I dont know your Postgres Server

 

chown -R root:root /var/lib/postgresql 

chown -R root:root /etc/postgresql 

chown -R root:root /var/log/postgresql 

chown -R root:root /var/run/postgresql

This error is all about you DB not OpenProject.

Edited by knex666
Link to post
  • 1 month later...

Hello, I tried to use your UNRAID docker image and I get this:

 

-----> Starting the all-in-one OpenProject setup at /app/docker/supervisord...
-----> Database cluster not found. Creating a new one in /var/openproject/pgdata...
The files belonging to this database system will be owned by user "postgres".
This user must also own the server process.

The database cluster will be initialized with locale "C.UTF-8".
The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory /var/openproject/pgdata ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
selecting default timezone ... America/Los_Angeles
selecting dynamic shared memory implementation ... posix
creating configuration files ... ok
LOG: could not link file "pg_xlog/xlogtemp.35" to "pg_xlog/000000010000000000000001": Function not implemented
FATAL: could not open file "pg_xlog/000000010000000000000001": No such file or directory
child process exited with exit code 1
initdb: removing contents of data directory "/var/openproject/pgdata"
running bootstrap script ...

 

Can you tell me where I should search before asking you guys :P Thank you!

Link to post

I am sorry to ask again... But I looked hard in the forums and could not find the exact source of the issue..
Some are talking about file permission, but nothing really comprehensible.

When you launch an instance yourself, do you let it create it's own DB or do you connect it to an existing one?

 

Edited by Normand_Nadon
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.