"setuser: user plex not found"


asmithphd

Recommended Posts

I'm having issues with PlexMediaServer on Unraid following an update.  I just used the unraid webgui to do the update.  I didn't notice any error during this process.  It now says "up to date" under version.  This is what the log looks like for PlexMediaServer now:

 

Feb 16 15:42:00 Tower cron[21]: (CRON) INFO (pidfile fd = 3)
Feb 16 15:42:00 Tower cron[21]: (CRON) INFO (Skipping @reboot jobs -- not system startup)
setuser: user plex not found
setuser: user plex not found

(repeats indefinitely)

 

Also, plex can no longer see my tower so I have no access to my media.  Any advice would be appreciated as I could find my little info on this error.  

Link to comment
1 hour ago, asmithphd said:

I have stopped and restarted the container.  I have also stopped and restarted the server.  Same outcome. 

I am experiencing the exact same behavior post-update. I am unable to connect to the webgui. Docker image:

limetech/plex       latest              720e7c5ffd7b        3 hours ago         576MB

 

Link to comment

i have the same issue after the upgrade...now plex container failed to start....

 

ErrorWarningSystemArrayLogin


*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/10_syslog-ng.init...
Feb 16 20:04:01 znas syslog-ng[11]: syslog-ng starting up; version='3.5.6'
Feb 16 20:04:02 znas syslog-ng[11]: EOF on control channel, closing connection;
*** Running /etc/rc.local...
*** Booting runit daemon...
*** Runit started as PID 17
Feb 16 20:04:02 znas cron[22]: (CRON) INFO (pidfile fd = 3)
Feb 16 20:04:02 znas cron[22]: (CRON) INFO (Running @reboot jobs)
setuser: user plex not found
setuser: user plex not found
setuser: user plex not found
setuser: user plex not found
 

Link to comment
4 minutes ago, itsm00ps said:

I am experiencing the exact same behavior post-update. I am unable to connect to the webgui. Docker image:


limetech/plex       latest              720e7c5ffd7b        3 hours ago         576MB

 

The only person in the thread who even told us which plex container they are using, and they are using the deprecated and no longer supported limetech plex.

Link to comment
21 minutes ago, trurl said:

The only person in the thread who even told us which plex container they are using, and they are using the deprecated and no longer supported limetech plex.

No offense, but I think this was the part where you could've offered some advice on which image we should be using, as we all apparently didn't get the memo.

FWIW, logging into the running container and doing 'useradd plex' resolved the issue for me, temporarily at least

UPDATE: I don't recall any warning about the deprecation, but apparently others did receive one:

 

Edited by itsm00ps
additional info
  • Thanks 1
Link to comment
1 hour ago, itsm00ps said:

but I think this was the part where you could've offered some advice on which image we should be using, as we all apparently didn't get the memo.

I'm quite sure that @trurl didn't mean anything by that.  But, in cases such as this switching apps will always be the first answer.  The "memo" does go out via Fix Common Problems,  (and in the applicable support thread), but admittedly not everyone has that plugin installed.

Link to comment
8 hours ago, trurl said:

You can go directly to the correct support thread for any of your dockers by simply clicking on its icon in the Unraid webUI and selecting Support.

 

Fix Common Problems plugin would have warned you about the deprecated container, and probably some other things as well.

@trurl

I just installed the FCP plugin. Thanks for the tip. But I still question why my Unraid server would prompt me to update a limetech/plex docker image that is deprecated and no longer supported by limetech, not to mention an image that is actually broken for existing limetech/plex users. Admittedly, I'm an Unraid noob, but we all forked out money for Unraid for a reason, rather than going with free options. Not asking for perfect software by any means, but would be nice to get support from this channel rather than "simply" criticism.

 

Edit: After re-reading, I want to add that I regret the negative vibe I've put forward here. No ill will towards Unraid/limetech nor @trurl whatsoever. I freaking LOVE my Unraid server overall. I know what it's like dealing with noob users of software that I've created. I always think they're dumb ;) I get it

Edited by itsm00ps
Link to comment

I too updated my limetech Plex docker this morning and it first wouldn’t start, then started but was broken with the “setuser: user plex not found” error repeating in the log.

 

After reading this thread I decided to install the “Fix Common Problems” plugin per one of the comments. It produces this message:

 

"PlexMediaServer (limetech/plex:latest) has the following comments: Deprecated in favour of one of the other Plex containers (linuxserver, binhex, or the official Plex container). This does not mean that you have to switch to another version of Plex. Only new installations of this version are blocked. This application has been deprecated from Community Applications for that reason. While still functional, it is no longer recommended to utilize it."

 

The part that caught my eye was:

 

“Only new installations of this version are blocked.”

 

Why is any Unraid user seeing docker updates for this container? Shouldn't that all stop if it's deprecated?

 

Thank you SpaceInvader for the pointer to the video. I guess I have something to do today.

Link to comment

Thx to all who responded.  I was impatient and figured out that the version of PMS that I was using was deprecated.  Not realizing that I could download a new version and point to my old database (per instructions posted above), I deleted my database and had to rescan all libraries.  It was a PITA.  Highly recommend following instructions, updating to non deprecated PMS and point to your old database so you don't have to go through fixing matches again (like I'm doing now).  Regardless, my problem is fixed.

Link to comment
  • 2 weeks later...
On 2/17/2020 at 6:01 AM, asmithphd said:

I'm having issues with PlexMediaServer on Unraid following an update.  I just used the unraid webgui to do the update.  I didn't notice any error during this process.  It now says "up to date" under version.  This is what the log looks like for PlexMediaServer now:

 

Feb 16 15:42:00 Tower cron[21]: (CRON) INFO (pidfile fd = 3)
Feb 16 15:42:00 Tower cron[21]: (CRON) INFO (Skipping @reboot jobs -- not system startup)
setuser: user plex not found
setuser: user plex not found

(repeats indefinitely)

 

Also, plex can no longer see my tower so I have no access to my media.  Any advice would be appreciated as I could find my little info on this error.  

Got this issue after update also, I ended up changing to the "Official Plex Repository" https://rawgit.com/Squidly271/AppsThread/master/forumpost0.html

 

Copied URL and Repository Name details to the broken/same plex docker container and I was back up and running in minutes...

 

Repository:    
plexinc/pms-docker
Docker Hub URL:    
https://hub.docker.com/r/plexinc/pms-docker/
Icon URL:    
https://raw.githubusercontent.com/plexinc/pms-docker/master/img/plex-server.png
WebUI:    
http://[IP]:[PORT:32400]/web

 

Link to comment
4 minutes ago, Squid said:

I sincerely hope that you're not regularly using that thread / post to look for any apps.  It's a legacy thread that I only update on the rare occasions that it pops into my head, and doesn't take into account moderation, errors, blacklisting, etc.  Use CA

Ok, it's like the first link on the "Community Applications"

 

"Note: To view the application lists before installing unRaid, click HERE"

 

Just saying...

Link to comment
4 minutes ago, cyrix253 said:

Ok, it's like the first link on the "Community Applications"

 

"Note: To view the application lists before installing unRaid, click HERE"

 

Just saying...

And that post says

 

Quote

Why are you looking at this thread?  Save yourself a ton of aggravation and install Community Applications.  I'll pay $$ to anyone who has a valid reason to NOT install it

 

If you already are running unRaid, then there is ZERO reason to ever look at this thread.  Install Community Applications and be done with it.  

and the actual list is prefaced with

Quote

The best way to install applications on unRaid is with the Community Applications plugin
Note that this list is a raw output. Community Applications moderates the entries so that any incompatible / non-functional apps will not appear (and it looks a lot better also

 

If I could convince the limetech gods to un-sticky that thread, I would delete it in a heartbeat.  (Thus far no one has ever come up with a reason to not have CA installed)

Link to comment
  • 2 weeks later...

Thanks everyone!  I updated, and then went to watch a show and no plex server!  Argh!

I have to admit I'm slack these days at updating (too many projects on the go like 3D printing and Christmas light displays) so this saved me a ton of fiddling.  Also discovered a great new app on that youtube video for moving files., Krusader!  That made the task a lot easier! :)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.