Jump to content
Sign in to follow this  
bobbintb

Two disks started in error state

6 posts in this topic Last Reply

Recommended Posts

My machine was becoming unresponsive so I did a reboot. It was a safe reboot, didn't have to force anything to shutdown, although it did take a while. When it came back up, a parity disk and an array disk were in error state. There doesn't seem to be any obvious reason though. No read or write errors, no SMART issues. I've attached my diagnostics. Any idea what happened? I'm just worried about re-adding them.

 

tower-diagnostics-20200217-0345.zip

Edited by bobbintb

Share this post


Link to post

Disk got disabled before this last boot, likely during previous shutdown, but it does look healthy so you can rebuild on top, good idea to replace/swap cables to rule them out in case it happens again to the same disk.

Share this post


Link to post
2 minutes ago, johnnie.black said:

Disk got disabled before this last boot, likely during previous shutdown, but it does look healthy so you can rebuild on top, good idea to replace/swap cables to rule them out in case it happens again to the same disk.

Is it going to start a parity rebuild if I do that? I'm worried about the array being unprotected.

Edited by bobbintb

Share this post


Link to post
2 minutes ago, bobbintb said:

Is it going to start a parity check if I do that?

I have not checked but from your comments I assume you had dual parity which means 2 disabled drives can be rebuilt.

 

As one of the failed disk is a parity disk, then the parity on it will need to be rebuilt when you re-enable the drive, but this can happen in parallel to rebuilding the disabled data drive.

Share this post


Link to post

Yes, I forgot to mention parity, it can be synced at the same time, and yes array will be unprotected during the rebuild. 

 

Also a good idea to update the LSI firmware since it's using a very old one.

Share this post


Link to post
9 hours ago, johnnie.black said:

Yes, I forgot to mention parity, it can be synced at the same time, and yes array will be unprotected during the rebuild. 

 

Also a good idea to update the LSI firmware since it's using a very old one.

Hadn't noticed it was outdated, thanks. Although, every time I make a change to this server it goes to shit and I spend days fixing things so maybe I won't. I probably am long overdue for an upgrade TBH.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this