Jump to content
malvarez00

[SUPPORT] malvarez00 - HOOBS

28 posts in this topic Last Reply

Recommended Posts

just installed this to use it instead of homebridge , installed Homeseer plugin but I'm getting this error : 

 

How do I update my node version inside the docker ?

 

Unexpected token =
Unable to determine plugin type for "homebridge-homeseer4"
[Homebridge] [2/29/2020, 12:05:45 AM] Loaded config.json with 0 accessories and 3 platforms.
[Homebridge] [2/29/2020, 12:05:46 AM] Loaded plugin: "homebridge-harmony"
[Homebridge] [2/29/2020, 12:05:46 AM] Registering platform "homebridge-harmonyHub.HarmonyHubWebSocket"
[Homebridge] [2/29/2020, 12:05:46 AM] Plugin /hoobs/node_modules/homebridge-homeseer4 requires Node version of >=12.0.0 which does not satisfy the current Node version of v10.18.0. You may need to upgrade your installation of Node.

[Homebridge] [2/29/2020, 12:05:46 AM] Error Loading Plugin "homebridge-homeseer4"

[Homebridge] [2/29/2020, 12:05:46 AM] Loaded plugin: "homebridge-yeelight-wifi"
[Homebridge] [2/29/2020, 12:05:46 AM] Registering platform "homebridge-yeelight.yeelight"
[Homebridge] [2/29/2020, 12:05:46 AM] Loading 3 platforms...
[Homebridge] [2/29/2020, 12:05:46 AM] [yeelight] Initializing yeelight platform...
[Homebridge] [2/29/2020, 12:05:46 AM] Error: The requested platform 'HomeSeer' was not registered by any plugin.

at API.platform (/hoobs/node_modules/@hoobs/homebridge/lib/api.js:115:19)
at Server._loadPlatforms (/hoobs/node_modules/@hoobs/homebridge/lib/server.js:283:47)
at Server.run (/hoobs/node_modules/@hoobs/homebridge/lib/server.js:74:14)
at module.exports (/hoobs/node_modules/@hoobs/homebridge/lib/cli.js:90:12)
at Object.<anonymous> (/hoobs/node_modules/@hoobs/homebridge/bin/homebridge:10:63)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)
at Function.Module.runMain (internal/modules/cjs/loader.js:831:12)
at startup (internal/bootstrap/node.js:283:19)
at bootstrapNodeJSCore (internal/bootstrap/node.js:623:3)
[Homebridge] [2/29/2020, 12:05:46 AM] Got SIGTERM, shutting down service...

 

Share this post


Link to post
Posted (edited)

Are there specific network requirements for this? I got the docker all set up but whenever I scan the QR code I get "Accessory not found" after it tries for awhile. I've already forwarded all the ports on my router.

Edited by halorrr

Share this post


Link to post
On 3/2/2020 at 7:03 AM, halorrr said:

Are there specific network requirements for this? I got the docker all set up but whenever I scan the QR code I get "Accessory not found" after it tries for awhile. I've already forwarded all the ports on my router.

Looks like it yes. I had the same issue till I Gave the docker container it’s own IP and it worked then

Share this post


Link to post

I ran into the same issue and assigning its own IP worked as well, but now I can't easily log the webgui from the docker page. Bummer

Share this post


Link to post
9 minutes ago, DisposableHero said:

I ran into the same issue and assigning its own IP worked as well, but now I can't easily log the webgui from the docker page. Bummer

Pretty sure if you edit the container and access the advanced settings, you can change the webgui URL to your liking.

Share this post


Link to post

Its a typo in the template  should be [IP]:[PORT:8080]

Share this post


Link to post

Am I doing something wrong still here? I tried assigning it an IP. But when I do, it seems to think there are no longer any port mappings? And it still doesn't work when I try using the code. The WebUI option on the docker also disappears (even with fixing the typo in the template)

 

 

Cerberus:UpdateContainer 2020-03-04 21-42-56.jpg

Cerberus:Docker 2020-03-04 21-41-44.jpg

Cerberus:Docker 2020-03-04 21-45-11.jpg

Share this post


Link to post
Am I doing something wrong still here? I tried assigning it an IP. But when I do, it seems to think there are no longer any port mappings? And it still doesn't work when I try using the code. The WebUI option on the docker also disappears (even with fixing the typo in the template)
 
 
255686287_CerberusUpdateContainer2020-03-0421-42-56.thumb.jpg.f0f7dab487c533631af0ea6b77130cd8.jpg
301628273_CerberusDocker2020-03-0421-41-44.jpg.e597e7ff09fc5441b438da45a6397fc9.jpg
1441045238_CerberusDocker2020-03-0421-45-11.jpg.635cc8f85fd8bcdbd023d3e9e550bb12.jpg

Are you connecting via the new IP:8080? Not the port in the docket configuration.


Sent from my iPhone using Tapatalk

Share this post


Link to post

Yup I can get into the interface if I manually type out the IP and port number, still no better luck with the "Accessory not found" error though.

Share this post


Link to post
Yup I can get into the interface if I manually type out the IP and port number, still no better luck with the "Accessory not found" error though.

Try changing the MAC


Sent from my iPhone using Tapatalk

Share this post


Link to post
Posted (edited)
On 3/5/2020 at 1:49 AM, DisposableHero said:


Try changing the MAC
 

That didn't work but I got a new router today and it magically works, so I guess something was set wrong in the old one.

Edited by halorrr

Share this post


Link to post

Helloo,

 

Have recently moved from a Raspberry Pi running Hoobs to this Docker and when installing homebridge-dacp, I am greeted by the following error:

Cannot find module '../build/Release/dns_sd_bindings'
Require stack:
- /hoobs/node_modules/mdns/lib/dns_sd.js
- /hoobs/node_modules/mdns/lib/mdns.js
- /hoobs/node_modules/homebridge-dacp/src/dacp/DacpBrowser.js
- /hoobs/node_modules/homebridge-dacp/src/index.js
- /hoobs/lib/plugins.js
- /hoobs/lib/controllers/system.js
- /hoobs/lib/api.js
- /hoobs/lib/cli.js
- /usr/src/hoobs/scripts/docker.js
- /usr/src/hoobs/bin/hoobs
Unable to determine plugin type for "homebridge-dacp"

I believe this is due to the plugin missing some dependencies but am not 100%, any help would be much appreciated :)

Share this post


Link to post

Updated this the other day and didn't realize it completely broke my setup until I went to control something lol

 

Here is the error in the logs:

(node:1) UnhandledPromiseRejectionWarning: Error: Cannot find module 'inherits'
Require stack:
- /hoobs/node_modules/glob/glob.js
- /hoobs/lib/cli.js
- /usr/src/hoobs/scripts/docker.js
- /usr/src/hoobs/bin/hoobs
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:982:15)
at Function.Module._load (internal/modules/cjs/loader.js:864:27)
at Module.require (internal/modules/cjs/loader.js:1044:19)
at require (internal/modules/cjs/helpers.js:77:18)
at Object.<anonymous> (/hoobs/node_modules/glob/glob.js:47:16)
at Module._compile (internal/modules/cjs/loader.js:1158:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1178:10)
at Module.load (internal/modules/cjs/loader.js:1002:32)
at Function.Module._load (internal/modules/cjs/loader.js:901:14)
at Module.require (internal/modules/cjs/loader.js:1044:19)
(node:1) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
(node:1) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

 

Share this post


Link to post
5 hours ago, DisposableHero said:

Updated this the other day and didn't realize it completely broke my setup until I went to control something lol

 

Here is the error in the logs:


(node:1) UnhandledPromiseRejectionWarning: Error: Cannot find module 'inherits'
Require stack:
- /hoobs/node_modules/glob/glob.js
- /hoobs/lib/cli.js
- /usr/src/hoobs/scripts/docker.js
- /usr/src/hoobs/bin/hoobs
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:982:15)
at Function.Module._load (internal/modules/cjs/loader.js:864:27)
at Module.require (internal/modules/cjs/loader.js:1044:19)
at require (internal/modules/cjs/helpers.js:77:18)
at Object.<anonymous> (/hoobs/node_modules/glob/glob.js:47:16)
at Module._compile (internal/modules/cjs/loader.js:1158:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1178:10)
at Module.load (internal/modules/cjs/loader.js:1002:32)
at Function.Module._load (internal/modules/cjs/loader.js:901:14)
at Module.require (internal/modules/cjs/loader.js:1044:19)
(node:1) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
(node:1) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

 

I am currently having the same problem.

Share this post


Link to post
12 hours ago, TheNitram24 said:

Same here

And of course it looks like they don't keep older versions up on their docker hub page... so I guess we wait for a fix.

Share this post


Link to post

Hi there,

 

I am a little bit new at ssh but when I follow a tutorial about configuring a plugin I get stuck at changing the dir. Hope someone can help me out. ;)

 

When I use the telnet client in HOOBS and I want to change from '/hoobs/etc #' to '/hoobs' I get the following error:

 

sh: cd: can't cd to ~/.hoobs/: No such file or directory

 

I am simply using the command 'cd ~/.hoobs/' Does anyone know what I am doing wrong here?

 

Hope someone can help me out. 

Share this post


Link to post
On 4/16/2020 at 10:23 PM, TheNitram24 said:

Same here

 

On 4/16/2020 at 10:23 PM, TheNitram24 said:

Same here

 

On 4/16/2020 at 1:47 PM, DisposableHero said:

Updated this the other day and didn't realize it completely broke my setup until I went to control something lol

 

Here is the error in the logs:


(node:1) UnhandledPromiseRejectionWarning: Error: Cannot find module 'inherits'
Require stack:
- /hoobs/node_modules/glob/glob.js
- /hoobs/lib/cli.js
- /usr/src/hoobs/scripts/docker.js
- /usr/src/hoobs/bin/hoobs
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:982:15)
at Function.Module._load (internal/modules/cjs/loader.js:864:27)
at Module.require (internal/modules/cjs/loader.js:1044:19)
at require (internal/modules/cjs/helpers.js:77:18)
at Object.<anonymous> (/hoobs/node_modules/glob/glob.js:47:16)
at Module._compile (internal/modules/cjs/loader.js:1158:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:1178:10)
at Module.load (internal/modules/cjs/loader.js:1002:32)
at Function.Module._load (internal/modules/cjs/loader.js:901:14)
at Module.require (internal/modules/cjs/loader.js:1044:19)
(node:1) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 1)
(node:1) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

 

An update was released this morning.  Mine is working fine now.

 

Share this post


Link to post

Ran Hoobs for ages on a raspberry pi and wanting to set up the Hoobs docker.

 

Install goes fine and the docker is running according to the log and using the default homebridge and server ports in the config 51826 and 8282 but I cannot access the webui. I noticed that the container ports shown in the config are the standard homebridge ports. I've tried to change the ports to these container ports to no avail.

 

Am I doing something wrong?

 

 

hoobs docker no webui.png

log.png

Share this post


Link to post
On 5/19/2020 at 4:00 PM, davidkerr82 said:

Ran Hoobs for ages on a raspberry pi and wanting to set up the Hoobs docker.

 

Install goes fine and the docker is running according to the log and using the default homebridge and server ports in the config 51826 and 8282 but I cannot access the webui. I noticed that the container ports shown in the config are the standard homebridge ports. I've tried to change the ports to these container ports to no avail.

 

Am I doing something wrong?

 

 

hoobs docker no webui.png

log.png

 

Hi,

Same problem for me

 

A French user

Share this post


Link to post
On 5/24/2020 at 5:22 PM, dancue said:

Same issue here. Can't get to the web interface.

you cant get to the web interface because the default web port for the container is pointed at 8282 but the webserver is running on port 80.  Edit the server port setting to look like mine below. Thats how I fixed mine, seems to be a misconfiguration in the unraid docker template

 

image.thumb.png.382193447651ecc02c6529fd8e2751ad.png

Share this post


Link to post
Posted (edited)
On 6/8/2020 at 11:43 PM, flinte said:

you cant get to the web interface because the default web port for the container is pointed at 8282 but the webserver is running on port 80.  Edit the server port setting to look like mine below. Thats how I fixed mine, seems to be a misconfiguration in the unraid docker template

It wont let me change the container port like you were able to do.  Is there some advanced edit mode I need to be in?

Edited by Bondfire

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.