Windows issues with unRAID


RobJ

Recommended Posts

Just updated my PC to 20H2 and now I can't access my shares.  One unriad box is on a P2P 10gbe link, I thought that configuration was the issue, but my other unriad box which is connected normally through my router is also not connecting.  I don't see the registry setting found here: "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" so maybe Windows isn't suing that anymore.

 

EDIT: Bit of a false alarm, 1 restart fixed the normal 1gbe router shares, and a couple more restarts and reconfiguring the 10gbe settings in Windows fixed that.

 

EDIT 2: Been dealing with the issue all morning, issue sometimes only happened with 10gbe share, I uninstalled 20H2, that didn't work, then I uninstalled KB4586781 which had been installed at the same time as 20H2, and now everything works!

Edited by bobobeastie
more info
Link to comment
  • 3 weeks later...

I can't find this in regedit anymore:

Regedit Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Double-click AllowInsecureGuestAuth and change "Value data" from 0 to 1

Like that option is GONE from regedit now
The option is still there in local group policy editor though...(edited)

I tried uninstalling some of the latest windows security updates but the registry still doesn't have that entry there

Link to comment
On 11/29/2020 at 9:21 AM, Rollingsound514 said:

Ok, so despite PIA VPN client being set to allow LAN, it wasn't allowing connections to be made to network drives, go figure, so I turned it off, made the connection and then turned it back on again and the connection to the network drive seems to be maintained...

Thank you so much, my pause updates for 7 days just ran out and my computer updated this morning, had a bunch of red X's on my shares, one wasn't red and it was trying to connect for a minute, saw your post, disabled PIA, and it connected immediately, along with the ones that were red.  I think it might have been a long time before I thought of disabling PIA.

Link to comment
  • 4 weeks later...
On 7/25/2020 at 5:12 PM, DoleWhip said:

 

TL;DR: 

1. If Computer Configuration > Administrative Templates > Network > Lanman Workstation > Enable insecure guest logons shows "Enabled" but it isn't working, continue

2. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

3. Double-click on AllowInsecureGuestAuth

4. Under "Value data:", change it from 0 to 1 

 

Describing what I did troubleshooting-wise (not that it matters, but maybe it'll help someone):

 

I updated my Windows 10 Education to version 2004 yesterday and was no longer able to access my SMB shares (was working fine before Windows update).

 

I could see them, but double-clicking on my server name in Windows Explorer under Network gave me the generic can't access error. Luckily (because it helped me google my problem) I had pinned some folders in it, and trying to access those gave me the popup pictured in that preview/thread saying:

"You can't access this shared folder because your organization's security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network."

 

I was confused because my group policy under: 

Computer Configuration > Administrative Templates > Network > Lanman Workstation > Enable insecure guest logons

showed "Enabled". Toggling this back and forth and restarting my PC didn't fix anything.

 

My unRAID server SMB settings had enabled for workgroup, enable NetBIOS to yes, and enable WSD to yes. My workgroup under those SMB settings matched with my PC, I even retyped them in holding down shift to capitalize just in case. Local master was set to yes, and I also downloaded the Dynamix Local Master plugin to check for me and it verified that yes, my unRAID server was indeed the current local master. Still not working.

 

I added:

log level=2

syslog=3

to SMB Extras and saw in my syslog that my PC was trying to send my local user to access the SMB shares (which are set to public) with errors along the lines of:

FAILED with error NT_STATUS_NO_SUCH_USER, authoritative=1

and that I was trying to use SMBv2

 

In the end, I found the solution in the linked thread to do this:

 

1. Open the registry editor and go to Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

2. Double-click on AllowInsecureGuestAuth

3. Under "Value data:", change it from 0 to 1 

I have tried everything in this thread, yet my windows pc will not connect but my mac will......

Link to comment
17 minutes ago, grock900 said:

have tried everything in this thread, yet my windows pc will not connect but my mac will......

Did you try going to Control Panel  >>>  Network and Sharing Center.    Then look on left side of the panel for 'Change advance sharing settings'.   Under all three (Private, Guest or Public, All Networks) of the types of network change the options to always allow 'access'.  In the 'All Networks' section, be sure that you select 'Turn off password protected sharing'.

 

When I upgraded to 2004 (Winsdows 10 PRO), MS decided to change these settings for me!!!!

Link to comment
12 minutes ago, Frank1940 said:

Did you try going to Control Panel  >>>  Network and Sharing Center.    Then look on left side of the panel for 'Change advance sharing settings'.   Under all three (Private, Guest or Public, All Networks) of the types of network change the options to always allow 'access'.  In the 'All Networks' section, be sure that you select 'Turn off password protected sharing'.

 

When I upgraded to 2004 (Winsdows 10 PRO), MS decided to change these settings for me!!!!

Yes, i turned password protected off but still no luck, thank you for the reply! why would i be able to see the tower but not connect?

Link to comment
  • 3 weeks later...

I'm on Windows version 20H2 build 19042.746 and I have also spent hours on this.  I've tried every single suggestion in this thread (and others in the forum) and nothing works.  Like others have said, the registry settings also aren't even there now so that tip is now irrelevant.  I even tried to create a DWORD entry and gave it the appropriate value but still no go. 

Link to comment
1 hour ago, Hadrian_Aurelius said:

I'm on Windows version 20H2 build 19042.746 and I have also spent hours on this.  I've tried every single suggestion in this thread (and others in the forum) and nothing works.  Like others have said, the registry settings also aren't even there now so that tip is now irrelevant.  I even tried to create a DWORD entry and gave it the appropriate value but still no go. 

 

You are not the only one with this problem.  I have not seen a solution posted up on the forum yet. One thing which I would like to suggest is that you google the problem.  Suggested phase would be something like:      SMB/CIFS problems WIN 10 20H2   (You will get a lot of hits!!!)  IF you are getting an error message be sure to include that in your search.

 

You also  have to realize that there are many different favors of WIN 10 version 20H2 ---  Home, Pro, Educational, Enterprise.  And I may have missed some.  They are all a little bit different when you look under the 'hood'.  For example, I believe Home does not have the Edit Group Policy app.  Settings in the registry may differ depending on which one you have.  What works for one favor may not work for another. 

 

Now if you find a solution, PLEASE (pretty please) post back with what you found.  (I have actually locked my WIN 10 Pro to version 2004 until someone finds a solution...)

Link to comment
12 hours ago, Frank1940 said:

 

You are not the only one with this problem.  I have not seen a solution posted up on the forum yet. One thing which I would like to suggest is that you google the problem.  Suggested phase would be something like:      SMB/CIFS problems WIN 10 20H2   (You will get a lot of hits!!!)  IF you are getting an error message be sure to include that in your search.

 

You also  have to realize that there are many different favors of WIN 10 version 20H2 ---  Home, Pro, Educational, Enterprise.  And I may have missed some.  They are all a little bit different when you look under the 'hood'.  For example, I believe Home does not have the Edit Group Policy app.  Settings in the registry may differ depending on which one you have.  What works for one favor may not work for another. 

 

Now if you find a solution, PLEASE (pretty please) post back with what you found.  (I have actually locked my WIN 10 Pro to version 2004 until someone finds a solution...)

I also have several Win10 systems on my home network, and only have problems with my Win10 Pro clients (the rest are Win10 Home).  With Win10 Pro the only solution that works to allow File Manager access to my unraid server (either with server name or with IP address) is to create a User/Password combo on Unraid that matches my Win10 system, and then manually create those credentials in Windows Credential Manager.  Then I can connect like I always used to,

 

For some reason the tips to turn off password protected sharing, and allow SMB 1.0, and allow insecure guest no longer work with 20H2 without that account -- as far as I can determine!

  • Thanks 1
Link to comment
2 hours ago, pasgener said:

I also have several Win10 systems on my home network, and only have problems with my Win10 Pro clients (the rest are Win10 Home).  With Win10 Pro the only solution that works to allow File Manager access to my unraid server (either with server name or with IP address) is to create a User/Password combo on Unraid that matches my Win10 system, and then manually create those credentials in Windows Credential Manager.  Then I can connect like I always used to,

And I have nothing but Win 10 Pro PCs (4 of them) all on 20H2 and none of them have any problems at all accessing the unRAID server by name with nothing but guest access.  I have no users other than root on the unRAID server.

 

That's what makes this all so maddening.  It seems to be a total crap shoot and there is no solution that seems to always work reliably.

Link to comment
On 11/28/2020 at 11:32 PM, Rollingsound514 said:

I can't find this in regedit anymore:

Regedit Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Double-click AllowInsecureGuestAuth and change "Value data" from 0 to 1

Like that option is GONE from regedit now
The option is still there in local group policy editor though...(edited)

I tried uninstalling some of the latest windows security updates but the registry still doesn't have that entry there

 

7 hours ago, Hoopster said:

And I have nothing but Win 10 Pro PCs (4 of them) all on 20H2 and none of them have any problems at all accessing the unRAID server by name with nothing but guest access.  I have no users other than root on the unRAID server.

 

@Hoopster, could you please check and see if you have the Regedit

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

 setting in your setup(s) and what the setting is?

 

EDIT:  I suspect that the regedit key and the group policy edit key are both required for clients with the group policy editor included...

Edited by Frank1940
Link to comment
@Hoopster, could you please check and see if you have the Regedit
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

 setting in your setup(s) and what the setting is?
 
EDIT:  I suspect that the regedit key and the group policy edit key are both required for clients with the group policy editor included...


I’ll check them all when I can (not home now) but I know it exists on two machines as I added it about a year ago as that was the needed fix after some past Windows 10 update.

I have also disabled SMB 1.0 on them all and run WSD on the unRAID server.


Sent from my iPhone using Tapatalk
Link to comment
On 11/28/2020 at 11:32 PM, Rollingsound514 said:

I can't find this in regedit anymore:

Regedit Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Double-click AllowInsecureGuestAuth and change "Value data" from 0 to 1

Like that option is GONE from regedit now
The option is still there in local group policy editor though...(edited)

I tried uninstalling some of the latest windows security updates but the registry still doesn't have that entry there

 

Read this:

 

      https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/

 

Link to comment
4 hours ago, Frank1940 said:

 

could you please check and see if you have the Regedit


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

 setting in your setup(s) and what the setting is?

I have the EnableInsecureGuestAuth key on 3 of the 4 and it is set to 1. 

 

The one without the key can still access the server by name from Network in the File Manager.  The one way in which this PC is different is that I have drive mappings direct to several shares for my wife's convenience.

Link to comment
On 11/28/2020 at 11:32 PM, Rollingsound514 said:

I can't find this in regedit anymore:

Regedit Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

Double-click AllowInsecureGuestAuth and change "Value data" from 0 to 1

Like that option is GONE from regedit now
The option is still there in local group policy editor though...(edited)

I tried uninstalling some of the latest windows security updates but the registry still doesn't have that entry there

 Some points of observation on these two settings. 

 

1--  I am not sure how they interact---  Do both have to set to allow insecure guest access to a server or will only one allow it?  I tend to suspect that both are required for those 'favors' of WIN 10 that include the Policy Editor.

 

2-- As I understand it, the group policy editor is not a component of WIN 10 Home.

 

3-- Knowing a bit about configuration files (mostly Linux), there are a lot of settings that don't show up in the standard configuration files.  But all of these settings do have a default setting.  If a setting is not in the standard configuration file and the user wants to change from the default, he will have to add it to the file.  I suspect that the same is true for the Windows Registry File.

Link to comment
  • 3 weeks later...

Hey all, sorry to ask a noob question so bare with me.

My cousin provided me a nice server and my windows machine can’t connect to the server. I am able to access http:\\tower but when I click on the Tower icon in Network folder, it gives me the 0x80070035 error. I followed all the footsteps except deleting the MSlicensing folder(kind of feel weird deleting it)

Any thoughts please


Sent from my iPhone using Tapatalk

Link to comment
33 minutes ago, Gman4life said:

I am able to access http:\\tower

Do you mean  http://tower which provides access to the GUI

 

33 minutes ago, Gman4life said:

Any thoughts please

 

First, please provide the details of your Window 10 install--   example; WIN10 PRO v2004.   (You can type   winver    in the search in the lower left corner of the desktop to find this information.

 

Next tell us exactly which 'footsteps' you applied.  No point in us suggesting all of the things that you tried.   😇

Edited by Frank1940
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.