[Support] A75G Repo


324 posts in this topic Last Reply

Recommended Posts

4 hours ago, A75G said:

what i meant when i said "./archive (URL,FEED,BOOKMARK,FILE)"  is for example "./archive www.google.com" or "./archive /data/link.txt" for file you need to put it in the appdata

Aaaaaah! But that's something I might as well just put into the container's shell command prompt, right? No need to edit in and out post args, right?

 

My personal investigation is that with cleared args the container just stops... Isn't the whole point of such a container to also do pulls on demand? Ideally with a page where I just drop a URL?

 

Also, do you have any idea how smooth the transition to the v0.4 branch will be? I know the dev has been delaying the release of it outside of beta stage for a long while now, but the release is going to come around eventually, if the transition is rough, maybe it's better to start this docker on the unstable 0.4 in CA beta status and then just hang on tight until 0.4 final drops and reflect that change in removing the beta flag in the CA as well?

 

Sorry if the questions seem a bit silly, never really looked in the codebase for this project, I just know that I love the approach this application has over similar ones since it saves in many formats and even (will?) support dynamic content.

 


Oh and I have a second question! I am also trying to use your wallabag container, however the layout it completely borked. Maybe you can give me any pointers?

 

1933348568_Anmerkung2020-04-20102935.thumb.png.4110a99b145b05234c79338b7253e5d6.png

 

Cheers and thanks a lot for your work! :)

Edited by Glassed Silver
added screenshot
Link to post
  • Replies 323
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

It is not so complicated to get it up & running, you just need to know where to start   First thing you need to edit the homeserver.yaml located in /appdata/matrix   Locate

Info https://github.com/A75G/docker-templates/blob/master/README.md   Request Docker Template && Template Issues (Cant guarantee anything but will try my best) https:/

Each one of those should be a separate command: su - archivebox cd /data archivebox init archivebox manage createsuperuser   All done inside of docker console

Posted Images

41 minutes ago, Glassed Silver said:

Aaaaaah! But that's something I might as well just put into the container's shell command prompt, right? No need to edit in and out post args, right?

 

My personal investigation is that with cleared args the container just stops... Isn't the whole point of such a container to also do pulls on demand? Ideally with a page where I just drop a URL?

 

Also, do you have any idea how smooth the transition to the v0.4 branch will be? I know the dev has been delaying the release of it outside of beta stage for a long while now, but the release is going to come around eventually, if the transition is rough, maybe it's better to start this docker on the unstable 0.4 in CA beta status and then just hang on tight until 0.4 final drops and reflect that change in removing the beta flag in the CA as well?

 

Sorry if the questions seem a bit silly, never really looked in the codebase for this project, I just know that I love the approach this application has over similar ones since it saves in many formats and even (will?) support dynamic content.

 


Oh and I have a second question! I am also trying to use your wallabag container, however the layout it completely borked. Maybe you can give me any pointers?

 

 

Cheers and thanks a lot for your work! :)

 

Quote

Aaaaaah! But that's something I might as well just put into the container's shell command prompt, right? No need to edit in and out post args, right?

Yeah

 

Quote

Isn't the whole point of such a container to also do pulls on demand? Ideally with a page where I just drop a URL?

Yea, you can ran it with cron what i do is put links on file inside the app folder it run weekly and it save it to way back machine too.

 

Quote

wallabag issue:

https://github.com/A75G/docker-templates/blob/master/README.md#missing-texture-and-images

 

 

Link to post
32 minutes ago, A75G said:

 

Yeah

 

Yea, you can ran it with cron what i do is put links on file inside the app folder it run weekly and it save it to way back machine too.

 

https://github.com/A75G/docker-templates/blob/master/README.md#missing-texture-and-images

 

 

Thanks a bunch! I fixed my wallabag and now am looking into getting my Firefox history (from a Windows desktop, mind you) to automatically get scraped. The instructions on the project's github page seem to assume you run ArchiveBox on a Linux desktop on which the installation of Firefox is running. That clearly isn't the case though here. :P

 

Would love to do several automatic scrapes with cron jobs.

 

a) a defined watched.txt with manual entries. Already set that up, easy!

b) an automatically syncing history and bookmarks file of Firefox and maybe even Chrome. (I only use Chrome occasionally, but hey, whilst I'm at it...)

c) constantly watching a Pocket/Wallabag list.

d) maybe more? Curious to maybe throw huginn into the mix to even backup sites that are possibly interesting and that may be pulled. Fan games for example. (notorious example: Nintendo-based fan games...)

 

Really stoked to jump into a whole new dimension of independence! :D

 

I take you not replying to the transition to v0.4 as a positive sign? As in, it won't affect us? Either way, better to start archiving now than later. Even if there is structural breaking change I guess.

 

Again, thanks so much for offering this container. I requested it on the CA wishlist github repo and here we are, a few weeks later with a working solution! :)

Link to post
2 minutes ago, Glassed Silver said:

Thanks a bunch! I fixed my wallabag and now am looking into getting my Firefox history (from a Windows desktop, mind you) to automatically get scraped. The instructions on the project's github page seem to assume you run ArchiveBox on a Linux desktop on which the installation of Firefox is running. That clearly isn't the case though here. :P

 

Would love to do several automatic scrapes with cron jobs.

 

a) a defined watched.txt with manual entries. Already set that up, easy!

b) an automatically syncing history and bookmarks file of Firefox and maybe even Chrome. (I only use Chrome occasionally, but hey, whilst I'm at it...)

c) constantly watching a Pocket/Wallabag list.

d) maybe more? Curious to maybe throw huginn into the mix to even backup sites that are possibly interesting and that may be pulled. Fan games for example. (notorious example: Nintendo-based fan games...)

 

Really stoked to jump into a whole new dimension of independence! :D

 

I take you not replying to the transition to v0.4 as a positive sign? As in, it won't affect us? Either way, better to start archiving now than later. Even if there is structural breaking change I guess.

 

Again, thanks so much for offering this container. I requested it on the CA wishlist github repo and here we are, a few weeks later with a working solution! :)

until v0.4 release ill see what i can change to the template because right now there is no tag for it https://hub.docker.com/r/nikisweeting/archivebox/tags

and im no developer only template guy :P

Link to post
51 minutes ago, A75G said:

until v0.4 release ill see what i can change to the template because right now there is no tag for it https://hub.docker.com/r/nikisweeting/archivebox/tags

and im no developer only template guy :P

I didn't assume you were the developer, but I am particularly fond that you created this CA anyhow. :)

 

Having said that, still would love to know if the different formats that ArchiveBox is supposed to generate are generated ok on your end?

All the format flags in the template are set to true, so that can't be it. But PDF, screenshot and output.html aren't being generated. (well actually output.html is generated, it's just a 0kb file, the rest isn't even an empty file on disk)

 

I'll merrily look into this when I have more time on the github of the project, however since we have the same setup kinda I thought I might ask here first.

Link to post
On 4/1/2020 at 1:21 PM, PSYCHOPATHiO said:

It is not so complicated to get it up & running, you just need to know where to start

 

First thing you need to edit the homeserver.yaml located in /appdata/matrix

 

Locate


- port: 8008
    tls: false
    type: http
    x_forwarded: true
    bind_addresses: ['::1', '127.0.0.1'] 

Change the bind address to your docker IP address or to 0.0.0.0, otherwise you wont be able to connect.

 

Then start the docker, head to console & insert the following:


cat /dev/urandom | tr -dc 'a-zA-Z0-9' | fold -w 32 | head -n 1

Copy the result & back to homeserver.yaml locate these 2 lines


enable_registration: False <-- True if you want users to register
registration_shared_secret: "past the code here"

apparently in the docker the registration shared secret is already generated but I advise you use your own.

 

You can add your own ReCAPTCHA & TUEN_uri server settings to the homeserver.yaml.

just restart the matrix docker & redirect your reverse proxy to the IP & port, you can test it https://riot.im/app

 

To register an admin account:


register_new_matrix_user -c /data/homeserver.yaml http://0.0.0.0:8008

This can be HTTPS 8448 if you have the certs installed

 

There is one more step that involves creating an SRV record in your DNS if you want to connect your server to the federation.

 

_matrix._tcp.matrix.example.com the wight and priority is your choice as for the port if your behind a reverse proxy you can go with 443.

 

Once the server up & running you can head back to homeserver.yaml read through the settings & adjust the server to what you need.

 

Thanks for the explanation, I've got my Matrix Synapse server running! Only problem I have is creating an admin account. When I use your code (or 0.0.0.0 adjusted to my matrix docker's IP) I get a console full of errors. Could you elaborate on this process and what I should fill in on the questions? It's a lot of connection refused error and now max retries errors. See below:

 

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/urllib3/connection.py", line 157, in _new_conn
    (self._dns_host, self.port), self.timeout, **extra_kw
  File "/usr/local/lib/python3.7/dist-packages/urllib3/util/connection.py", line 84, in create_connection
    raise err
  File "/usr/local/lib/python3.7/dist-packages/urllib3/util/connection.py", line 74, in create_connection
    sock.connect(sa)
ConnectionRefusedError: [Errno 111] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/urllib3/connectionpool.py", line 672, in urlopen
    chunked=chunked,
  File "/usr/local/lib/python3.7/dist-packages/urllib3/connectionpool.py", line 387, in _make_request
    conn.request(method, url, **httplib_request_kw)
  File "/usr/lib/python3.7/http/client.py", line 1244, in request
    self._send_request(method, url, body, headers, encode_chunked)
  File "/usr/lib/python3.7/http/client.py", line 1290, in _send_request
    self.endheaders(body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.7/http/client.py", line 1239, in endheaders
    self._send_output(message_body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.7/http/client.py", line 1026, in _send_output
    self.send(msg)
  File "/usr/lib/python3.7/http/client.py", line 966, in send
    self.connect()
  File "/usr/local/lib/python3.7/dist-packages/urllib3/connection.py", line 184, in connect
    conn = self._new_conn()
  File "/usr/local/lib/python3.7/dist-packages/urllib3/connection.py", line 169, in _new_conn
    self, "Failed to establish a new connection: %s" % e
urllib3.exceptions.NewConnectionError: <urllib3.connection.HTTPConnection object at 0x14bb337d2320>: Failed to establish a new connection: [Errno 111] Connection refused

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/requests/adapters.py", line 449, in send
    timeout=timeout
  File "/usr/local/lib/python3.7/dist-packages/urllib3/connectionpool.py", line 720, in urlopen
    method, url, error=e, _pool=self, _stacktrace=sys.exc_info()[2]
  File "/usr/local/lib/python3.7/dist-packages/urllib3/util/retry.py", line 436, in increment
    raise MaxRetryError(_pool, url, error or ResponseError(cause))
urllib3.exceptions.MaxRetryError: HTTPConnectionPool(host='0.0.0.0', port=8008): Max retries exceeded with url: /_matrix/client/r0/admin/register (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x14bb337d2320>: Failed to establish a new connection: [Errno 111] Connection refused'))

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/bin/register_new_matrix_user", line 22, in <module>
    main()
  File "/usr/local/lib/python3.7/dist-packages/synapse/_scripts/register_new_matrix_user.py", line 225, in main
    args.user, args.password, args.server_url, secret, admin, args.user_type
  File "/usr/local/lib/python3.7/dist-packages/synapse/_scripts/register_new_matrix_user.py", line 138, in register_new_user
    user, password, server_location, shared_secret, bool(admin), user_type
  File "/usr/local/lib/python3.7/dist-packages/synapse/_scripts/register_new_matrix_user.py", line 47, in request_registration
    r = requests.get(url, verify=False)
  File "/usr/local/lib/python3.7/dist-packages/requests/api.py", line 76, in get
    return request('get', url, params=params, **kwargs)
  File "/usr/local/lib/python3.7/dist-packages/requests/api.py", line 61, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/local/lib/python3.7/dist-packages/requests/sessions.py", line 530, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/local/lib/python3.7/dist-packages/requests/sessions.py", line 643, in send
    r = adapter.send(request, **kwargs)
  File "/usr/local/lib/python3.7/dist-packages/requests/adapters.py", line 516, in send
    raise ConnectionError(e, request=request)
requests.exceptions.ConnectionError: HTTPConnectionPool(host='0.0.0.0', port=8008): Max retries exceeded with url: /_matrix/client/r0/admin/register (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x14bb337d2320>: Failed to establish a new connection: [Errno 111] Connection refused'))

 

Link to post
44 minutes ago, Kaizac said:

0.0.0.0 adjusted to my matrix docker's IP

Just add the 0.0.0.0 remove the docker IP, for some reason it wont work with the docker IP.

Also when editing the homeserver.yaml make sure you save, restart & check after every small change you make as a space or a dot can break the server.

Link to post

Question about the Golinks docker

From what I can see, the run command is

golinks -bind 127.0.0.1:8000 -fqdn localhost:8000

Firefox on my local computer uses the FQDN address set to localhost:8000 which obviously won't work as Golinks is running on my Unraid server. Chrome used the IP address and worked as it should. Is it possible to have the FQDN configurable so I can use "unraidbox:8000"? Or use IP only?

 

Thanks!

Link to post
7 minutes ago, wazabees said:

Question about the Golinks docker

From what I can see, the run command is


golinks -bind 127.0.0.1:8000 -fqdn localhost:8000

Firefox on my local computer uses the FQDN address set to localhost:8000 which obviously won't work as Golinks is running on my Unraid server. Chrome used the IP address and worked as it should. Is it possible to have the FQDN configurable so I can use "unraidbox:8000"? Or use IP only?

 

Thanks!

if you have set FQDN for unraid then all you have is to put the FQDN:8000

for example my unraid is unraid.lan i can do unraid.lan:8000 or use IP which ever you like

Edited by A75G
Link to post
3 hours ago, wazabees said:

Question about the Golinks docker

From what I can see, the run command is


golinks -bind 127.0.0.1:8000 -fqdn localhost:8000

Firefox on my local computer uses the FQDN address set to localhost:8000 which obviously won't work as Golinks is running on my Unraid server. Chrome used the IP address and worked as it should. Is it possible to have the FQDN configurable so I can use "unraidbox:8000"? Or use IP only?

 

Thanks!

 

3 hours ago, A75G said:

if you have set FQDN for unraid then all you have is to put the FQDN:8000

for example my unraid is unraid.lan i can do unraid.lan:8000 or use IP which ever you like

Having same issue,

i can set search address inside of chrome (aka http://x.x.x.x:8000/?q=%s) but firefox has no option to manually set ip.

how do i change the run command for the container so it sets ip:8000 instead of localhost:8000?

Link to post
17 hours ago, wazabees said:

Question about the Golinks docker

From what I can see, the run command is


golinks -bind 127.0.0.1:8000 -fqdn localhost:8000

Firefox on my local computer uses the FQDN address set to localhost:8000 which obviously won't work as Golinks is running on my Unraid server. Chrome used the IP address and worked as it should. Is it possible to have the FQDN configurable so I can use "unraidbox:8000"? Or use IP only?

 

Thanks!

 

13 hours ago, Cion said:

Having same issue,

i can set search address inside of chrome (aka http://x.x.x.x:8000/?q=%s) but firefox has no option to manually set ip.

how do i change the run command for the container so it sets ip:8000 instead of localhost:8000?

I used this https://addons.mozilla.org/en-US/firefox/addon/add-custom-search-engine and it works check it out

 

4 hours ago, eds said:

Looks like @SpaceInvaderOne created a video on Jitsi and lo and behold I see you have a docker container already made @A75G.   

This should make trying that video conferencing app out much easier.  Thanks.

Do you know how taxing Jitsi is on server resources like cpu?

SpaceInvaderOne made it easier my template a bit of a mess

docker-compose usually for me is better because you have lot of moving parts between two or more dockers

I dont know how taxing Jitsi i never run it but heres what people say

https://community.jitsi.org/t/server-requirements-for-20-users-with-video/24865/2

 

Link to post
10 minutes ago, A75G said:

That's a great little addon! Thanks for the suggestion, it works for me.

 

Some more user customization would be fantastic. I don't know if it's feasible though?

 

Usage of ./golinks:
  -bind="0.0.0.0:8000": [int]:<port> to bind to
  -config="": config file
  -dbpath="search.db": database path
  -fqdn="localhost:8000": FQDN for public access
  -suggest="https://suggestqueries.google.com/complete/search?client=firefox&q=%s": default URL to retrieve search suggestions from
  -title="Search": OpenSearch title
  -url="https://www.google.com/search?q=%s&btnK": default URL to redirect to
  -v=false: display version information

The ability to set the -url option to something else would be nice. Some people, myself included, try to avoid Google. So the ability to change the default -url from Google to something like DuckDuckGo (https://duckduckgo.com/?q=%s) would be most welcome.

Link to post
4 hours ago, A75G said:

 

I used this https://addons.mozilla.org/en-US/firefox/addon/add-custom-search-engine and it works check it out

 

SpaceInvaderOne made it easier my template a bit of a mess

docker-compose usually for me is better because you have lot of moving parts between two or more dockers

I dont know how taxing Jitsi i never run it but heres what people say

https://community.jitsi.org/t/server-requirements-for-20-users-with-video/24865/2

 

Thanks for the link.  Wish some of the transcoding chores could be off loaded to a gpu. 

I'm going to give your dockers a shot.  The only problem I have with @SpaceInvaderOne approach is the lets encrypt config.  Since I use npm, I don't want to be bothered with setting up let's encrypt docker and configs if I can avoid it.   

We shall see. 

 

Link to post
4 hours ago, wazabees said:

That's a great little addon! Thanks for the suggestion, it works for me.

 

Some more user customization would be fantastic. I don't know if it's feasible though?

 


Usage of ./golinks:
  -bind="0.0.0.0:8000": [int]:<port> to bind to
  -config="": config file
  -dbpath="search.db": database path
  -fqdn="localhost:8000": FQDN for public access
  -suggest="https://suggestqueries.google.com/complete/search?client=firefox&q=%s": default URL to retrieve search suggestions from
  -title="Search": OpenSearch title
  -url="https://www.google.com/search?q=%s&btnK": default URL to redirect to
  -v=false: display version information

The ability to set the -url option to something else would be nice. Some people, myself included, try to avoid Google. So the ability to change the default -url from Google to something like DuckDuckGo (https://duckduckgo.com/?q=%s) would be most welcome.

you can change default add this on post command

-url="https://duckduckgo.com/?q=%s"

 

Link to post

Having an issue with port forwarding with Jitsi.

I am in host mode and everything appears to be forwarded correctly.

I have a container running on port 80/443, so I am mapping 443 to 5443 on jitsi. 

But everytime i use the webui, I'm getting the other container.

I am not sure what the issue is.   Any advice? 

 

 

Also, lets encrypt appears to be built into the docker  From what I can see if disable_https set to 0 it sets up let's encrypt for the first time to  download a new cert.  I would have expected enable_letsencrypt set to 1 to do that.  Is that to be expected?

 

 

Edited by eds
added question about lets encrypt.
Link to post

Need a little guidance on the freepbx install....

 

i cant get it to init.... any ideas?

 

Quote

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] 00-functions: applying...
[fix-attrs.d] 00-functions: exited 0.
[fix-attrs.d] 01-s6: applying...
[fix-attrs.d] 01-s6: exited 0.
[fix-attrs.d] 02-zabbix: applying...
[fix-attrs.d] 02-zabbix: exited 0.
[fix-attrs.d] 03-logrotate: applying...
[fix-attrs.d] 03-logrotate: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 00-startup: executing...
[cont-init.d] 00-startup: exited 0.
[cont-init.d] 01-timezone: executing...
[cont-init.d] 01-timezone: exited 0.
[cont-init.d] 02-permissions: executing...
[cont-init.d] 02-permissions: exited 0.
[cont-init.d] 03-cron: executing...
[cont-init.d] 03-cron: exited 0.
[cont-init.d] 03-zabbix: executing...
[cont-init.d] 03-zabbix: exited 0.
[cont-init.d] 04-cron: executing...
[cont-init.d] 04-cron: exited 0.
[cont-init.d] 05-fail2ban: executing...
[42m[INFO][49m ** [fail2ban] Starting Fail2ban
[cont-init.d] 05-fail2ban: exited 0.
[cont-init.d] 05-smtp: executing...
[100m[NOTICE][49m ** [smtp] Sendmail replaced and enabled to route mail to: 'postfix-relay'
[cont-init.d] 05-smtp: exited 0.
[cont-init.d] 08-mongodb: executing...
[cont-init.d] 08-mongodb: exited 0.
[cont-init.d] 09-mariadb: executing...
[cont-init.d] 09-mariadb: exited 0.
[cont-init.d] 10-freepbx: executing...
[100m[NOTICE][49m ** [freepbx] Creating Default Configuration Files
[100m[NOTICE][49m ** [freepbx] Setting File Permissions
[42m[INFO][49m ** [freepbx] New Install Detected - Please wait while we fetch FreePBX - Will take 3 to 30 minutes!
[100m[NOTICE][49m ** [freepbx] Starting Asterisk 17.2.0 for the first time
[100m[NOTICE][49m ** [freepbx] Installing FreePBX source code
[101m[ERROR][49m ** [freepbx] Can't seem to locate /usr/sbin/fwconsole.. Exitting
[cont-init.d] 10-freepbx: exited 1.
[cont-init.d] 99-container: executing...
**********************************************************************************************************************
**********************************************************************************************************************
**** ****
**** ERROR - Some initialization scripts haven't completed - All services are now halted ****
**** - The following scripts in '/etc/cont-init.d' did not pass their completion check ****
**** ****
**********************************************************************************************************************
**********************************************************************************************************************

10-freepbx

**********************************************************************************************************************
**********************************************************************************************************************
**** ****
**** This could have happened for a variety of reasons. Please make sure you have followed the README ****
**** relating to this image and have proper configuration such as environment variables and volumes set ****
**** ****
**** If you feel that you have encountered a bug, please submit an issue on the revision control system ****
**** and provide full debug logs by setting the environment variable 'DEBUG_MODE=TRUE' ****
**** ****
**********************************************************************************************************************
**********************************************************************************************************************
[cont-init.d] 99-container: exited 1.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

 

Link to post
10 hours ago, eds said:

Having an issue with port forwarding with Jitsi.

I am in host mode and everything appears to be forwarded correctly.

I have a container running on port 80/443, so I am mapping 443 to 5443 on jitsi. 

But everytime i use the webui, I'm getting the other container.

I am not sure what the issue is.   Any advice? 

 

 

Also, lets encrypt appears to be built into the docker  From what I can see if disable_https set to 0 it sets up let's encrypt for the first time to  download a new cert.  I would have expected enable_letsencrypt set to 1 to do that.  Is that to be expected?

 

 

jitsi need custom docker network to communicate between each other

if enable_letsencrypt 1 then disable_https 0

but better use reverse proxy

and remove lot variable thats not needed like ldap if ur not using it

7 hours ago, RSQtech said:

Need a little guidance on the freepbx install....

 

i cant get it to init.... any ideas?

 

 

maybe database issue enable embedded database and remove delete database configuration

ill update template so there so need for external database

Link to post
9 hours ago, A75G said:

jitsi need custom docker network to communicate between each other

if enable_letsencrypt 1 then disable_https 0

but better use reverse proxy

and remove lot variable thats not needed like ldap if ur not using it

 

Only dealing with jitsi web right now.  Do all the jitsi dockers need to be installed for jitsi web to install correctly?

Link to post

hello,

thanks for the netbox docker. I got one question, how do I change other settings in the netbox config file.

I tried making another variable via unraid gui with no luck. When editing directly via cli the configuration.py is always rewritten upon restart.

 

Link to post

I'm running into an issue with the jitsi containers. Coincidentally, I had setup the spaceinvader jitsi and then immediately found this. Because of the way unraid cannot manage the docker compose containers I wanted to setup the jitsi ones from CA, and because the spaceinvader guide worked well I basically followed those customizations on your containers.

 

Not many things needed to be changed. Jitsi web and jvb do have a port conflict. I changed jvb port 4443 to 8443, that's what it was when installing from jitsi's github, and that resolved the port conflict. However, I have another issue that I cannot get past and am wondering if you were able to get all four containers working together.

 

When starting jicofo it fails with the following error, "FATAL ERROR: Jicofo component secret must be changed, check the README." The container is then stopped. I am confused by this because I know that even on the jitsi readme it says the jicofo secret should not need to be changed. I decided to change it to another random six character string containing just lower case letters and numbers. I found all traces of this string and made sure they all matched, I still got the same error.

Edited by gRuNdLeKrEiSt
wording
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.